Forum Discussion

rklopsch's avatar
rklopsch
Level 3
10 years ago

B2D Folder can't be added

Dear ladies and gentlemen,

 

after an firmwareupdate of a Lenovo/EMC (Iomega) px4-300r NAS the B2D share isn't reachable even more.

I deleted the B2D Folder. Now I want to recreate it.

Error in BE Console: "The specified server can not perform the requested procedure"

Error in Debug Monitor:

PVLSVR:   [08.18.14 13:35:12] [0000]     08/18/14 13:35:11.912 PvlEntityDatabase::QueryEntity() : ERROR = 0xE0008120 (E_PVL_B2D_FOLDER_DOES_NOT_EXIST)
BESERVER: [08.18.14 13:35:12] [0000]     08/18/14 13:35:11 05 AdammAdminBO::Execute() - hr = 0xe0008120
BESERVER: [08.18.14 13:35:12] [0000]     08/18/14 13:35:11 05 AdammAdminBO::Insert() - Parent = MACHINE , Entity = BACKUP_TO_DISK
PVLSVR:   [08.18.14 13:35:12] [0000]     08/18/14 13:35:11.914 PvlEntityDatabase::CreateEntity()

            ParentEntityType = MACHINE_ENTITY_TYPE

            ParentEntityGuid = {00000000-0000-0000-0000-000000000000}

            EntityType = BACKUP_TO_DISK_ENTITY_TYPE

            BackupToDisk = {00000000-0000-0000-0000-000000000000}, "Backup-to-Disk-Ordner 0001"
BEREMOTE: [08.18.14 13:35:17] [0000]     08/18/14 13:35:17 [ndmp\ndmpsrvr]      - Freeing unsued COM libraries
PVLSVR:   [08.18.14 13:35:22] [0000]     08/18/14 13:35:22.059 PvlEntityDatabase::CreateEntity() : ERROR = 0x0000003A (58)

            BackupToDisk = {00000000-0000-0000-0000-000000000000}, "Backup-to-Disk-Ordner 0001"
PVLSVR:   [08.18.14 13:35:22] [0000]     08/18/14 13:35:22.059 PvlEntityDatabase::CreateEntity() : ERROR = 0x0000003A (58)
BESERVER: [08.18.14 13:35:22] [0000]     08/18/14 13:35:22 05 AdammAdminBO::Insert() - hr = 0x3a

System Eventlog:

- System

  - Provider

   [ Name]  Backup Exec
 
  - EventID 33808

   [ Qualifiers]  8192
 
   Level 2
 
   Task 0
 
   Keywords 0x80000000000000
 
  - TimeCreated

   [ SystemTime]  2014-08-18T11:35:22.000000000Z
 
   EventRecordID 317498
 
   Channel Application
 
   Computer xxx.xxx.local
 
   Security
 

- EventData

   Changer: LockAndRefreshChangerConfig() GetFileInformationByHandle failed. Error=58

 

Backup Exec 2010 R3. The NAS is member of the Domain. I can reach the NAS by using the Windows Explorer.

 

Sorry for the bad english. You can also answer in german.

 

Kindly regards,

Robert

9 Replies

  • I deleted the B2D Folder.

    Did you delete it from the Backup Exec UI or from the actual storage itself ? If from the UI, did you remove the changer.cfg and folder.cfg files from the actual storage also ?

    And what path are you specifyiny while creating the B2D ?

  • Hi,

    i deleted it from the Backup Exec UI. Yes I deleted the changer.cfg and folder.cfg form the share also.

    I also tested to add a new share on the NAS. Same error.

    Sharename is "Backup"

    Path: I tested \\IP-address\Backup and \\DNS-name\Backup 

    Same error.

     

    Kindly regards,

    Robert

     

     

     

  • Try running this tool - http://www.symantec.com/business/support/index?page=content&id=TECH69107

  • Is the user which you specified during the B2D test, the same user configured in Backup Exec ?

    Alternatively, are you able to add the NAS using the "root" user itself ?

    I guess this device is capable of iSCSI as well. Maybe you could consider adding the B2D using iSCSI.

  • Hi,

    the user I used during the B2D test is one of the User which has full access on the share on the NAS.

    This user is also the System Login Account in Backup Exec.

    What you mean with the "root" user? I only have a web GUI for the NAS. There I log in with domain credentials. iSCSI is an option, but only in the last step.

     

    best regards,

    Robert

  • By root, I meant the default Administrator user.

    Is the BE system logon account added as an Administrator in the NAS ? If yes, does this user have explicit full permissions over the share itself ?

    If it was working prior to the firmware upgrade, it could be an issue with the firmware itself. Was the share and user created prior to the firmware upgrade ? If yes, you could deleting them, recreate and check if you are able to configure the B2D or not.

  • Hi,

    yes the BE system login account is an Administrator in the NAS and yes this user has explicit full permissions over the share.

    Both, the share and the user were created prior firmwate updaten, but the NAS wasn`t member of the domain prior update. I tested a second share on the NAS and two other domain users. Still the same problem.

     

    best regards,

    Robert

  • I would then recommend to log a formal support case so that we can have a closer look @ the setup. Of course, alternative would be to use iSCSI.