Forum Discussion

Milan_Lesnik's avatar
17 years ago

BE7170 Hotfix 42 failed to install

Hello

I can't install hot fix 42 (backup exec 7170, sp2, x64) on one of my media server (MS WIN 2003 x64 EE sp2 installed patched with all fixes, SQL 2005 EE patched to sp2 and one hot fix after sp2 - version 9.00.3054.00 default instance, backup exec 7170 sp2 all hotfixes but hf42 and hf43 installed, options - sql agent, san storage, library expansion).
 
Here is windows installer log (only small part):

-------------------------
Action 12:37:52: MsiPublishAssemblies. Publishing assembly information
MSI (s) (A4:E0) [12:37:52:093]: Executing op: AssemblyUnpublish(Feature=BackupExec,Component={14C6FA38-02B5-4B8B-A8F1-2FA7B6BFA3BE},AssemblyType=1,,AssemblyName=crf,version="1.0.79.0",publicKeyToken="E7002583054F8181",processorArchitecture="MSIL",culture="neutral",)
MsiPublishAssemblies: Application Context:Global, Assembly Name:crf,version="1.0.79.0",publicKeyToken="E7002583054F8181",processorArchitecture="MSIL",culture="neutral"
MSI (s) (A4:E0) [12:37:52:093]: Executing op: AssemblyPublish(Feature=BackupExec,Component={14C6FA38-02B5-4B8B-A8F1-2FA7B6BFA3BE},AssemblyType=1,,AssemblyName=crf,version="1.0.79.0",publicKeyToken="E7002583054F8181",processorArchitecture="MSIL",culture="neutral",)
MsiPublishAssemblies: Application Context:Global, Assembly Name:crf,version="1.0.79.0",publicKeyToken="E7002583054F8181",processorArchitecture="MSIL",culture="neutral"
MSI (s) (A4:E0) [12:37:52:093]: Executing op: AssemblyUnpublish(Feature=BackupExec,Component={08DA865F-B509-40EF-872B-42C2FA1C4F82},AssemblyType=3,AppCtx=C:\Program Files\Symantec\Backup Exec\SPSManagedWrapperHelper.dll,AssemblyName=SPSManagedWrapperHelper,Version="1.0.20.0",FileVersion="1.0.20.0",Culture="neutral",)
MsiPublishAssemblies: Application Context:CProgram Files|Symantec|Backup Exec|SPSManagedWrapperHelper.dll, Assembly Name:SPSManagedWrapperHelper,Version="1.0.20.0",FileVersion="1.0.20.0",Culture="neutral"
MSI (s) (A4:E0) [12:37:52:093]: Note: 1: 1402 2: UNKNOWN\Installer\Assemblies\CProgram Files|Symantec|Backup Exec|SPSManagedWrapperHelper.dll 3: 2
MSI (s) (A4:E0) [12:37:52:093]: Note: 1: 1402 2: UNKNOWN\Installer\Assemblies\CProgram Files|Symantec|Backup Exec|SPSManagedWrapperHelper.dll 3: 2
MSI (s) (A4:E0) [12:37:52:093]: Executing op: AssemblyPublish(Feature=BackupExec,Component={08DA865F-B509-40EF-872B-42C2FA1C4F82},AssemblyType=3,AppCtx=C:\Program Files\Symantec\Backup Exec\SPSManagedWrapperHelper.dll,AssemblyName=SPSManagedWrapperHelper,Version="1.0.20.0",FileVersion="1.0.20.0",Culture="neutral",)
MsiPublishAssemblies: Application Context:CProgram Files|Symantec|Backup Exec|SPSManagedWrapperHelper.dll, Assembly Name:SPSManagedWrapperHelper,Version="1.0.20.0",FileVersion="1.0.20.0",Culture="neutral"
MSI (s) (A4:E0) [12:37:52:093]: Note: 1: 1402 2: UNKNOWN\Installer\Assemblies\CProgram Files|Symantec|Backup Exec|SPSManagedWrapperHelper.dll 3: 2
MSI (s) (A4:E0) [12:37:52:093]: Executing op: AssemblyUnpublish(Feature=BackupExec,Component={1B89D933-ED6A-417D-8281-C6CA401C3987},AssemblyType=3,AppCtx=C:\Program Files\Symantec\Backup Exec\SPSWrapperV3.exe,AssemblyName=SPSWrapperV3,Version="0.0.0.0",FileVersion="1.0.20.0",Culture="neutral",)
MsiPublishAssemblies: Application Context:CProgram Files|Symantec|Backup Exec|SPSWrapperV3.exe, Assembly Name:SPSWrapperV3,Version="0.0.0.0",FileVersion="1.0.20.0",Culture="neutral"
MSI (s) (A4:E0) [12:37:52:093]: Note: 1: 1402 2: UNKNOWN\Installer\Assemblies\CProgram Files|Symantec|Backup Exec|SPSWrapperV3.exe 3: 2
MSI (s) (A4:E0) [12:37:52:093]: Note: 1: 1402 2: UNKNOWN\Installer\Assemblies\CProgram Files|Symantec|Backup Exec|SPSWrapperV3.exe 3: 2
MSI (s) (A4:E0) [12:37:52:093]: Executing op: AssemblyPublish(Feature=BackupExec,Component={1B89D933-ED6A-417D-8281-C6CA401C3987},AssemblyType=3,AppCtx=C:\Program Files\Symantec\Backup Exec\SPSWrapperV3.exe,AssemblyName=SPSWrapperV3,Version="0.0.0.0",FileVersion="1.0.20.0",Culture="neutral",)
MsiPublishAssemblies: Application Context:CProgram Files|Symantec|Backup Exec|SPSWrapperV3.exe, Assembly Name:SPSWrapperV3,Version="0.0.0.0",FileVersion="1.0.20.0",Culture="neutral"
MSI (s) (A4:E0) [12:37:52:093]: Note: 1: 1402 2: UNKNOWN\Installer\Assemblies\CProgram Files|Symantec|Backup Exec|SPSWrapperV3.exe 3: 2
MSI (s) (A4:E0) [12:37:52:093]: Executing op: ActionStart(Name=ConfigInstall,Description=Configuring Symantec Backup Exec.  Please wait...,)
Action 12:37:52: ConfigInstall. Configuring Symantec Backup Exec.  Please wait...
MSI (s) (A4:E0) [12:37:52:109]: Executing op: CustomActionSchedule(Action=ConfigInstall,ActionType=17409,Source=BinaryData,Target=ConfigInstall_MSI,CustomActionData=TOKEN-INSTALLDIR:C:\Program Files\Symantec\Backup Exec\ TOKEN-SVCNAME:realusername TOKEN-SVCPSWD:realplainpassword TOKEN-SVCDOM:realdomain TOKEN-BE:1 TOKEN-RA:0 TOKEN-TAPEDEV:0 TOKEN-AUTOLDR:1 TOKEN-IDR:0 TOKEN-VSP:0 TOKEN-TSM:0 TOKEN-SSO:1 TOKEN-DLOSVC:0 TOKEN-DLOCLIENT:0 TOKEN-5USERDLOSVC:0 TOKEN-5USERDLOCLIENT:0 TOKEN-TSMSERVER:xxx.xxx.xxx.xxx TOKEN-TSMPORT:1500 TOKEN-SSOPRIMARY:2 TOKEN-SSODATA:realprimary TOKEN-SSOSTATE:0 TOKEN-BEUIMODE:1 TOKEN-ADAMMLOCAL: TOKEN-PATCH:1 TOKEN-PATCHCODE: TOKEN-8XUPG:0 TOKEN-9XUPG:0 TOKEN-PUSHBE:0 TOKEN-CASO:0 TOKEN-MMS:0)
MSI (s) (A4:E0) [12:37:52:171]: Creating MSIHANDLE (6778) of type 790536 for thread 1760
MSI (s) (A4:78) [12:37:52:171]: Invoking remote custom action. DLL: C:\WINDOWS\Installer\MSI11B.tmp, Entrypoint: ConfigInstall_MSI
MSI (s) (A4!00) [12:37:52:202]: Creating MSIHANDLE (6779) of type 790531 for thread 2304
DISABLECANCEL
MSI (s) (A4!00) [12:37:52:202]: Closing MSIHANDLE (6779) of type 790531 for thread 2304
MSI (s) (A4:78) [12:38:50:900]: Closing MSIHANDLE (6778) of type 790536 for thread 1760
Action ended 12:38:50: InstallFinalize. Return value 3.
----------------------------------------------------------------

We don't have Share Point servers http://seer.entsupport.symantec.com/docs/300675.htm so this cookbook recipe doesn't work: https://forums.symantec.com/syment/board/message?board.id=be12_sharepoint&message.id=40

I think this could be somehow related: http://support.microsoft.com/kb/915854. On this server I have default instance (2005 EE) and backup exec instance installed.

On this media (and only on this) server I observe the following weird problem. I start backup exec then click restore tab and then I've to wait more than 30 minutes to see selections (catalogs).

BTW: log file contains real username and PLAIN password - so one must delete log file immediately after the problem is solved.

Regards, Milan

1 Reply

  • Hello

    Both issues are solved (thanks to mr. Mark Russinovich's procmon.exe). It was (perhaps) sql lookup problem.

    Modify values TcpDynamicPorts and TcpPort under HKLM\Software\Microsoft\Microsoft SQL Server\BKUPEXEC\MSSQLServer\SuperSocketNetLib\TCP.

    Regards, Milan