Forum Discussion

systematic92's avatar
10 years ago

Help with NDMP Exclusions (NetApp)

Hi Guys,

 
The following path contains 1000's of user folders on the SAN:
 
//GUINNESS-FAS02:10000/vol/PROD_FILE1_DATA_02_CIFS/Q_userhome/
 
The top-level 'Userhome' directory is selected, which in turn selects all the folders within it (all 3000 of them)
 
How do I use the EXCLUDE function please? I would like to exclude all folders that begin with 'A'.
 
Before you answer, perhaps the following info will help.  
 
I was able to work out how to use the INCLUDE function. This include basically means nothing is selected under the top-level folder of 'Userhome'. I then specified the following settings using the 'include/exclude' option in BEXEC:
 
NDMP
NETAPP/IBM/FUJITSU
INCLUDE
Resource Selection Path =   //GUINNESS-FAS02:10000/vol/PROD_FILE1_DATA_02_CIFS/Q_userhome/A*/
 
This path now selects and INCLUDES every folder under 'userhome' beginning with the letter 'A'.
 
The problem is that when you run the job it goes from pre-processing to running and fails with:
 
NDMP Log Message: DUMP: Dumping /vol/PROD_FILE1_DATA_02_CIFS to NDMP connection
NDMP Log Message: DUMP: mapping (Pass I)[regular files] 
NDMP Log Message: DUMP: Reading file names from NDMP.
NDMP Log Message: DUMP: Q_userhome/A*: No such file or directory
NDMP Log Message: DUMP: DUMP IS ABORTED
 
I raised the above error in a seperate Symantec Forum and was informed of the following URL, 
 
http://www.symantec.com/business/support/index?page=content&id=TECH87338
 
The article explains an issue regarding wildcard INCLUSIONS and NetApp.
 
As inclusions do not work, I wanted to try EXCLUSIONS to see if it offered any success. Does anyone know how to do this please?
 
 
 
 
 
 
 
 

3 Replies

  • The format of exclusions is specified by NetApp's NDMP implemenation and is not something designed by us. I have not looked  at this for a while but last time I tested this (with an older Ontap version and older BE version) I found that you could not specify paths as the Exclusion standard did not allow the \ or / characters. If I remerber correctly the * wildcard was not functional either. EDIT it's possible such characters are not allowed in the include statement either.

    What you could do was specify a string - for instance the word HOME and then any folder or file containing the word HOME in the name, wherever it was found in the file system would be excluded. To me this means you would have to be very very careful with exclusion strings in order to avoid something important not being backed up. It is possible that newer ONtap versions handle things slightly different from my original test experiences.

    Unfortunately as all we are doing is passing the string as an NDMP exclude statement to the OnTap implementation of NDMP, the exact behaviour and format of the strings in the exclude statement is outside of Symantec's control and you may need to look at NetApp's own documentation to try to understand what is possible.

     

     

     

  • Hi Colin,

     
    Thank you for your response. 
     
    I think the problem still exists in the most current version of ONTAP given the error I am experiencing.
     
    Just to briefly elaborate:
     
    The userhome folder contains 3000 roaming profiles. If I create a BEXEC job to backup the entire userhome folder, it never starts because of the sheer amount of data it needs review prior to starting the job. I have never timed how long this waiting/review process takes but I have had to cancel many jobs that have gone past 14 hours. I have however manually selected all the user profiles beginning with 'A' and the job starts successfully after a 30 minute waiting/review period.
     
    I reallly do not want to manually select A, B, C, D etc.
     
    The manual selection process will also mean that any new users that join the company will not be included in the backup job unless a member of the team reviews the selection list on a daily basis. Extremely cumbersome.
     
    There has to be a simpler way to achieve this......save me Mr. Weaver!
     
     
     
  • Sorry but due to limitations outside of Symantec's control because it is how the programming interface from the harwdare vendor works, how the NDMP option selections/exclusions/inclusions work is cumbersome. As such I am not aware of a setting which will help you. You may have to play around a bit.

    What you could do is create a subfolder with a very unique name and move the stuff you don't want into that and then exlude that unique name. - however this might affect how applications that use the data are configured.