Forum Discussion

montel999's avatar
montel999
Level 2
8 years ago

"No Media in storage device" Even though there is a backup tape in the drive.

Hi guys, I need some assistance, one of our customers uses Backup Exec 2012 and are having serious issues with their backup. We have exhausted all possibilities and cannot find a solution. Everytime the backup starts it keeps failing with the error of "no media in storage device even though there is a tape in the drive. I have tried recreating the job excluding folders. The tape is showing as fine and so is the RDX Drive. I have even updated the firmware and still experiencing issues... any suggestions?

2 Replies

  • Quick question. Is the backup device (i.e. destination for the backup) a physical tape drive/loader, or is it a Backup to Disk folder on the RDX Drive?  If it is a physical tape drive it could be that the tapes are being protected by the Overwrite settings within Backup Exec. One of the options is to terminate the job if no overwritable media is found.

     

  • Typically for handling RDX, if Backup Exec cannot use the RDX cartridge, it ejects it (BTW please don't call them tapes it gets confusing when we try to give advice because taoes use Media Seta dn RDX uses DLM). Is this eject happening in yoru case?

     

    Reasons why BE might not be able to use an RDX cartidge include;

    - cartridge full (usually because of not understanding backup set retention and backup sets filling the cartidge, although there have been problems with DLM - see comment below)

    - cartridge physically write protected (RDX cartridges have a slider on them to enable a write protect capability, this is similar to a tape. In transit this slider can be accidentally applied)

    - the cartridge itself has not be connecting to the Backup Exec server for over 4 weeks. we have a default setting to limit cartridges to read ony if they have not been used for over 4 weeks (so that vaulted cartridges being returned for a restore won't get overwritten if the retention timings were too short for the vault use).  This setting can be completely disabled or the timings changed, however when re-inserting such a cartridge all you need to do is open up the properties and check/change the limit to read only setting. Note: I am not 100% sure which version of BE we introduced this ability so it's possible it is not something seen in BE 2012 (BE 2010 R3 and earlier worked a different way so it woud not apply to those cersuosn anyway)

     

    COMMENT ABOUT DLM:

    BE 2012 used an early implementaion if our Data Lifecycle Management (DLM) system. There have been a number of DLM enhancements and fixes since this version, as such anyone running BE 2012 and experiencing conditions relating to lengthy retention of disk based sets (or early deletion) should upgrade to at least BE 15 FP5 (preferably 16) but make sure they carefully check the compatibiity lists as part of their planning for such an upgrade (as some older technologies are no longer supported)