Forum Discussion

moniker131's avatar
moniker131
Level 4
6 years ago

VMWare error "Adapter data initialization failed." when adding restored vdisk

I just need a few files from a backup, but GRT is not enabled on the job. So, I restored the vdisk locally, and imported into our VMFS datastore. I get the error when I try to add the vdisk to a virtual machine. At first I tried a dev server to not interfere with any production systems, but I get the same error on the original vm was well. I followed a VMWare article to change the UUID so I could add it to the original server.

https://kb.vmware.com/s/article/1021189

Any advice?

2 Replies

  • I restored an older backup of the same VMDK and get the same error. So I found vmware's vmware-mount.exe tool (which is a part of the vmware disk development kit, but not after version 5.5 fyi). Using this tool, I still was getting an error mounting the VMDK. This was in the log located at C:\users\<user>\AppData\Local\Temp\vmware-<user>-<nnnn>\vmount.log and vmount-client.log:

    Snapshot error: 7, legacySuccess: 1, numStates: 0

    I came across this old post which had the same error using vmware-mount.exe.

    https://vox.veritas.com/t5/Backup-Exec/Mounting-a-VMDK-from-a-restored-backup-taken-with-Backup-Exec/td-p/835187

    So I used the /m:n switch, and was able to mount the VMDK and grab the files I needed. That's cool, but I'm still concenred about my ability to restore these VMDKs.

  • when you restored the disk locally what did you use to import it to the VMFS datastore?  Did you just copy it up using the vSphere GUI?