Forum Discussion

notmen's avatar
notmen
Level 2
14 years ago

EV 9.0 for Sharepoint 2007 R2 not working good

Hi All,

I am testing the EV9.0 witch sharepoint 2007 r2, but not working well.

I have disabled the prune option and set 0 days to archive and replace with shortcut.

Every time I archive a document, a new version with 1K (I think it is the shortcut) added to the sharepoint library, but the old version still keeping the actual file size. (Not take away from the sharepint sql at all!!! I tried to shrink the SQL but no space free up)

More worse thing is sometimes the shortcut not work at all!!! Return page said EV server not available or access denied!

Any idea?

Roy

8 Replies

  • (Not take away from the sharepint sql at all!!! I tried to shrink the SQL but no space free up)?

    Are you talking about SQL whitespace and reducing this?  If so really would be down to maintanance and backups of SQL and not an EV operation.

    With regards access is denied or unavailable more information would be required.  What is the IIS status code? Any errors or warnings in EV event log at this time.  Does it sometime works and sometimes not for the same user and item? Any firewalls or proxy servers in use?

  • So your items are getting archived correctly?

    They are not getting shortcut correctly, is that correct?

     

    In your Sharepoint policy what do you have set on the shortcut tab ?

  • We had that same issue in our environment and it was because the site alias couldn't be resolved (I.e the site alias was myEVSite when it should have been myEVsite.mydomain.com
  • Hi JesusWept2,

    Which issue? And how did you solve it?

    Thanks,

    Roy

  • Hi Archiving Central:

    I think I knew what happened to the sql, please ignore this part.

    For the dead link, I attached the screen shot 2.jpg.

    I got no error or warning at that time in EV or IIS....., I am suspecting it cause by the SQL shrinking. Also attached the IIS log for sharepoint as SP-IIS-log.txt
    The Last 2 lines are the deadlink document shortcut.

     

    Hi Rob:

    I don't think the items are archived correctly because any edit and save on the items will produce 2 idential versions after archiving task.

    Attached the current version list screen as Sharepoint.jpg.
    You can see duplicated set of document and shortcuts.

    Attached the Sharepoint Policy screen as ShortcutSetting.jpg.

    Thanks.

    Roy

  • Ok so your issue being the ev service is unavailable or access denied, it's because it was trying to communicate to the site alias, in our case the site alias was myEVSite If you pinged myEVSite it would come back with unknown host But if you pinged myEVSite.mydomain.com it worked We tested adding myEVsite to the correct ip address in the hosts file and then everything started working, so we then added mydomain.com to the domain suffix list on the ev server
  • Hi JesusWept2,

    Your suggest is close to the solution.

    I tried and it open the document.

    But what exactly I have to do?

    My sharepoint host is "SPS", Domain is "EV9Demo.local".

    Add all host name with domain to host file in EV server?

    Please advise,

    Roy

  • We were having similar issues in a POC where we are trying to archive some sites (WSS 3.0) with EV 9.01.

    The archiving routine works, documents are in the Vault and are replaced by a shortcut (1K in size). However opening a document resulted in a dialog prompting for username/password where authentication failed. When trying to edit the document properties we got the error message "The enterprise Vault Server is unavailable or access is denied".

    Finally found the solution by disabling the firewall on our windows 2008 WSS server!

    Now only thing is missing is the "Restore from Archive" option in the drop down menu on sharepoint. I tried disabling/enabling the feature but dit not have any success... any other options?