Forum Discussion

SYMAJ's avatar
Level 6
13 years ago

EV9 FSA Agent - Install Failure - ISSCRIPT

I have upgraded an EV7.5 installation to EV8SP5, both FSA and Exchange.  There are 5 file servers involved in the FSA configuration, and I upgraded the FSA agent on one server only.  This was due to a reboot being required following upgrade - and as I was upgrading to EV9 shortly after I decided to leave the other 4 servers.  All worked fine with the one I upgraded and rebooted.

Following the EV9 upgrade I attempted to upgrade the remaining 4 file servers from the 7.5 FSA AGent to EV9SP3 FSA Agent.  ALL of the 4 servers failed the upgrade with the same error.  I tried both install from with the VAC and also a local install on each file server - same results - each failed and rolled back.  The message I am seeing in EV Installation Log is near the end, and is as follows:

 ISSCRIPT_VERSION_MISSING = The InstallScript engine is missing from this machine. If available, please run ISScript.msi, or contact your support personnel for further assistance.

I see many references to this message regarding installations of various software products, but nothing relevant for EV.  I didn't try to install EV8SP5 on these remaining 4 servers, would that of worked ?  Is it an issue with installing EV9SP3 FSA Agent over the EV7.5 agent, it seems strange that the one I picked at random for the EV8SP5 upgrade wotked OK.

Any advice welcome.


6 Replies

  • I'm not sure but perhaps the 9.0.x Agent binaries don't have the logic to upgrade a 7.5.x agent.

    It might be worth trying to upgrade the agent to 8.0.x first and see how things are handled.

    Otherwise I would suggest to manually un-install the FSA Agent from one system and then try the push install with 9.0.x 

  • WIndows is W2K3 SP2 - so no UAC issues.

    I saw that technote - it is specific to System Recovery and none of these entries are in place on my fileservers.

    I considered trying the EV8SP5 upgrade (which worked on one file server last week) - but as it was late didn't attempt it last night. The other option of uninstalling the EV7 Agent and trying a fresh install of EV9SP3 was also considered, however I was concerned that if I couldn't get the EV9SP3 agent on I would be left with a system with no functioning agent (at least it is all working OK at present). !

    I would have expected that EV9SP3 could update EV7.5 binaries, but I guess if we have to step EV server through 8 to get to 9 maybe the upgrade of the FSA Agent isn't supported (although don't see it noted anywhere)


  • I Know it's a different product but the concept is still the same, just a differen product name But agree with rob, uninstall and reinstall, especially since its only 4 servers
  • I will do this and report back (still have a little fear as to what happens if I cannot get ANY agent back onto the file server.....).

    May try and upgrade the one I moved to EV8SP5 already up to EV9SP3 and see if that goes OK ??