Forum Discussion

DJSAJJAD's avatar
DJSAJJAD
Level 3
10 years ago

EVPM: Error Creating Privileged MAPI Session

Hi There,

I had this EVPM process which would create and populate folders in people's Outlook and set retention categories on them. This process is broken now and when i run that process, it returns with the error message "Error creating privileged MAPI session"

Here is how i run this and i have been running like this for ages and it has been working but this stopped over a month ago and i cannot make it work anymore, anything found online so far is not helping:

I modify the INI file with proper Mailbox DN to which i need to deploy the folders and then i launch the commad prompt, i browse to the directory where Evpm is located, see below, i have changed any identifiable info to something phony:

"C:\Users\evault>Cd C:\Program Files (x86)\Enterprise Vault

C:\Program Files (x86)\Enterprise Vault>Evpm

Would you like to perform an Exchange or a Domino related task? [E/D]:e

Please enter an Exchange Server name: CASARRAY1234

Please enter the service mailbox alias: EV--mailbox1@smtpdomain.com

Please enter the ini file name and location: C:\Program Files (x86)\Enterprise V
ault\All_default_useralias.ini

 

Creating privileged MAPI session ...
Error creating privileged MAPI session"

Now for all above fields, i have tried all possible combinations i can think of, for example, for Exchange server name i have tried all CAS servers individually one by one, e.g CAS1, CAS2, CAS3, CAS4

For service mailbox alias, i have tried, SMTP addresses and mailbox aliases of all of our four EV system mailboxes e.g EV-mailbox1@smtpdomain.com, EV-mailbox2@smtpdomain.com, EV-mailbox3@smtpdomain.com, EV-mailbox4@smtpdomain.com, EV-mailbox1, EV-mailbox2, EV-mailbox3, EV-mailbox4

I have even recreated one of archiving tasks to no avail.

I cannot think of anything other than that we might have created some new mailbox databases and moved mailboxes around around the time when this started occuring but i am not 100% sure about it. I am under pressure to get this fixed, please help!

  • You can try this:

    When running EVPM, "Error creating privileged MAPI session" is returned.

    Article:TECH195356  |  Created: 2012-08-21  |  Updated: 2014-10-05  |  Article URL http://www.symantec.com/docs/TECH195356
     

    Issue

     
     

    When running EVPM, "Error creating privileged MAPI session" is returned.

     

    Error

     
     

    See below DTrace of process EVPM below:

    65 10:20:17.015  [8408] (EVPM) <7184> EV:M CMAPISession::GetExchangeServerDnFromSession - calculate ExchangeServerDn
    66 10:20:17.015  [8408] (EVPM) <7184> EV:M CMAPISession::GetExchangeServerDnFromSession - found exchange server dn: /o=ABCCORP/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)/cn=Configuration/cn=Servers/cn=ABCEX12
    67 10:20:17.015  [8408] (EVPM) <7184> EV:M CMAPISession::CreateMapiSession - Get PR_MAILBOX_OWNER_ENTRYID
    68 10:20:17.015  [8408] (EVPM) <7184> EV:M CMAPISession::CreateMapiSession - Release Mutex(2)
    69 10:20:17.015  [8408] (EVPM) <7184> EV:M CMAPISession::ClearProfileCache()
    70 10:20:17.015  [8408] (EVPM) <7184> EV:M CMAPISession::CloseMapiSession - Entry
    71 10:20:17.155  [8408] (EVPM) <7184> EV:M CMAPISession::CloseMapiSession - [1]
    72 10:20:17.155  [8408] (EVPM) <7184> EV:M CMAPISession::CloseMapiSession - [2]
    73 10:20:17.155  [8408] (EVPM) <7184> EV:M CMAPISession::CloseMapiSession - [3]
    74 10:20:17.155  [8408] (EVPM) <7184> EV:M CMailboxHelper::DeleteProfile(VaultMbxAgent-abc14-7184-1345569616-0-437-0): 0x0
    75 10:20:17.155  [8408] (EVPM) <7184> EV:M CMAPISession::GetMapiSessionFromPoolEx: Exit status: 0x8004010f
    76 10:20:17.171  [8408] (EVPM) <7184> EV:M ~EVPM - Successfully processed 0 out of 0 mailboxes

     

    Solution

     
     

    Check the following registry values on affected Enterprise Vault Server:

    HKEY_CURRENT_USER\Software\Microsoft\Office\12.0\Outlook\Cached Mode
    HKEY_CURRENT_USER\Software\Policies\Microsoft\Office\12.0\Outlook\Cached Mode

    1 = Enabled
    0 = Disabled

    If value is Enabled = 1, set it to 0 to disable Exchange Cached Mode and try the EVPM again.

15 Replies