Forum Discussion

tester3's avatar
Level 3
2 years ago

FSA Can't create new file server.


I'm using Enterprise Vault 14.1, I'm trying to add a new File Server for FSA in EV. However I am not able to do so, getting the following error:

New File Server belongs to a Netapp 9.8 C-mode, something is not letting me add a new FS, I already have 1 FS configured which is from a different Vserver...

Tried mmc dtrace but the same error displays. 
Also checked Netapp account permissions and configuration.

Any ideas what else should I troubleshoot here?


5 Replies

  • Hi Tester3, 

    ONTAP 9.8 is not yet on the compatibility list for EV, however it may still work.  From the error you are showing it could be that the LIF does not have management access enabled.

    It could also be that http enabled is set to false.

    Would validate the one at a time to see if that allows you to add the NetApp target. 



    • tester3's avatar
      Level 3

      Hello Patrick and thanks for your swift response.

      http is enabled:
      External Web Services: true
      Status: online
      HTTP Protocol Port: 80
      HTTPS Protocol Port: 443
      HTTP Enabled: true

      And about LIF access management we have the same configuration as the vserver that is already configured working.

      Vserver: ---------------------
      Policy Name: ---------------------------
      Included Services: data-core, data-nfs, data-cifs, management-https,
      Service: Allowed Addresses: data-core:



      meuhassan Thanks sir.

      1.- We already have a different Vserver working in this tool, connectivity is OK, and configuration settings between Vservers are the same.

      2.- Will check this with NetApp team to verify correct permissions.

      3.- Getting this error in event viewer (EV Host):
      DCOM was unable to communicate with the computer VSERVER-LIF using any of the configured protocols; requested by PID 4330 (C:\WINDOWS\SysWOW64\mmc.exe).

      Dtraced mmc and exact same error showing up as above.(first post)

      4.- According to this table, it is compatible:


      5.- Done, all same exact configuration between Vservers.

  • If you are encountering an error while trying to add a new File Server for File System Archiving (FSA) in Enterprise Vault 14.1, and you have already checked the NetApp account permissions and configuration, there are a few other areas you can investigate:

    1. Verify Network Connectivity: Ensure that there is proper network connectivity between the Enterprise Vault server and the NetApp file server. Check for any firewall settings or network configurations that may be blocking the communication.

    2. Confirm Enterprise Vault Service Account Permissions: Double-check that the Enterprise Vault service account has the necessary permissions to access and configure the NetApp file server. The account should have appropriate rights to manage the file shares and perform the required actions.

    3. Review Event Logs: Check the Event Viewer logs on both the Enterprise Vault server and the NetApp file server for any relevant error messages or warnings. Look for any indications of connectivity issues, authentication failures, or other potential problems.

    4. Verify Enterprise Vault and NetApp Compatibility: Ensure that your version of Enterprise Vault (14.1) and NetApp (9.8 C-mode) are compatible with each other. Check the Enterprise Vault compatibility matrix and the NetApp documentation for any specific requirements or known issues related to your software versions.

    5. Validate FSA Configuration Settings: Review your existing FSA configuration and compare it with the settings you are trying to configure for the new File Server. Verify that the configuration is consistent and matches the requirements of your environment.

    6. Engage Enterprise Vault Support: If you have gone through the above steps and are still encountering the error, it is advisable to contact Enterprise Vault support. Provide them with detailed information about the error, any relevant log files, and the steps you have taken so far. They will be able to provide specific guidance based on their expertise.

  • Thank you for the update.  It could be that the name resolution is not working properly. Are the LIF's on working and not working servers configured the same as far as name resolution goes?  DNS entries?  

    You could try a hosts file entry on the EV server to see if that changes the behavior.  Otherwise, I would suggest opening a case so Support can look at the Dtrace and check other settings. 



  • Yes, all DNS seems to be in order.

    Raised a Case. Will let you guys know the solution if we find it.

    Thanks everyone!