Forum Discussion

Sani_B's avatar
Sani_B
Level 6
13 years ago

Messages won't delete from archive though shortcut deletion setting is set to "both deleted"...

Hi!

Yet another problem...

According to this article TECH136787 deleting shortcut from OWA should produce this message

"You have chosen to delete an Enterprise Vault shortcut and the associated archived item. You cannot undo this deletion. Copies of this shortcut will no longer work. Do you want to continue?" As long as the shortcut deletion setting is set to "both deleted" on the desktop policy.  Well we do and it asks nothing and deletes the message and put's it in the Deleted Items folder... that should'n happen either according to the article, it should ask the question and then if chosen to, delete it straight away and pass the Deleted Items folder and delete it from the archive too... It doesn't delete the message from the archive either...

In Outlook It asks the question "You have chosen to delete an Enterprise Vault shortcut and the associated archived item. You cannot undo this deletion. Copies of this shortcut will no longer work. Do you want to continue?" and when I choose yes it gives me an error message:

"Unable to delete the archived item

Access is denied

Do you want to delete just the shortcut?"

I checked this from the logs and it gives error: "Deleteo2k returned with error: 164"

 

We also have soft deletes = ON, could this have anything to do with anything?

Thanks again for your help

Sani B.
 

6 Replies

  • It seems that a policy settings somewhere that is preventing the deletion from the archive. Whats' your EV Site setting and what is your retention category settings. Are the users able to delete from their archive and do the retention categories preventing them from doing so? 

  • Could you also do a Dtrace of the deletion process please, hopefully the dtrace will show in more details the reason why the archived message is not being deleted.

  • You might check the retention category properties.  If the "Prevent deletion of archived items in this category" setting is checked, you won't be able to delete the item, even if you allow deletes from the archives.

  • Okay so couple things to this issue:

     

    The retention is set to 1 day so that the deleting can be done, and at first I tried to delete from outlook such messages that I had just done for the demonstration so naturally it would give me the error message - older messages got deleted from outlook just fine from archive too so the problem is just deleting from OWA...

    Still I tried to delete from OWA the older one's and it behaves like yesterday, will delete the shorcut and move it to "Deleted Items" folder but not delete it from the archive...

    I did a trace regarding the OWA issue with these instructions:

    How to trace Outlook Web Access process using Enterprise Vault

    Enterprise Vault for Microsoft Exchange has the ability to trace Outlook Web Access processes like: opening items from vault archive or archiving items to vault.
    To trace Outlook Web Access processes:

    1. Open Vault Administration Console in Symantec Vault Server.
    2. Go to "Tools" menu and Select 'Advanced Features'.
    3. Open the (+) sign under Enterprise Vault Servers.
    4. Right click "Traces" button and click "New"< "trace".
    5. Search for "Outlook Web Access issues” in the list and click "Next".
    6. Name the trace and click "Next".
    7. it's possible to Increase the running time in no other heavy processes use the CPU.
    8. Locate the log file location and click "Next".
    9. Click "Run now" to run the trace.

     

    and I tried to read the log but there is no separation of the accounts so I have no Idea what is it that I'm suppose to find from there... I't from our customers server so I can't just post it here... any suggestions?

    This is what it tells me about deleting:

    439 08:30:25.875  [13524] (w3wp) <14908> EV:L CAutoStorageOnline::~CAutoStorageOnline (Entry) |
    440 08:30:25.875  [13524] (w3wp) <14908> EV:L CQueue::Delete (Entry) |
    441 08:30:25.875  [13524] (w3wp) <14908> EV:H CQueue::Delete|Deleting queue:
    442 08:30:25.875  [13524] (w3wp) <14908> EV:M CQueue::Delete (Exit) |Success  [0] |
    443 08:30:25.875  [13524] (w3wp) <14908> EV:M CAutoStorageOnline::~CAutoStorageOnline (Exit) |Success  [0] |

     

    It suggests that the deletion was successfull? But it wasn't cause it would not delete from vault...

     

    Thanks again for your replys

    Sani B.

  • Hi,

     

    I think you need to enable Dtrace on the StorageDelete process as well.  I think that the w3wp process will be passing the request onto that particular process and i'm guessing it's in there that for some reason it might be saying 'no you can't do this'

     

    Mike