Forum Discussion

dgoodyear's avatar
dgoodyear
Level 5
14 years ago

Virtual Vault indexing errors after win 7 sp1 and outlook 2010 sp1 updates

We are using Outlook 2010 professional.  We were having issues a few months ago with outlook search not showing all of the results from virtual vault.  This issue was a known issue and Symantec released a hotfix client with instructions on how to rebuild the outlook index here:

http://www.symantec.com/business/support/index?page=content&id=TECH162170

I followed the instructions and it worked like a charm. 

 

Since then, we have just released the Office 2010 Professional SP1 and Windows 7 SP1 to our clients through WSUS.  Afterwards, machines that were using virtual vault began showing a number of event log error id 1000 messages:

Faulting application name: SearchProtocolHost.exe, version: 7.0.7601.17610, time stamp: 0x4dc0c63a
Faulting module name: unknown, version: 0.0.0.0, time stamp: 0x00000000
Exception code: 0xc0000005
Fault offset: 0x00000000
Faulting process id: 0x80c
Faulting application start time: 0x01cc489c16c2ff8c
Faulting application path: C:\Windows\sysWow64\SearchProtocolHost.exe
Faulting module path: unknown
Report Id: 54edce07-b48f-11e0-8beb-18a90581c45f

 

Also I noticed that the EV client log started showing these messages again:

The indexing operation performed by the WDS protocol handler failed: 0x80040154

 

I thought that perhaps something was reset from the Service Pack updates so I did some investigating.  I went through the hotfix again, rebuilt the indexes.  Everything appeared ok on my machine.  Outlook searching worked great.  So, I restarted the outlook client and then saw a new appearance of the 1000 event id message above.  Just a single instance.  Searching still worked fine.  I then tried to drag and drop a message for archiving into Virtual Vault.  It worked, but as soon as I did, I immediately saw 8 event id 1000 error messages like above in the windows application event log.

I then performed a synchronize vault cache, which does go through, but it immediately generated another: The indexing operation performed by the WDS protocol handler failed: 0x80040154 error in the EV client log.

 

Are we back to square one since either the windows 7 sp1 patch or the outlook 2010 sp1 patch? Or is there something else I should look for?  Has anyone else seen this issue?

 

I

8 Replies

  • First of all, Outlook 2010 SP 1 isn't yet certified.  However, I've been using it on my x64 Windows 7 laptop with Outlook 2010 x86, and on my desktop at the office x64 Windows 7 with Outlook 2010 x64, without any issues.

    I definitely don't have Windows 7 SP 1 on the laptop (yet), and I can't recall if I have it on the desktop or not.

     

    So, if you can...  try to isolate whether this is Windows 7 SP 1 or Outlook 2010 SP 1, or a combination of the two.

     

    Whilst it's NOT certified, our teams are working on that, and of course we want to know about customer testing too.

     

    You may also want to work with Support and / or Microsoft to narrow down what's causing the crash.

     

     

    We do have one customer already working with on this type of issue, though at the moment I can't tell if it's the same issue or not (sounds very similar though)

  • I hadn't thought to check the compatibility chart for Outlook yet.  We dont' have Virtual Vault rolled out company-wide yet, but it is in pilot testing in our organization with a number of people.  I'll see if I can do some testing between for service packs to narrow it down.

     

  • Some updates:

    I set up a brand new instance of Win 7 Enterprise (64bit) on a laptop.  I installed Office 2010 32bit version.  I installed the EV 9 sp2 hotfix client.  Everything appers to work ok on the machine.  No event log errors and no ev client errors.

    I downloaded the 32bit Service Pack 1 for office 2010 and installed.  I immediately saw the searchprotocolhost.exe errors in application event log (event id 1000) when running outlook.

    I then deleted the relevant registry files and rebuilt the microsoft office index per the hotfix instructions.  The errors didn't seem to appear in the windows application event log (event id 1000) when launching Outlook.  I then moved a message to the virtual vault.  A single event id 1000 error in the application event log appeared.  No errors in EV log yet.  I then manually performed a synchronize vault cache successfully.  I checked the EV client log and saw the error

    The indexing operation performed by the WDS protocol handler failed: 0x80040154 

    I double checked the windows app log again and there were no additional event log errors.

     

    So far this seems Office SP1 related. 

    My next step was to remove the Office Service Pack 1.  After restarting the computer, I checked the windows application event log.  No errors reported including after launching Outlook.  I then moved a file to virtual vault.  I checked the EV client log and windows event logs... no errors.  I performed a manual cache synchronization.  The EV client log reported the same indexing operation protocol handler failed error above.  The windows application event log was clean.

    At that point I tried to rebuild the index from the hotfix instructions.. same result.  No Windows app log errors but EV client reporting the protocol handler failed error.

    I then tried an ev client repair with the same result.

    I then removed the EV client, reinstalled it, and rebuilt the index per the hotfix again.  At first I thought this had restored all functionality with no errors but I started getting the EV client log WDS protocol handler failed failed messages again any time I tried to synch my vault cache after moving messages into virtual vault.  I gave the machine a reboot too just in case but there was no change. 

     

    I haven't tried checking anything with Windows 7 SP1 by itself yet.  In the meantime, I may try to uninstall office 2010 completely and reinstall it to see if I can bring it back to the original ev client non-error state I started with.

     

  • I've been working on this internally, and :

     

    * I think we have a handle on what the issue

    * Are testing an interim "cure".

     

    Alistair..  we're working with you (I know you're watching the thread)