Forum Discussion

AndreaBolongaro's avatar
16 years ago

get rid of vnetd messages

Hi,

in RedHat EL 5x I have a lot of

Mar  9 18:33:40 servername xinetd[4917]: START: vnetd pid=22869 from=x.x.x.x
Mar  9 18:33:41 servername xinetd[4917]: START: vnetd pid=22870 from=x.x.x.x
Mar  9 18:33:41 servername xinetd[4917]: EXIT: vnetd status=0 pid=22870 duration=0(sec)
Mar  9 18:33:41 servername xinetd[4917]: EXIT: vnetd status=0 pid=22869 duration=1(sec)

entries in /var/log/messages, every ~15 minutes. NB is 6.5.3.

There's a way to get rid of them?

Thanks in advance,

 

Andrea

 

  • Andrea,

     

    NetBackup is not logging those messages; xinetd is.  You will need to adjust the logging levels of xinetd.  It's a Linux configuration, not a NetBackup one.

     

    It's probably not a new feature, but more likely a different configuration of syslog between the two versions.

     

8 Replies

  • This looks like something you'll have to change in your logger (syslog?) configuration.  xinetd is probably writing logs at too low a severity for your taste.  Check....I think for your Linux, it's /etc/syslog.conf.

     

    (I feel like we had this discussion a couple weeks back at the STN, but for the life of me I can't figure out how to find it.)

  • Search via Google.

    Then use the cached link provided by Google instead of the live lnk.

     

  • I read the discussion before posting, but I was wondering a way to avoid messages throught NB. 

    That's is a new "feature" I have in Rhel5 but not in Rhel4.

    I read a similar issue for solaris, but not for linux

    http://seer.entsupport.symantec.com/docs/251190.htm

     

     

     

     

  • Andrea,

     

    NetBackup is not logging those messages; xinetd is.  You will need to adjust the logging levels of xinetd.  It's a Linux configuration, not a NetBackup one.

     

    It's probably not a new feature, but more likely a different configuration of syslog between the two versions.

     

  • From my experience the annoying entries in /var/log/messages:

    Sep 27 03:48:23 etdlsrv xinetd[3164]: START: vnetd pid=25325 from=10.1.98.12
    Sep 27 03:48:23 etdlsrv xinetd[3164]: START: vnetd pid=25326 from=10.1.98.12
    Sep 27 03:48:23 etdlsrv xinetd[3164]: EXIT: vnetd status=0 pid=25326 duration=0(sec)
    Sep 27 03:48:23 etdlsrv xinetd[3164]: EXIT: vnetd status=0 pid=25325 duration=0(sec)
    Sep 27 03:48:54 etdlsrv xinetd[3164]: START: vnetd pid=25988 from=10.1.98.12
    Sep 27 03:48:54 etdlsrv xinetd[3164]: EXIT: vnetd status=0 pid=25988 duration=0(sec)

    are due to the NBU installed /etc/xinetd.d/vnetd configuration file. It does not include a "log_on_success" line and it appears that as a result, xinetd logs all all the vnetd start/stops - and there are a bunch!

    I get rid of them by adding

    log_on_success  =

    to list no options for xinetd logging. I also move the previous vnetd configuration file that the NBU upgrade renames at install time. I am not sure about the precedence, but I don't like having two files listing the same service.

    Anyway, when I upgraded to 6.5.4, the logging came back. I edited vnetd and "reloaded" xinetd and the logging stopped.

  • I found that this worked like a charm on my Linux servers without needing to reconfigure OS level logging.  Just adding the one line into /etc/xinetd.d/vnetd removed the tons of messages.  Now my message logs will be a lot cleaner going forward.