Forum Discussion

KeirL's avatar
KeirL
Level 6
11 years ago

NetBackup AIR Import not running unless services restarted

Hi

I've configured AIR between two NBU 5230 Appliance which works fine most of the time. This is bi-directional (both sites are active and replicate to each other). One of the sites is troublefree, the other replicates ok but the import job at the destination site fails to run. If I run the nbstlutil -pendimplist then nothing is returned. However if I restart all the services the import job starts and imports all the replication jobs that are outstanding.

I've read technotes on various reasons why the import jobs may not run eg policies and paths with over 128 characters and name mis-match between master servers and SLPs etc but if this was the case in my environment then I assume restarting the services wouldn't fix the issue?

I've tried re-creating the SLP's both manually and using the Auto Create method but still the problem persists.

Although my environment has Appliances I'm not convinved this is because I have Appliances and view this as a more software related issue

Just interested if anyone else has had this and perhaps what's the best log file to review to see what errors may be logged?

kind regards

K

4 Replies

  • So just to get more info what version is your appliance running on? 2.6? 

    I would look at /disk/log/spad/replication.log The image is making it to the destination side but nbrmms isn't picking up the events and it sounds like the failure is happening on the MSDP side between the source MSDP server and the destination MSDP server. Also look at the OID's 220, 222, 226, and especially 369

     

     
  • Hi

    Thanks for the reply

    I'm running 2.5.4 on both appliances

    Yes - all the replication jobs complete successfully and when the services are restarted at the destination end an import job will start after about 5mins which imports all the images that had been successfully replicated. So I'm not losing any information or data but I don't want to have to restart the services every day to allow the import job to start.

    Thanks for the info on the logs - I'll take a look over the next day or so to see if there is any error information that may point towards what the problem is.

    This only appears to be in one direction - the import jobs going in the other direction all seems fine and consistantly starts after the replication jobs complete.

  • Hi,

     

    I had a similar issue a while back, I'll check with my client if the imports are running. I'd raise a support case to check it out though.

     

    Let us know if its a bug.

  • Thanks - it seems be be fine now.

    I've not had an issue for a couple of weeks - perhaps it was just a glitch :o)

    cheers