Forum Discussion

SYMAJ's avatar
SYMAJ
Level 6
10 years ago

Netbackup, Exchange 2010 DAGs and Public Folders

I have a 5230 Appliance running 2603, an exchange config of 2 x CAS servers & 2 x DAG DB servers.  Exchange servers are W2K8R2 with NBU 7603.  The databases are distributed accross the DAG DB servers with a Public Folder database on each of the DAG members.

I am backing up the mailboxes with an MS-Exchange policy specifying 'Microsoft Exchange Database Availability Groups:\' with NO new stream entry.  I have a Limit Jobs Per Policy to 20. 

When I run the policy I get a single job per database submitted - which is the intended result.

However - I have a question around Public Folders........

I want to exclude the Public Folder databases from the backup and back them up seperately.  In order to exclude these I have added an entry in the EXCLUDED FILES tab of the Client Attributes for each of the public folders to the 2 DAG members as follows:

Microsoft Information Store:\name of public folder database 1

Microsoft Information Store:\name of public folder database 2

Will this exclude the public folders from the entire DAG backup ?

 

Also, I will be setting up a policy purely to back up the 2 Public Folder databases.  I intend to have an MS-Exchange policy with backup selection entries as follows:

NEW STREAM

Microsoft Exchange Database Availability Groups:\public folder database 1

NEW STREAM

Microsoft Exchange Database Availability Groups:\public folder database 2

Is this correct for selecting just the public folders from a DAG config or should I be using the 'Microsoft Exchange Public Folders:\' directive ?

 

I appreciate any input as I have reviewed many many documents and TECH notes and am still not clear as to the correct way forward.

 

Thanks,

AJ

 

9 Replies

  • Hi AJ

     

    The excludes look ok, for the new policies use in the following in the file list.

    Microsoft Information Store:\name of public folder database 1

    Microsoft Information Store:\name of public folder database 2

  • Thanks.

    The excludes on the two DAG members for the Public Folders did work OK, but it does return a status 2 from the snapshot job saying no fiiles were backed up. 

    Also, the job to back up the public folders is se up with a backup selection of MICROSOFT EXCHANGE DATABASE AVAILABILITY GROUPS:\Pub Folder Database Name and works just fine.

    AJ

  • Of the snapshot jobs submitted by the parent job for the entire DAG (total 7 jobs), 2 are for the Public folders.  As above, 1 completes with a status 2, but the other finishes with a status 4200 - unable to obtain snapshot lock.  After researching this I created a registry entry on the DAG members to increase the timeout for the snapshot - VssOperationMutexLockTimeout, and specified 10800000.  However - the job is still failing with a 4200 after 1hr 38mins.  I don't want this job to run anyhow as it is one of my exclusions but I would rather it didn't finish with a 4200 !!

    Any suggestions ?

    AJ.

  • Its working in terms of the Public Folders are not being backed up as part of a FULL DAG backup, only issue is the status code being returned from the two snapshot jobs for the public folders.

    AJ

  • To make things a litle bit easier, just create two policies, like:

    EX_DAG : with "Microsoft Exchange Database Availability Groups:\[name of your mailboxes databases, one per line] as the backup selection and with the dag name as the client.

    EX_PF: with "Microsoft Information Store:\" as as the backup selection and put your Exchange Public Folder machines on the clients list.

    Did you tried a simple setup like this one ? I backup my environment like this without any issue. However, my Public Folder databases are hosted on dedicated servers (not on my dag members).

  • Fabrice,

    That would be fine excepting the following:

    1. I have the maximum 100 databases, so this would equate to a massive selections list.

    2. Ongoing maintenance - as databases change, get deleted, get added - the selection list would need to be updated each time.  Not where I want to go.

    AJ.

  • You mean for the DAG, did you try with

    Microsoft Exchange Database Availability Groups:\   or

    Microsoft Exchange Database Availability Groups:\*

    As backup selection ?

  • I am running with the backup selection of Microsoft Exchange Database Availability Groups:\

    I have two DAG member servers (DB servers), each with 1 Public Folder database and many mailbox databases.  I get 7 snapshot jobs submitted when the policy runs:  1 for Pub Folder database on DAG member 1, 1 for Pub Folder database on DAG member 2, 2 for mailbox databases on DAG member 1 and 3 for mailbox databases on DAG member 2.

    Both the DAG members have the specific exclude for the Public Folder database resident on the server, and one of my Public Folder snapshot jobs finishes with a status 2 and the other with a status 4200.

    As the VSS snapshots will run serially by default, and the timeout is 1hr by default I can see why the snapshot job on the server with more snapshot jobs is timing out - hence I increased the VSS snapshot timeout.  However, this doesn't appear to have resolved the problem.  (Also I would prefer not to have a status 2 either).  I don't want to go down the road of individually specifying each of the databases in the backup selections so would rather get to the bottom of this problem.

    After placing the registry entry for the VssOperationMutexLockTimeout I did restart the NBU Client services, but didn't reboot the server.  Surely it doesn't need a reboot to pickup this setting ??

    AJ