Forum Discussion

Kisad's avatar
Kisad
Level 5
14 years ago

Netbackup Status Code 2001,help needed

Hi Guys,

 

Backups are failing in my environment with status code 2001 (No drives are available for this job). I'm seeing this error code for the first time. I'm going to the  drives. In the meantime any additional help or pointers will be greatly helpful.

Netbackup Version :  6.5.6

OS: Solaris9

 

Thanks

Kisad

 

 

 

 

 
  • Just when we think we've seen it all!!

    One of the 6.5.6 enhancements (http://www.symantec.com/business/support/index?page=content&id=TECH129631&locale=en_us ):

    "Disambiguation Of Status 800"

    There's also a new 6.5.6 Troubleshooting Guide:

    http://www.symantec.com/business/support/index?page=content&id=TECH128469&locale=en_us

     

    Extract:

    NetBackup status code: 2001

    Message: No drives are available for this job

    Explanation: Ajob requested a tape drive, but no eligible drive path was configured for the job.

    Recommended Action: Try the following:

    ■ Verify that the required drives and robots are configured and up.
    ■ Verify that ltid is active and a drive path exists that is configured on the drive for the media server that the storage unit requires.
    ■ If the job requires an NDMP drive path, verify that one exists.

7 Replies

  • an update

     

    I'm not able to ping the media server  which is configured for the failed clients. and when i check from command vmoprcmd -d -h <media server>, i get error Could not connect to vmd on host media server (70).

    currently my unix team is checking the media server.

  • Just when we think we've seen it all!!

    One of the 6.5.6 enhancements (http://www.symantec.com/business/support/index?page=content&id=TECH129631&locale=en_us ):

    "Disambiguation Of Status 800"

    There's also a new 6.5.6 Troubleshooting Guide:

    http://www.symantec.com/business/support/index?page=content&id=TECH128469&locale=en_us

     

    Extract:

    NetBackup status code: 2001

    Message: No drives are available for this job

    Explanation: Ajob requested a tape drive, but no eligible drive path was configured for the job.

    Recommended Action: Try the following:

    ■ Verify that the required drives and robots are configured and up.
    ■ Verify that ltid is active and a drive path exists that is configured on the drive for the media server that the storage unit requires.
    ■ If the job requires an NDMP drive path, verify that one exists.

  • Oh yes....came across one of those on the forum a few months back! laugh

    Thought it was a typo until I had a closer look!

    ***EDIT***

    "Could not ping media server" - if pings aren't disabled in your environment that should be your first port of call then!

  • Off course friend I think you first check the Media Server Network connectivity, NIC of both sides, firewall.....After connectivity successful/Fixed i think the backup should be started. if not please share the logs

  • Thanks for the responses. The NIC on the media server had problems and the interface would not come up. The Unix team had to bounce the box to get it fixed. The master was then able to communicate with the media server and backups started working.

    I encountered this status code for the first time and frankly it had me stumped. Thanks again for the help.

     

    Happy Weekend

    kisad

  • I have marked Marianne's post as solution. Andy and Zahib , Thank You for your responses too.