Forum Discussion

NAYAB's avatar
NAYAB
Level 4
7 years ago

Point to Consider while upgrading AIX which both master and media

Hi All, 

I have a question on upgrading a NBU server which is both master and media server, Do i need to consider anything in particular upgrading the same.

Current NBU version on MASTER/MEDIA is 7.6.1 and to be upgraded to 8.0 (I can directly upgrade from 7.6.1 to 8.0 right)

I have a AIX client which has NBU version 6.5.3, May i know if i can upgrade direct to 8.0 ? Or do i need to do any conditional upgrade to 7.XX first ?

 

Thanks, 

Nayab

 

  • As long as you are aware of the pre-reqs (e.g. nbwebsvc user) and check compatibilities, all should be good. 

    Read through Upgrade Guide, Installation Guide, check for readiness on SORT.

    Check HCL for tape driver requirements.

    Clients can be upgraded direrectly. No need for 7.6. 
    Just confirm compatibilities.

  • For the master server, confirm you are ready by downloading and running the SORT collector from here https://sort.veritas.com/data_collectors

    Considering the gap between NBU 7.6.1 and 8.1 there could be additional patches required for AIX to satisfy 8.1 installation requirements, those will be flagged by the collector.

    For the client you can upgrade it straight to the latest and greatest version but bear in mind that if your client has databases that are no longer supported by NBU 8.1 client, such as old Oracles etc, you may want to stay on the latest supported version, which may or may not be 8.1. Also it's worth checking if the AIX version that is capable of running NBU 6.5 client is actually compatible with the 8.1 client (I have a bit of doubt about that)

9 Replies

  • As long as you are aware of the pre-reqs (e.g. nbwebsvc user) and check compatibilities, all should be good. 

    Read through Upgrade Guide, Installation Guide, check for readiness on SORT.

    Check HCL for tape driver requirements.

    Clients can be upgraded direrectly. No need for 7.6. 
    Just confirm compatibilities.

  • For the master server, confirm you are ready by downloading and running the SORT collector from here https://sort.veritas.com/data_collectors

    Considering the gap between NBU 7.6.1 and 8.1 there could be additional patches required for AIX to satisfy 8.1 installation requirements, those will be flagged by the collector.

    For the client you can upgrade it straight to the latest and greatest version but bear in mind that if your client has databases that are no longer supported by NBU 8.1 client, such as old Oracles etc, you may want to stay on the latest supported version, which may or may not be 8.1. Also it's worth checking if the AIX version that is capable of running NBU 6.5 client is actually compatible with the 8.1 client (I have a bit of doubt about that)

      • NAYAB's avatar
        NAYAB
        Level 4

        Thank you, i have run through SORT and checking all the pre-requisites. I have downloaded the upgrade package for AIX, will i be using same package for both AIX Master, Media and Clients or it has to be a seperate package for each one of them.

    • NAYAB's avatar
      NAYAB
      Level 4

      From the Upgrade guide is see "(Conditional) If your environment is pre-NetBackup 7.6, and you want to use the guided method of migration because the environment has a large image catalog, perform the actions shown" 

      Do i need to perform the guided migration ? I am using NBU version 7.6.1 for Master and Media and i have a mix of clients 7.5.0.5 and 6.5.3. Please advise.

      • Marianne's avatar
        Marianne
        Level 6
        You need Unix Clients 1 download for all of these clients:
        ■ AIX
        ■ HPPA-RISC and IA64
        ■ Solaris SPARC and X86

        The note about pre-7.6 applies to the master server only because this is where the image catalog is stored. Nowhere else.

        So, it does not apply to your environment.