Forum Discussion

NBdmecha's avatar
NBdmecha
Level 4
12 years ago

Problems restoring vSphere 5.1 machines

Hi all,

this is our environment:

  Master and backup Host: Windows 2008 R2 

  vSphere version: 5.1 

  Netbackup version: 7.5.0.5

  Vmware clients OS: windows 2008 R2 and RHEL

  Policy type : FlashBackup-Windows using SAN transport and the backup Host (master).

and this is our issue:

  backups are working properly, and the restores seem so, but restored machines can´t boot. It happens for 2008R2 clients and also for RHEL:

       -Win2008 clients says Operating system not found when trying to boot.

       -RHEL clients hangs on boot too, in this case while some services are being started.

  After reading other similar issues, I checked that disk on backup Hosts are Online and that 2008R2 is installed with the 100Mb partition for boot(standard installation).

 

Is there anything that we are doing wrong? Has anyone faced this before??

Thanks in advance.

8 Replies

  • I tried NBD and it failed the restore. I couldn´t troubleshoot it because I was interested on SAN restores, and as long as we have our disks Online on the backup host it should works.

    I understand you offered us this workaround to help troubleshooting, so I will try to find the error restoring via NBD and see if I can make it work.

     

  • I changed policy type to VMware (which I think is the best option) and it also failed. Clients don´t boot.

     

    I tried NBD but it ended with the following error: "VMware policy restore error(2820)"  and the log displayed:

       -cannot connect on socket

       -FTL - Virtual machine restore: VxMS initialization failed

    Note: backup host and master are the same computers.

  • After opening the appropiate ports Nbd woks properly. So the failure only happens restoring via San.
  • This sometimes happens when datastore LUN is not active on VMware Backup Host.

    Yes, I know you have already checked this point. But key of this issue is "VDDK does not return error even if write to SAN datastore failed". Please check if any security which prevents VMware Backup Host from write access to SAN datastore, is deployed at SAN or storage level. Also check if block size of vmfs is same between source and destionation if you are trying to restore to the datastore other than original datastore.

    This issue is too comlicated to handle here, so I recommend you to open a case with Symantec after enabling VxMS log following this technote. VxMS log is needed in such case.
    http://www.symantec.com/docs/TECH72862

    If anyone alse here has an idea, please help him.

  • Thanks Yasuhisa, I´m restoring to the same DataStore, I enabled the VxMS log and opened the case. Where can I see this new log? I didn´t see any new log folder.

     

    Anyway let´s see what symantec says...