Forum Discussion

Ram_EUHR's avatar
Ram_EUHR
Level 4
10 years ago

Question on Scheduling jobs and cmdline for checking job history

Hello,

I have to schedule backups for one of the windows server and facing some issues with the schedule as the backups are not running on the scheduled time.

I have created a new policy and wanted it to run as mentioned below:

  1. 7 days a week differential backups
  2. Once a week full backups.

And the screenshot of the schedule is attached here.

Both incremental and full backups are scheduled to run from 18:00 -05:00AM.

Couple of questions:

  1. Is this right? I am noticing the backups are not running as expected? (most likely I am missing something). On the day of full backup should I exclude the differential backup run? I am guessing something is wrong with the duration but not able to find out the exact cause? In fact other jobs with similar schedules are running as expected.
  2. As there are a lot of jobs, the activity monitor is getting cleaned quite frequently. Does bpdbjobs give an option to check the historical details of job run based on policy (For eg: I was looking for something like bpdbjobs --policy <policy name> --start date <start_date>--end date <end_date> should give me the details of the job runs of that particular policy in the time specified.

We are running Symantec Netbackup v7.5.0.1 in Solaris v10.

Please let me know if you have any questions.

-Ram Kumar

  • Dear Ram Euhr,

    This can happen when the schedules get corrupted. You need to folow the execution of the policies on a daily basis ( make some kind of report) to see which are the ones not running as expected.

    When you have find out go to the policies and you only need to delete the schedule and accept the changes. Afterwords you will re-create your schedule again and you will see that this time it will run without problems.

    It happens to me that I find a schedule that was not working from the beginnning,  unfortanately one month later, so therefore be prepared,  you have to be sure that all schedules run correctly, and than they will run always and you do not need to worry anymore.

    Other point:

    You dont need to exclude schedules that run on the same day, it will do it for you if all schedules (daily, weekly, etc) are part of one and only policy.

     

    Best regards,

    Cruisen

     

6 Replies

  • "Is this right? I am noticing the backups are not running as expected? "

    How are you noticing this? What is happening?

    As for question 2, you could run: bpdjobs | grep <policyname> - that will list all jobs with that policy, or if you want specific schedule only:

    bpdbjobs | grep <policyname|grep <schedulename>

     

    run: man bpdbjobs for more options and fields you can use for pre-processing. This option may help

        -t timestamp
              Fetches the job records which have completed after the specified timestamp. The timestamp is specified in the following format:

              mm/dd/yyyy HH:MM:SS
              The required date and time values format in NetBackup commands varies according to your locale. The /usr/openv/msg/.conf file (UNIX) and the
              install_path\VERITAS\msg\LC.CONF file (Windows) contain information such as the date-time formats for each supported locale. The files contain specific
              instructions on how to add or modify the list of supported locales and formats.

     

     

     

    Otherwise you may want to use Opscenter.

     

     

  • 1) Definately, you would be excluding the differential backup on the day of full-backup schedule. Why would you be running differential and full backup on the same day..?
     

    2) you can increase the number of days you would like to keep jobs in Activity monitor with KEEP_JOB_HOURS attribute in bp.conf on master server, overriding the default one.

  • Thanks for the inputs revarooo and a_la_carte.

    I will check out the options of bpdbjobs and will get back to you on this.

    >> How are you noticing this? What is happening?

    I can see the backups are missing on the disk where it's supposed to happen. Let me double check on that.

    >> Definately, you would be excluding the differential backup on the day of full-backup schedule. Why would you be running differential and full backup on the same day..?

    Definitely not but how do I exclude that? I guess I should specify it on the schedule. Let me check on that too.

    In the meanwhile, I have pasted the screenshot of the schedule in the first comment. Can someone please take a look at it once and let me know if that sounds right?

    If the schedule is right, then I can be more optimistic in digging this further, 

  • Dear Ram Euhr,

    This can happen when the schedules get corrupted. You need to folow the execution of the policies on a daily basis ( make some kind of report) to see which are the ones not running as expected.

    When you have find out go to the policies and you only need to delete the schedule and accept the changes. Afterwords you will re-create your schedule again and you will see that this time it will run without problems.

    It happens to me that I find a schedule that was not working from the beginnning,  unfortanately one month later, so therefore be prepared,  you have to be sure that all schedules run correctly, and than they will run always and you do not need to worry anymore.

    Other point:

    You dont need to exclude schedules that run on the same day, it will do it for you if all schedules (daily, weekly, etc) are part of one and only policy.

     

    Best regards,

    Cruisen

     

  • Thanks everyone for your response :).

    The schedule issue should hopefully be fixed now.

    The backup window for daily incremental backups wasn't set correctly. I clicked on the duplicate button to duplicate the schedule for everyday.

    Hopefully that should fix the issue.

    [Sorry for the delayed response. I was on vacation last week and came back just today].

    Thank you once again.