Forum Discussion

LT2013's avatar
LT2013
Level 4
10 years ago

Question on Vaulting inline backup copies

Running NetBackup 7.6.0.2 on a Windows server.

I setup the backup policies to do inline copies, such that copy 1 goes to an onsite tape pool and copy 2 goes to an offsite pool.

I was going to use Vault to do the duplications, but in reading other posts, it seems inline copies are recommended over vault duplications.

So now I'm trying to setup a vault job to report on the tapes to be ejected, and run a catalog backup (no duplication and no eject).

The criteria I used for "Choose Backups" in the vault profile was the aforementioned offsite volume pool name (which is copy 2). I'm not getting anything back from vault as far as the robot picking list. I noticed in the Catalog gui, both copy 1 and 2 have a "Yes" under Primary copy. Not sure if this is why I'm not getting any tapes to be ejected.

 

  • Ok so that is the reason it is not working.

    My vault profile has "include all" for every criteria, except the volume pool, where I only include "Daily_Offsite

    In the choose backup tab please make sure to include all for everything. Select all in 'source volume group' and 'volume pool' as well.

    You have to specify the pool that you want to eject in the eject tab. In the eject tab select daily_offsite pool.

    for example, if set the volume pool to 'Daily_Offsite' and this  is not the primary copy, it won't eject.

    There is document on this but I don't have that handy, will update once I have it.

     

     

  • By default , vault will choose the primary copy.

    If you want to use a different and non-primary copy, check out this technote: http://www.symantec.com/docs/TECH74265

     

6 Replies

  • I was going to use Vault to do the duplications, but in reading other posts, it seems inline copies are recommended over vault duplications.

    Inline copies are recommended when you don't have the vault license, if you have the vault duplication license I would recommend using the vaul duplication or infact SLP if you have.

     

    So now I'm trying to setup a vault job to report on the tapes to be ejected, and run a catalog backup (no duplication and no eject).

    In the "Choose Backups" Select everything by default and put the right numbe of days, as far as you mention the right pools in the "Eject" section it will eject the tapes from those pools.

     

     

     

  • both copy 1 and 2 have a "Yes" under Primary copy

    Really? Something must have gone wrong... are we talking about the same image here?

    If tapes are not being picked up from vault, you can look at \vault\sessions\<vault>\sid###\logs\detail.log, it will explain why certain tapes are not picked up. 

    I also prefer SLP & vault over inline tape copy.

  • I'm doing inline vs. vault because doing the concurrent backup (as opposed to scheduling duplication jobs via vault) is the better option in terms of more efficiently creating my offsite backup copies. I ran some more test vault jobs and focused on a specific image: foo.domain.com_1412070119, which was created last night, and has 2 copies.

    bpimagelist shows accurate information...2 copies, Copy 1 is primary and Copy 2 is on a tape in the "Daily_Offsite" pool. My vault profile has "include all" for every criteria, except the volume pool, where I only include "Daily_Offsite".

    From the details log, I see:

    406 [21376.17180] <2> vltrun@PassImageThruFilters^6: IMG_ID=foo.domain.com_1412070119
    12:34:44.406 [21376.17180] <2> vltrun@cImgFilterInVolPool::ValidateCopy^6: Image:foo.domain.com_1412070119 COPY#=1 skipped by VolPoolSet
    12:34:44.406 [21376.17180] <8> vltrun@cImgFilterInVolPool::DoValidate^6: Image: foo.domain.com_1412070119 Rejected - PrCpy 1 NOT in VolPoolSet
     

    Looks like vault will try to vault the primary copy. So I ran another backup and changed the policy such that Copy1 goes to Daily_Offsite. I still go nothing on the vault reports for the robot picking list, and details log would lead me to believe that the tape should have been vaulted (the backupid that I switched is foo.domain.com_1412093299)...

    13:37:21.697 [19468.20032] <4> vltrun@ImageInterface::init_query^7: TS=(1412087841,1412095041) BPType=9 PLCY=
    13:37:21.822 [19468.20032] <2> vltrun@PassImageThruFilters^7: IMG_ID=foo.domain.com_1412093299
    13:37:21.837 [19468.20032] <2> vltrun@PassImageThruFilters^7: IMG_ID=foo2.domain.com_1412091511
    13:37:21.837 [19468.20032] <2> vltrun@cImgFilterInVolPool::ValidateCopy^7: Image: foo2.domain.com_1412091511 COPY#=1 skipped by VolPoolSet
    13:37:21.837 [19468.20032] <8> vltrun@cImgFilterInVolPool::DoValidate^7: foo2.domain.com Rejected - PrCpy 1 NOT in VolPoolSet

  • Ok so that is the reason it is not working.

    My vault profile has "include all" for every criteria, except the volume pool, where I only include "Daily_Offsite

    In the choose backup tab please make sure to include all for everything. Select all in 'source volume group' and 'volume pool' as well.

    You have to specify the pool that you want to eject in the eject tab. In the eject tab select daily_offsite pool.

    for example, if set the volume pool to 'Daily_Offsite' and this  is not the primary copy, it won't eject.

    There is document on this but I don't have that handy, will update once I have it.

     

     

  • By default , vault will choose the primary copy.

    If you want to use a different and non-primary copy, check out this technote: http://www.symantec.com/docs/TECH74265

     

  • Thanks for the replies...they were very helpful in gaining a better understanding of how vault works. Its been a while since I set it up to do duplications (I've been more accustomed to using SLPs with backup appliances), and I figured the "Choose Backups" meant "choose backups to eject". But as Sazz pointed out, thats in the Eject tab. I went that route to eject the "offsite" volume pool tapes. Not sure what happened that the GUI was showing me Primary copy for copy 1 and 2...maybe it was a screen refresh issue. I checked again and all looks fine.