Forum Discussion

cgcsym's avatar
cgcsym
Level 3
10 years ago

restoring exchange 2007 failed with error 2810 unable to create object for restore rai 17

I'm trying to restore mailbox or one single email from exchange 2007 through netbackup 7.6.1.1 but it's failing with  error 2810 unable to create object for restore rai 17. I have opened a case with symantec but no solution tell now, i feel the problem with the exchange server we have cluster. Can someone help in the issue please?

Note: Restore was workign before.

10 Replies

  • 1) Can I ask exactly which version of MS Exchange 2007 service pack and rollup/cumulative update, and NetBackup Client version the client is running right now?

    2) And exactly which version of MS Exchange and service pack and rollup/cumulative update and version of NetBackup Client the client was running when the backup was taken/saved/written?

    3) I'm asking so that we can determine whether the backup written/saved/taken from the same version of MS Exchange and NetBackup Client, as the restore is being atempted to?  Or has the MS Exchange service pack, and/or MS Exchange rollup/cumulative update, and/or NetBackup Client version changed since the backup was taken?

     

  • 1- exchange 2007 Rollup 13 and netbackup 7.6.1.1 on master server and client.

    2- The backup is still working now as before except one storage group is failing before it was 7.5.0.5

    3- We have recently updated the exchange to rollup 13 but the problem was before the update of exchange. The Netbackup version was updated.

  • Ok - apologies, I probably didn't ask the questions in the right manner - or explain why I asked them.

    Perhaps if you could fill in this table?

    Versions at point in time MS Exchange Client Media Master
    at time of backup 2007 SP? CU? v7.5.0.5 ? ?
    at time of restore 2007 SP? CU? v7.6.1.1 ? ?

    And the reason for asking is... It is possible that the MS Exchange database schema may have changed between versions of MS Exchange on the backup client.  i.e. whilst it should always be possible to restore from a backup of MS Exchange SP'a' CU'b' to MS Exchange SP'a' CU'b', it may not be possible to restore from MS Exchange 2007 SP'a' CU'b' to MS Exchange 2007 SP'c' CU'd'.  I would have thought that only Microsoft would be able to comment on whether backups of earlier versions of MS Exchange can be restored to later versions/updates of MS Exchange.

  • Take a look at the exchange server event log. It could be a obvious configuration issue

    Symantec has the following recommendation regarding 2810

    http://www.symantec.com/docs/TECH146996

  •  

    Dear Sdo,

    I don't have exact information about this because it's been tested under many senarios one time before exchange update and the netbackup and exchange both where 7.6.1.1 but later i have discovered that node2 was not updated it was 7.5.0.5 and i have upgraded it and tried the backup again and the restore but the same error. So now i'm trying to restore a recent backup with latest updates but same error exists.

    Versions at point in time MS Exchange Client Media Master
    at time of backup 2007 SP3 CU? v7.6.1.1 NU v7.6.1.1
    at time of restore 2007 SP? CU13 v7.6.1.1 NU

    v7.6.1.1

     

  • I'm getting the following warning in event viewer in exchange:

     

    Windows(R) Lightweight Directory Access Protocol (LDAP) failed a request to connect to Active Directory Domain Services(R) for Windows user <Domain\Administrator>.

    Without the corresponding UNIX identity of the Windows user, the user cannot access Network File System (NFS) shared resources.

    Verify that the Windows user is in Active Directory Domain Services and has access permissions

     

    and this is in system logs

     

    Client for NFS requested a mount with file locking enabled, and the remote Network File System (NFS) server does not support file locking.

    Client for NFS mounted the shared resource anyway. File locking may not be available.

    To avoid this warning in the future, enable file-locking suppport on the remote NFS server.

  • Sounds tricky.  I don't think I can offer anything else.  I think you've done the right thing in opening a support case.  Fingers crossed they are able to help you resolve the problem.

  • I think it's an exchange issue related to replication

    The error is related to the logs in exchange and most probably due to the logs not being in sync (replicated) with the active copy.

    Check the following link:

    https://www-secure.symantec.com/connect/forums/nbu-701-exchange-2010-dag

     

    and we have this error also in exchange server

     

    There was a problem with 'node1', which is an alternate name for 'node1'. The list of aliases is now 'node1', and the alias 'was' removed from the list. The specific problem is 'CreateFile(\\node1\f7d0a90a-bfe8-4f0d-b876-2142b3bcee2a$\E0B001076A6.log) = 2'.

  • Be aware you can't restore single mail without GRT option that require NFS access.

    Restoring the entire storage group, can be done without GRT option, please see:

    DOCUMENTATION: How to restore Exchange 2007 database backup to a Recovery Storage Group

    http://www.symantec.com/docs/TECH57346