Forum Discussion

stevenfoo's avatar
stevenfoo
Level 4
13 years ago

OpsCenter 7.1 started with HTTP 404

We had our NB Server hang yesterday evening and we were able to restart the server.

After restarting, the OpsCenter services could be started and runing. However accessing it via https://<servername>:8443/opscenter/ or https://<ipaddress>:8443/opscenter/ is giving us the following error

HTTP Status 404 - /opscenter/


type Status report

message /opscenter/

description The requested resource (/opscenter/) is not available.


Apache Tomcat/6.0.32

I have tried to find some solution as below, however non of them help.

http://www.symantec.com/business/support/index?page=content&id=HOWTO42624

C:\Program Files\Symantec\OpsCenter\gui\bin\goodies>configureports.cmd -status
Current Http Port: 8181
Current Https Port: 8443
Current Shutdown Port: 8105

I have also look at http://www.symantec.com/connect/forums/nbu-7-opscenter-cant-get-web-gui-alluse-work , however nothing help.

Anyone have any ideas is much appreciated.

7 Replies

  • Please check the tomcat.log and catalina.out files unser C:\Program Files\Symantec\OpsCenter\gui\webserver\logs to verify if they contain any exception message.

  • Below is the catalina.log file output. Tomcat.log have zero bytes. Any ideas what going on and how to fix it?

     

    Sep 15, 2011 2:41:50 PM org.apache.catalina.core.AprLifecycleListener init
    INFO: The APR based Apache Tomcat Native library which allows optimal performance in production environments was not found on the java.library.path: C:\PROGRA~1\Java\jre6\bin;.;C:\Windows\Sun\Java\bin;C:\Windows\system32;C:\Windows;C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;C:\Windows\System32\WindowsPowerShell\v1.0\;C:\Program Files (x86)\Dell\SysMgt\oma\bin;C:\Program Files (x86)\Dell\SysMgt\idrac;C:\Program Files\QLogic Corporation\QConvergeConsoleCLI\;
    Sep 15, 2011 2:41:50 PM org.apache.coyote.http11.Http11Protocol init
    INFO: Initializing Coyote HTTP/1.1 on http-8181
    Sep 15, 2011 2:41:51 PM org.apache.coyote.http11.Http11Protocol init
    INFO: Initializing Coyote HTTP/1.1 on http-8443
    Sep 15, 2011 2:41:51 PM org.apache.catalina.startup.Catalina load
    INFO: Initialization processed in 1419 ms
    Sep 15, 2011 2:41:51 PM org.apache.catalina.core.StandardService start
    INFO: Starting service Catalina
    Sep 15, 2011 2:41:51 PM org.apache.catalina.core.StandardEngine start
    INFO: Starting Servlet Engine: Apache Tomcat/6.0.29
    Sep 15, 2011 2:41:52 PM org.apache.catalina.startup.HostConfig deployWAR
    INFO: Deploying web application archive opscenter.war
    Sep 15, 2011 2:42:09 PM org.apache.catalina.startup.HostConfig deployDirectory
    INFO: Deploying web application directory ROOT
    Sep 15, 2011 2:42:09 PM org.apache.coyote.http11.Http11Protocol start
    INFO: Starting Coyote HTTP/1.1 on http-8181
    Sep 15, 2011 2:42:09 PM org.apache.coyote.http11.Http11Protocol start
    INFO: Starting Coyote HTTP/1.1 on http-8443
    Sep 15, 2011 2:42:10 PM org.apache.jk.common.ChannelSocket init
    INFO: JK: ajp13 listening on /0.0.0.0:8009
    Sep 15, 2011 2:42:10 PM org.apache.jk.server.JkMain start
    INFO: Jk running ID=0 time=0/32  config=null
    Sep 15, 2011 2:42:10 PM org.apache.catalina.startup.Catalina start
    INFO: Server startup in 18817 ms
    Sep 15, 2011 4:48:23 PM org.apache.coyote.http11.Http11Protocol pause
    INFO: Pausing Coyote HTTP/1.1 on http-8181
    Sep 15, 2011 4:48:23 PM org.apache.coyote.http11.Http11Protocol pause
    INFO: Pausing Coyote HTTP/1.1 on http-8443
    Sep 15, 2011 4:48:24 PM org.apache.catalina.core.StandardService stop
    INFO: Stopping service Catalina
    Sep 15, 2011 4:48:37 PM org.apache.coyote.http11.Http11Protocol destroy
    INFO: Stopping Coyote HTTP/1.1 on http-8181
    Sep 15, 2011 4:48:37 PM org.apache.coyote.http11.Http11Protocol destroy
    INFO: Stopping Coyote HTTP/1.1 on http-8443
    Sep 15, 2011 4:56:31 PM org.apache.catalina.core.AprLifecycleListener init
    INFO: The APR based Apache Tomcat Native library which allows optimal performance in production environments was not found on the java.library.path: C:\PROGRA~1\Java\jre6\bin;.;C:\Windows\Sun\Java\bin;C:\Windows\system32;C:\Windows;C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;C:\Windows\System32\WindowsPowerShell\v1.0\;C:\Program Files (x86)\Dell\SysMgt\oma\bin;C:\Program Files (x86)\Dell\SysMgt\idrac;C:\Program Files\QLogic Corporation\QConvergeConsoleCLI\;
    Sep 15, 2011 4:56:31 PM org.apache.coyote.http11.Http11Protocol init
    INFO: Initializing Coyote HTTP/1.1 on http-8181
    Sep 15, 2011 4:56:32 PM org.apache.coyote.http11.Http11Protocol init
    INFO: Initializing Coyote HTTP/1.1 on http-8443
    Sep 15, 2011 4:56:32 PM org.apache.catalina.startup.Catalina load
    INFO: Initialization processed in 1946 ms
    Sep 15, 2011 4:56:32 PM org.apache.catalina.core.StandardService start
    INFO: Starting service Catalina
    Sep 15, 2011 4:56:32 PM org.apache.catalina.core.StandardEngine start
    INFO: Starting Servlet Engine: Apache Tomcat/6.0.32
    Sep 15, 2011 4:56:32 PM org.apache.catalina.startup.HostConfig deployWAR
    INFO: Deploying web application archive opscenter.war
    Sep 15, 2011 4:56:49 PM org.apache.catalina.startup.HostConfig deployDirectory
    INFO: Deploying web application directory ROOT
    Sep 15, 2011 4:56:49 PM org.apache.coyote.http11.Http11Protocol start
    INFO: Starting Coyote HTTP/1.1 on http-8181
    Sep 15, 2011 4:56:50 PM org.apache.coyote.http11.Http11Protocol start
    INFO: Starting Coyote HTTP/1.1 on http-8443
    Sep 15, 2011 4:56:50 PM org.apache.jk.common.ChannelSocket init
    INFO: JK: ajp13 listening on /0.0.0.0:8009
    Sep 15, 2011 4:56:50 PM org.apache.jk.server.JkMain start
    INFO: Jk running ID=0 time=0/30  config=null
    Sep 15, 2011 4:56:50 PM org.apache.catalina.startup.Catalina start
    INFO: Server startup in 18440 ms

  • We get he symantec support person to look into our case. So far the person are not sure and no clue of what's going on even abt 2 hours webex session.

    All we are as is to reinstall OpsCenter on another server and update them accordingly.

  • A brief review of the case notes, I would like to see the following...   (NBSU & OpsCenter Support

    It appears an OpsCenter Support was attempted, however, it did not appear to gather any information.

    Keep in mind with Windows 2008, you may need to execute the command window using RUN AS Administrator option.

    Ensure the command window is opened using the Run As Admin option, and execute the OpsCenterSupport.bat script from ./installpath/OpsCenter/Server/bin/OpsCenterSupport.bat

    Answer yes to all inquires, then FTP to support for review... Once uploaded... I can review the output as well and verify if there is an environmental or configuration issue with the server.

    In addition, if the NetBackup client is installed, also gather an NBSU from the OpsCenter host.

    ./installpath/netbackup/bin/support/nbsu

    ----  Tom

  • Hi Steven,

    Did you ever get to resolve this? I just updated my Opscenter to 7.1.0.3 and I am having the same HTTP 404 issue. 

    Trying just the http://<servername>:8443/, i get 

    No Web Console is currently online 

    I am running on a window 2003 x86 and all Symantec Opscenter services are running.