Forum Discussion

7 Replies

  • have you ever tried to restart VEA services?

    /opt/VRTSob/bin/vxsvc -m
    /opt/VRTSob/bin/vxsvc -k
    /opt/VRTSob/bin/vxsvc -m
    /opt/VRTSob/bin/vxsvc

    If it doesn't help,  while there is a manual procedure to reconfigure vea, I wouldn't suggest so before you try restart of vea.
  • Hello,

    Did all the agents started fine when you did installf -configure ?

    also could you check for what agents are running ?

    # ps -ef | grep -i agent
    # vxsvc -m


    Gaurav
  • Sorry for the late update, I had another issue which needed to be fixed. My server wouldn't boot, and I learnt about the HOTFIX they have for.
    So the issue is that I don't see any controllers/ diskgroups/volumes etc. I only see filesystems. There is no issue with VEA starting up.


    /opt/VRTSob/bin/vxsvc -m
    Current state of server : RUNNING

    ps -ef | grep agent
    root 619 1 0 16:16:06 ? 0:01 /opt/VRTSobc/pal33/bin/vxpal -a actionagent -x

  • Well something is wrong here...

    I would expect more agents to run here, you should see StorageAgent running to see VxVM objects.... you can start it manually with following command:

    /opt/VRTSobc/pal33/bin/vxpalctrl -a StorageAgent -c start

    once started, check again if you see the objects, if not, you can try running installsf -configure again after starting storageagent....

    Gaurav

  • Unfortunately I ran into this same issue (case 312-156-643)  and after uninstalling all of the VRTSob packages allong with VRTSVail, the only fix was a complete reinstall of SFHA for Oracle.  Luckily it was a two node cluster, so we continued working on the passive box while rebulding the other node.  The most important caveat I found was to make sure all DNS information and network connectivity is correct.  I was able to resolve this once before by Re-Registering the agent Domains for SF after fixing some dns issues. That however was not the fix this last time around. 

    Joe D
  • Several attempts of installsf -configure have made not progress. I am glad someone else has see this. Please take a look at the vxdctl list output below. hostguid is not mentioned in the man pages but still appears here. BTW we've swapped the  hostid on the server, the other server is not showing any issues due to this.


    vxdctl list
    Volboot file
    version: 3/1
    seqno: 0.11
    cluster protocol version: 60
    hostid: mcmsfoudb01-2
    defaultdg: rootdg
    bootdg: rootdg
    hostguid: {ce07cd66-1dd1-11b2-be1a-0003babfdf1d}

  • As mentioned above, whther all DNS entries are correct  ?

    Also, were you able to start the storage agent & check again ?

    check in /etc/resolv.conf  also /etc/default/csf_resolv.conf

    U could also attempt to reinstall VRTSob package ....


    Gaurav