Highlighted

Virtual Machine Does Not Exist Error

Hi,

I am using Application HA 6.0 with Veritas 6.0.5 on Red Hat Enterprise Linux 6.5. I am following this user guide:

http://kbdownload.symantec.com/resources/sites/BUSINESS/content/live/DOCUMENTATION/5000/DOC5106/en_US/appha_userguide_60_lin_kvm.pdf?__gda__=1429210399_5eb5a02820d1e9abf4c20cf90c19f37e

When I get to here:

hasys -value VirtGuest ConnectionState 

I get an error that the Virtual Machine does not exist.

The output of the command:

hares -value virt_name CEInfo

Looks ok and I can see the hostname of the server. Also the Virtual Machine has been added as a KVM resource. I can see that the system has been successfully registered for Application HA:

./enable_applicationha -status virt_name

VIRTUAL MACHINES REGISTRATION

virt_name.................................................................................................................................................... Registered

On a previous project a couple of years ago I can see the following line in main.cf:

virtualsystem VirtGuest (
        )

However this line is missing from the main.cf this time. However I really cannot remember what I did different. So my question is; how do I add a virtualsystem to the cluster? Which step should add this?

Thanks for your help!

1 Reply
Highlighted

Hi, Is the virtual machine

Hi,

Is the virtual machine VirtGuest running? If yes, is Symantec ApplicationHA running inside  the virtual machine?

The "virtualsystem" object gets created only after the virtual machine successfully connects to the KVM host. To ensure connection, the virtual machine as well as ApplicationHA inside the virtual machine must be running.

Regards,

Amit