cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted

2012 SP4: Agent Linux Oracle problem

Hello,

I have problem with credential test - see image below.

oracle.png

I used AgentConfig to configure database and instance access with another account. Configured account backupexec for system access and be_backup for Oracle DB access and it seems to be OK:

b576d700 Thu Jul 24 13:02:13 2014 : OCIINTERCONNECT::LogonOracle: db = (a), home_dir = (/), user =(b), passwd= (****)
b576d700 Thu Jul 24 13:02:13 2014 :  Current Oracle user name (be_backup)
b576d700 Thu Jul 24 13:02:13 2014 : putenv(ORACLE_SID=adb11)
b576d700 Thu Jul 24 13:02:13 2014 : putenv(ORACLE_HOME=/opt/oracle/product/11.2.0/adb11)
b576d700 Thu Jul 24 13:02:13 2014 : OCIServerAttach() Linux 1
b576d700 Thu Jul 24 13:02:13 2014 : OCIINTERCONNECT::LogonOracle: Logon is successful
b576d700 Thu Jul 24 13:02:13 2014 : OCIInterconnect: Logon Successful
b576d700 Thu Jul 24 13:02:13 2014 : OCIINTERCONNECT:Smiley SurprisedracleIsRAC:- tq = select PARALLEL  from v$instance where instance_name='adb11' Sidname = adb11
b576d700 Thu Jul 24 13:02:13 2014 : OCIINTERCONNECT:Smiley SurprisedracleIsRAC: query = (select PARALLEL  from v$instance where instance_name='adb11')
b576d700 Thu Jul 24 13:02:13 2014 : CONFIG_ORACLE_ISRAC,TEXT(NO)
b576d700 Thu Jul 24 13:02:13 2014 : I Linux: SIDName adb11 is not part of RAC. Seems to be a normal setup. Adding DLE
b576d700 Thu Jul 24 13:02:13 2014 : OCIInterconnect: logoff successful

But in Oracle log, I found that user ROOT was trying to login:

24-JUL-2014 13:02:13 * (CONNECT_DATA=(SERVER=DEDICATED)(SERVICE_NAME=adb11)(CID=(PROGRAM=beremote)(HOST=adb-o11g)(USER=root))) * (ADDRESS=(PROTOCOL=tcp)(HOST=192.168.10.10)(PORT=47388)) * establish * adb11 * 0


24-JUL-2014 13:02:13 * (CONNECT_DATA=(SERVER=DEDICATED)(SERVICE_NAME=adb11)(CID=(PROGRAM=beremote)(HOST=adb-o11g)(USER=root))) * (ADDRESS=(PROTOCOL=tcp)(HOST=192.168.10.10)(PORT=47389)) * establish * adb11 * 0

I've used SGMON and beremote --log-console to find a cause of that problem but no luck.

Server and agent are both 2012 SP4 version. Agent runs on RHEL 6 and Oracle 11gR2.

 

 

3 Replies
Highlighted

What version of RHEL are you

What version of RHEL are you running?  BE 2012 only support up till RHEL 6.2.

Highlighted

Yes, it's obvious that

Yes, it's obvious that Symantec has not been able (willing) to support RHEL 6.5 which was released on November 21, 2013! Anyway as I wrote earlier, I cannot see any error or warning.

Highlighted

The latest version of BE

The latest version of BE supports RHEL 6.5

Consider evaluating the new version or an upgrade and see if helps resolve this issue. Additionally, BE 2014 has many other features and fixes which I would recommend over BE 2012.