Highlighted

Amazon S3 offline this device has not been discovered correctly

I have backup exec 15 running.  When I first installed, I was able to connect to amazon S3 and backup data to a bucket that I created.  This worked for a few days. Then all of a sudden the Amazon S3 storage device says "offline this device has not been discovered correctly and to restart services.  I restarted services, rebooted, removed/re-added, etc - and I can't figure it out.  Not sure if there's a network communiaction issue between my amazon instance and S3 or what.  It seems my config is correct because I was able to get it working for a few days.  If I remove and re-add it seems to connect as it finds my S3 bucket, but the storage just stays offline.  Not sure how to diagnoise.

 

6 Replies

Re: Amazon S3 offline this device has not been discovered correctly

Event Log Error: S3:amazon:amazon.com:climatecenter - Unable to connect to the OpenStorage device. Ensure that the network is properly configured between the device and the Backup Exec server. 

Re: Amazon S3 offline this device has not been discovered correctly

Run through the TN below and make sure everything is configured as shown:

https://www.veritas.com/support/en_US/article.000081253

THanks!

Re: Amazon S3 offline this device has not been discovered correctly

Did you ever get this working? 

I am having the same problem (BE 15 Feature Pack 3, so I have the updated cloudprovider.xml file). I followed the steps in the TN to no avail. I, like you, had it working for a brief period. There is no network connection issue between my server and s3. Any suggestions? 

Re: Amazon S3 offline this device has not been discovered correctly

I am having the same issue!  I was having the issue on FP3 and just upgraded to FP4 hoping that would solve the problem.  It did not, I did just re install the Cloud Connector.XML file and that did not work either..

 

I was able to test the credentials to the Amazon S3 server by using the Configuration and Settings>Logon Accounts>Manage Logon Accounts> Test screen.  It tested Sucessful after a few seconds!

 

Anyone please help, Veritas won't support, and my Cloud backups have been down for a week!!

 

Thanks In Advance,

 

-Justin

It happens the same to me.

It happens the same to me. Several months ago I'd opened a thread but I didn't have any answer at all: http://www.veritas.com/community/forums/incremental-backup-configured-over-amazon-bucket-fails

I'm "not worried" since I'm doing my backups with Amazon snapshots but if I can't use Veritas software for our backups, I won't renew our maintenance.

Hope this time anyone could help us.

Re: Amazon S3 offline this device has not been discovered correctly

I'm curious if you are using rules on the bucket to move data from S3 to Glacier.  I had my S3 bucket set up to immediately transfer any data to Glacier Storage.  Backup Exec can not talk to Glacier storage directly, and when it tries to bring that storage device, it looks for certain files at the destination.  Which in this case it can't find because they are on Glacier.

To get the storage device to come up again, I "restored" those specific files from Glacier back to S3.  Once it saw them the device was able to come online.

The folder it looks for is BEOST_Sinf and the three files within it.

For a permanent fix, I do all my backups to the bucket first, and then move the data to glacier storage.  If I ever had to access that data again, I'd have to restore at least those files from Glacier back to S3, and probably any actual files I wanted to access.  Of course, I only do quarterly backups to the cloud and don't ever really need them.  

Hope that helps.