Highlighted

Append media problems, PLEASE HELP!!

Hi guys,

Trying to backup 2 servers to 1 tape when seems to back them up fine but it overwrites the 1st server when backing up the 2nd server, so only end up with the 2nd server backed up.

I think I'm doing it right but would lilke some clarification if at all possible please.

I've got my 1st server (Job) set to "Overwrite Media" and the 2nd Server (Job) set to "append to Media, overwrite if not appendable media is available".

In the backup settings/storage I've just set this morning for tonight, I've set it to "Partial protection" and unticked the prompt option. Before it was set to NONE but before that it was on FULL protection and wouldn't backup because it complained it was protected.

The backup sets are set as followed;

Protection period - 3 weeks

Append period - Infinite - Allow append

I had the backup sets like this in 2010 and backing up to a NAS box which seemed to work fine and it kept the data until the protection period had expired. If I backed up any other data before the expriation date it just added to it instead of overwriting it.

I would like to backup both servers on 1 tape and keep about 2-3 weeks worth backups before overwriting anything, what am I doing wrong?

Many thanks,

James

24 Replies

Re: Append media problems, PLEASE HELP!!

In the backup settings/storage I've just set this morning for tonight, I've set it to "Partial protection" and unticked the prompt option. Before it was set to NONE but before that it was on FULL protection and wouldn't backup because it complained it was protected.

A setting of "none" would cause the overwrite issue you mentioned.  Things should be good now that you are set to "partial".

Re: Append media problems, PLEASE HELP!!

When you set the OPL to None, all the OPP does not apply and your tapes are unprotected.  You need to set it to either Partial or Full to protect your tapes.

You also need to make sure that you have sufficient overwritable tapes BEFORE the start of your jobs.

Note that for BE 2012, none of these applies to disk media which are managed by DLM, rather than media sets.

Re: Append media problems, PLEASE HELP!!

Hi guys,

Thanks for the replies :-).

Ok so both jobs have been set to "append to Media, overwrite if not appendable media is available". I want to add to the tape not overwrite it straight away.

Also the backup sets are set as followed;

Protection period - 3 weeks

Append period - Infinite - Allow append

And the backup settings/storage is set to "Partial Protection" prompt option unticked.

Fingers crossed that should work :-).

Thank you very much,

James

 

 

Re: Append media problems, PLEASE HELP!!

Hi guys,

Ok last night it still complained about overwrite protection problems when backing up the 2nd server and failed because it ejected the tape and wasn't put back in.

I've set the backups settings to everything I posted on the previous message :-) :-).

I've attached a screenshot of the error/information.

Many thanks,

James

Re: Append media problems, PLEASE HELP!!

Hi guys,

Any more suggestions on this please?

I've had to set the backup settings\storage to "none" and untick the prompt, then on the first job set to overwrite when it runs and the second job to "Append to Media, overwrite if no appendable media is available".

It will then backup both servers without a problem and doesn't overwrite the previous server job. I've had to set the backup sets as well to 1 day so it doesn't complain about overwriting protection errors as well.

I want to add data to the tapes for a couple of weeks before it starts overwriting data, so i can get more backups rather than a weeks worth on a tape then have to overwrite it.

Regards,

James

Re: Append media problems, PLEASE HELP!!

When you set the OPL to None, then your OPP does not apply and your tapes have no protection. You should set the OPL to either Partial or Full

Re: Append media problems, PLEASE HELP!!

I know that but I've done everything you've said and it still complains it's overwrite protected and won't go any further.

I want to set the OPP for 3 weeks because the tapes are change fortnightly and hope to get 1 months worth of DATA backups rather than just 2 weeks.

So when it comes round to the tapes being used for backup again, I wanted to append to it then it will overwrite on the next fortnightly occurence. Hope that makes sense

OPP was set to 3 weeks last time and it complained about the protection problems, so for now i've had to set the OPP to 1 day to make sure when it comes around to the next backup on that tape, it will backup the data at least without any protection complaints and had to change the OPL to None as well.

Kind Regards,

James

Re: Append media problems, PLEASE HELP!!

Read this document http://www.veritas.com/docs/000032654 Check that you have sufficient overwritable tapes BEFORE the start of your jobs

Re: Append media problems, PLEASE HELP!!

I've had to set the backup settings\storage to "none" and untick the prompt, then on the first job set to overwrite when it runs and the second job to "Append to Media, overwrite if no appendable media is available".

It will then backup both servers without a problem and doesn't overwrite the previous server job. I've had to set the backup sets as well to 1 day so it doesn't complain about overwriting protection errors as well.

Using "none" is a very bad idea, in my opinion.  Yes, it may get things running now, which is good to prove that the hardware works, but it will come back to haunt you at some point in the future when BE overwrites a tape that you wanted/needed to keep.

Please select "partial" and I suggest leaving the "prompt before overwriting imported media" checked.

The backup sets are set as followed;

Protection period - 3 weeks

Append period - Infinite - Allow append

Those setting look reasonable and match what you stated your intentions were, so I think that you are good there.

A common error is for users to put tapes into the media set manually.  The correct procedure is to leave the tapes in the "scratch" media set and let BE move them into the target media set at the time that the tape is actually used.

I believe that you are using a single stand-alone tape drive, without a robotic library.  Is that correct?

Do your two backup jobs use the same media set?  If you want to servers to backup onto one tape, they MUST use the same media set.  Your screenshot shows the media set name as starting with "Filer5".  If you have a different media set for the "CAD2" server backup job, then will never be on the same tape.

I thought that might be the

I thought that might be the case when using the None option but I won't be here when the backup is occuring.

So I'd need the prompt option to be unticked on the partial option and I've done the same anyway when I used the NONE option, it was unchecked too.

So it's possibly they way I've been introduced the tapes intially, I have been giving them a selected a Media set I created Manually.

I am using a single tape drive and the both servers are using the same media set when I have run the backups.

Thanks,

James

Re: Append media problems, PLEASE HELP!!

Hi Guys,

OK so I've now set it as shown below and appears to be working so far and appending to the media instead just overwriting it every week, plus not complaining about protection issues.

  • Backup Settings/Storage is set to "Partial", prompt option is unticked.
  • Backup set is set  "Overwrite Protection Period" is set to "3 days" and "Append Media" is set to 3 Weeks"
  • Both backup jobs are also set to "Append to Media, overwrite if appendable media is unavailable"

It's backed up both servers without overwriting the previous server job and it's appended to the tape and kept the data from the previous backup 2 weeks ago, which is exactly what I wanted.

So I'm now assuming when the Append media period has expired, it will then overwrite the oldest data backup or will it just overwrite everything and start again as if there was no previous backups. Hopefully someone knows what I mean :-).

Shall I just set the Backup OPP to 3 weeks as well??

Many Thanks,

James

 

When a tape is overwritten,

When a tape is overwritten, all the Data on it is gone

Re: Append media problems, PLEASE HELP!!

So I'd be using this append to media option for nothing really then, i'd have 2 weeks worth of backups then it'll all be gone.

Is it maybe best to set my Overwrite Protection Period for 3 weeks and my Append media to 3 weeks as well or will I still loose all the data??

I used to backup onto Nasbox's (B2D), the OPP was set to 3 - 4 weeks and append media Infinite Allow but if the OPP hadn't expired it just appended to it, is that because it's NASbox and not a tape??

Many Thanks,

James

For BE 2012 onwards, disk

For BE 2012 onwards, disk backup sets are managed by DLM, not media sets. For disk media there is no append. See this document https://www.veritas.com/support/en_US/article.HOWTO99585

Re: Append media problems, PLEASE HELP!!

Ok thank you PKH,

I think i've sorted the appending problem anyway, even if it overwrites after the expiration date, I've just set both the Overwrite protection and Append Media Periods to 3 weeks.

Both jobs are set to Append to media, overwrite if no append media is available..... So I assume once the 3 weeks Append Media period has expired and so has the overwrite protection period, it will start to overwrite the data, is that correct??

Thanks,

James

Re: Append media problems, PLEASE HELP!!

Both jobs are set to Append to media, overwrite if no append media is available..... So I assume once the 3 weeks Append Media period has expired and so has the overwrite protection period, it will start to overwrite the data, is that correct??

Yes, basically, BE will do whatever it is allowed to do to the media (based upon the media set rules) and what the job is configured for (overwrite only, append only, or whatever is best).

Re: Append media problems, PLEASE HELP!!

Thanks Larry :-).

Ok I came in this morning after setting the overwrite protection to 3 weeks and the Append is also 3 weeks.

If both jobs are set to Append to media, overwrite if no appendable media is available.

Why has it come back with it error/information message again saying protected and cannot overwrite but I've set it to append not overwrite, so I don't understand when this has occurred??.

Thanks,

James

Is the second job filling the

Is the second job filling the remaining space on the tape as it will ask for another tape if it does and this subsequent tape has to be an overwrite operation

Re: Append media problems, PLEASE HELP!!

No the tape has plenty of space left, the tapes can take probably about 3 FULL backups job, each job including the 2 servers I mean, so 6 backups really, then it will need to be overwritten.

Thanks,

james