cancel
Showing results for 
Search instead for 
Did you mean: 

BE 2010 R3 & MS Exchange 2003 - Help

Hi everyone, we have installed be 2010 R3 and its working really good in all the servers except in Exchange Server.

We have 4 StoreGroups each one with 4 datastores

The first error i got was:

V-79-57344-65233 - AOFO: Initialization failure on: "\\xxxxx\Microsoft Information Store\xxxxx-SG1".... Snapshot provider error (0xE000FED1): A failure occurred querying the Writer status. Check the Windows Event Viewer for details.

After this error, i ve check the vss status using 'vssadmin list writers' and got:

Writer name: 'Microsoft Exchange Writer'
   Writer Id: {76fe1ac4-15f7-4bcd-987e-8e1acb462fb7}
   Writer Instance Id: {186796db-c500-4123-bc94-ef75de83d12b}
   State: [7] Failed
   Last error: Retryable error

When i tryed to dismount a store it said "unable to perform operation a backup process is running"

Possible solutions: a) restart information store b) reboot servers c) apply a MS kb patch for vss (and then reboot).

Solved

But when i try to backup again next day the exchange server shows me again the vss error, and the backup process again locks the stores.

I got the error log with new errors and exceptions

V-79-57344-65298 - The Exchange Store service is not responding. Backup set canceled. (???????)

V-79-57344-34108 - An unexpected error occurred when cleaning up snapshot volumes. Confirm that all ... - AOFO: Initialization failure on: "\\xxxxx\Microsoft Information Store\xxxxx-SG2". Advanced Open F...

What i did to try resolving the issue.

a) install windows kb patch for vss -

b) change the vss in the AOFO if symantec using vss provider:System

c) reboot the exchange server and resintall backupexec agent.

no one helped.

 

Anyone could help me with this???

 

Thanks!!

 

Mariano

7 Replies

b) change the vss in the AOFO

b) change the vss in the AOFO if symantec using vss provider:System

Try not to select the AOFO option.

 

Thanks,

-Sush...

Trying... but if i disable

Trying... but if i disable aofo, it will let me make incremental or diferential backups with grt ???

 

Thanks!!

Thats not the case at all.

Thats not the case at all. AOFO has nothing to do with GRT backups. Infact AOFO is not recommended for Exchange backups. For Exchange 2007 and 2010 it by default uses VSS on the Exchange machine.

 

Thanks,

-Sush...

Hi Mariano,   OK, so the real

Hi Mariano,

 

OK, so the real issue is that your VSS writers are not all stable and running, which is why you get the error. Since you've already tried the server reboot and it hasn't worked, I'd suggest you reregister the VSS *.dlls if running Windows Server 2008, or install the VSS Rollup Patch if running Windows Server 2003 (you don't mention the OS).

1. VSS Reregister (can also work for Win2K3!)

http://www.symantec.com/business/support/index?page=content&id=TECH70486

2. VSS Rollup Patch for Win2K3 (not sure if this is what you loaded!)

http://support.microsoft.com/kb/940349

 

If you've installed the AOFO on the Exchange server, you can run a program modify through Add/Remove Programs and remove that option from it...

 

Thanks!

Hi thanks for the

Hi thanks for the reply.

Sush:

Right now with the aofo turned off, the backup works, with some warings.

It was a full bakcup, now... if a try to restore something with grt, it says that the database has to be unmounted.

This is for some special reason?. i cannot restore a single item to a mailbox while the database is mounted and running??

Craig:

The OS is windows 2003 r2 sp2, i already have installed the vss rollup form MS.

When i deploy the BE Agent it just install the windows agent, symantec/veritas vss is not installed.

 

 

Thanks guys!

You should be able to restore

You should be able to restore the individual items when the database is mounted. You should not be getting that error unless the complete database is selected for restore.

 

Thanks,

-Sush...

It won't install the VSS

It won't install the VSS component...BE just leverages this off the OS itself. It WOULD install AOFO if you selected that option within the RAWS installation.

I also assume here your media server is fully patched, and that these patches have been push-installed to your remote servers?