cancel
Showing results for 
Search instead for 
Did you mean: 

Backup Exec 11d Rev 7170 Remote agent and Registry problem?

This error happened to a server about 2 weeks ago, and I tried to reinstall the remote agent.  Uninstall wouldn't work, so I had to go into the registry and remove backup exec, and use Windows Install Cleanup to remove the rest of it.   After this I was able to reinstall the remote agent, and back up the server for about a week.
 
Now, this error is not only occuring once again on the same server, but also on another server.
 
The Remote Agent Service will not start, it will just time out, and under services states it is "Starting".
Upon open the Remote Agent Utility and going to the publishing tab, an error message is received:
"Unable to obtain settings for remote agent publishing from the registry"
 
What could be causing this error and how could I fix it?  These servers have been backing up fine for the past 6 months I've been here, plus some.
 
Server 1:  Win 2003 Server Standard.  Remote agent installed from 11d 7170
Server 2:  Win 2000 Server  SP4.  Remote agent installed from 11d 7170
Media Server:  Win 2003 Server Standard SP1.  Backup Exec 11d  Rev 7170.  No Updates installed.
 
 
Thanks,
David Howell
6 Replies

Re: Backup Exec 11d Rev 7170 Remote agent and Registry problem?

David,

Is the remote agent set to use Local System or a user account in the properties of the service?

Re: Backup Exec 11d Rev 7170 Remote agent and Registry problem?

Both are set to log on as Local System.  I tried using a User account with Admin priviledges that we have set up just for Backup Exec, and it isn't working with that either.


Message Edited by D Howell on 12-07-2007 09:02 AM

Re: Backup Exec 11d Rev 7170 Remote agent and Registry problem?

Any ideas on what could be causing this?  I've compared the registry entries on these servers, to servers that are working, but didn't notice anything out of the ordinary.  There were some things different, but I don't know enough about the registry to tell what could be causing a problem.

Re: Backup Exec 11d Rev 7170 Remote agent and Registry problem?

I did some checking on other cases that were having the same issue, seems most of them were fixed by just cycling the remote agent service.  Not sure if this helps or not.  But I would suggest opening a case for the issue if it continues.

Re: Backup Exec 11d Rev 7170 Remote agent and Registry problem?

Hi David,
 
Im facing the same problem and unable to fix it, Can you pls let me know the solution if you find it. pls reply ASAP...
 
Thanks
 
Dhaval

Re: Backup Exec 11d Rev 7170 Remote agent and Registry problem?

Have a look in the registry at the key HKLM\SOFTWARE\Symantec\Backup Exec for Windows\Backup Exec\Engine\Agents
There are some keys in there to do with advertising. It might be an idea to make sure that the permissions are open enough that the key can be read.


Message Edited by Hywel Mallett on 12-20-2007 02:15 PM