cancel
Showing results for 
Search instead for 
Did you mean: 

Backup Exec 15 Error with Amazon S3 Config

Hello,

I receive an error every time I try to configure an Amazon S3 bucket as a storage device I get the error: BEMSDK Failure Code: A0009B23.

I am running on server 2012 R2, using Backup Exec 15 FP1.

I have gone through and installed the latest update that hot fixed this connection issue with S3.  I have followed the how to doc for connecting S3 as a storage device.  I have disabled the firewall to see if that was the issue.  I created a user specified account in AWS to try accessing the S3 buckets.  I tried my admin credentials as well and am still unable to connect, receiving the same error.

I have looked online as well as this forum to see if there is a solution but have found none.  I am wondering if anyone has had the same problem and if so has come up with or found a solution.

 

Thank you!

1 Solution

Accepted Solutions
Accepted Solution!

Please see the following

Please see the following Support Article: https://www.veritas.com/support/en_US/article.000094413

This Support Article only applies to Backup Exec 15 Feature Pack 1 with the ODP patch. Future Feature Packs already contain the updated CloudProvider.xml-file.

Thanks,

@BackupMikko

View solution in original post

13 Replies

Go to Programs and Features

Go to Programs and Features and do a repair of BE

Was this article followed on

Was this article followed on configuring the cloud connector ?

https://www.veritas.com/support/en_US/article.000081253

If yes, are there any errors logged in adamm.log and/or Windows Event Viewer ?

Can you enable SGmon debugging and try to configure the storage again. Pls attach the debug log.

PKH - I went ahead and tried

PKH - I went ahead and tried a repair of BE, I still received an error upon configuring to S3 storage.

VJware - I followed that exact article on how to connect S3.

I looked through the event viewer and did not see any errors pertaining to Backup Exec.

When I installed Backup Exec, it came along with SQL 2008, would there be an issue with the connection to S3 due to SQL for any reason?

I enable debugging and have attached the log.

 

I failed to mention that this is a trial version as we are in the process of obtaining licenses, would this be an issue?

 

Thanks!

VJware - Step 6 of the

VJware - Step 6 of the articles instructions, is that the correct syntax we are to enter into the servername field, "amazon:amazon.com"?

Or are we supposed to provide the S3 link instead?

 

Thank you! 

The password being used...

The password being used... does it have complex characters such as a # ?

 

 

 

 

The passwords are generated

The passwords are generated automatically as amazon keys.  Some keys may or may not have special characters.

We have tested both keys and have received the same error.

amazon:amazon.com is

amazon:amazon.com is fine.

Are you able to access amazon.com and/or https://s3.amazonaws.com from the BE media server ?

If yes, would recommend logging a formal support case. Thanks.

Accepted Solution!

Please see the following

Please see the following Support Article: https://www.veritas.com/support/en_US/article.000094413

This Support Article only applies to Backup Exec 15 Feature Pack 1 with the ODP patch. Future Feature Packs already contain the updated CloudProvider.xml-file.

Thanks,

@BackupMikko

View solution in original post

@BackupMikko - I went to the

@BackupMikko - I went to the support article and was unable to download the patched file.  I received errors on Firefox, Chrome and a blank screen on IE.

Attached are the errors.

Right-click on the

Right-click on the attachement and choose save link as. You'll be able to download the xml file then.

Have also attached the file over here.

Make sure you right-click (on

Make sure you right-click (on Windows) or "<control>-Click"/Two-finger click (on OS X) and select to Download the file instead of just clicking on the XML-file to open as otherwise the web browser will try to open the encrypted XML-file which will result in the errors.

Hopefully that helps!

Best,

@BackupMikko

SUCCESS! The XML file

SUCCESS!

The XML file solution worked!

I ran into once issue in that the amazon keys I was using were not working, when I did the initial test.  I did a second test with an amazon account specifically for S3 storage and it worked!

You have to be careful with which keys you are using from Amazon as the user must have the correct permissions.

Thank you VJware, @BackupMikko, and Steve Y for your input and solutions!

Hello @BackupMikko and

Hello @BackupMikko and @Lazo86

I've tried the solution suggested but I have the same problem described in the first post. I attach the message I receive once I configure the server (amazon:amazon.com) and the user/password I use to connect to s3.amazonaws.com:

Fallo configuración almacenamiento en la nube.jpg

My O.S is Windows Server 2012 R2 and the version of the Backup Exec is 15 Ver. 14.2 Rev. 1180.

Thanks in advanced.