Backup Exec 16 cannot recover single elements from virtual machines using GRT

I'm using Backup Exec 16 to backup 2 Vmware virtual machines with Active Directory and Exchange 2013. I have noticed that even if i have enabled GRT in the job options i can only restore the whole vmdk. I cannot restore single elements from Active Directory or Exchange using GRT. Both virtual machines have the backup exec agent installed. I'm using the default Microsoft VSS provider to backup the virtual machines. Jobs successfully complete without errors. I cannot understand why the backups aren't granular.

Tags (3)
4 Replies

Re: Backup Exec 16 cannot recover single elements from virtual machines using GRT

Have you installed 2 Agent for Applications and Databases licences for this VM?

Highlighted

Re: Backup Exec 16 cannot recover single elements from virtual machines using GRT

Yes, I have Capacity Edition Lite. Agent for applications and database license should be included.

Re: Backup Exec 16 cannot recover single elements from virtual machines using GRT

Have you installed the BE agent into the VMs?  Do you see the AD and Exchange servers on the  "Backup and Restore" tab?  The whole VM restore is started from the vCenter entry on the B&R tab, but the GRT restore from the corresponding server entry.

 

Re: Backup Exec 16 cannot recover single elements from virtual machines using GRT

Reinstalled the agents on the vms and the backups now look like granular backups. I can now see the two mailbox databases on Exchange and C: drive on Domain Controller. Before the reinstall i could see the corresponding server entry but the backup sets were empty as if there were no scheduled jobs on those servers. On AD the old agent was unable to start services for some unknown internal error. Checked again the BE log in job history and found a warning saying that no agent was found on the vm. I think when i updated BE from 15 to 16 something went amiss and the old agents stopped working.

Everything seems ok now. I'll have to restore those backups to be sure that they are really working.

Thanks