cancel
Showing results for 
Search instead for 
Did you mean: 

Backup Exec 20 Speeds

DCA-IT
Level 4

We back up a lot of data to tape and some of the jobs are over 6TB in size and are taking over a week to complete so I'm trying to improve speeds.

Slowest link in the LAN operates at a gigabit so I would expect to see speeds around the 200-250Mb/s mark which I am when copying files using something simple like Windows Explorer.

Whilst I know that I will never see the quoted speeds for tape devices, just like I will never see actual gigabit spees on the network, the stated write speed of LTO-6 is 1280Mb/s uncompressed and 3200Mb/s compressed while LTO-7 is 2400Mb/s uncompressed and a whopping 6000Mb/s compressed.

Backing up to tape using a test file set of a single 5GB file and twenty 200MB files, gives me speeds of around 120-160Mb/s while using hardware compression but this is not even in the same league as the stated speeds.

I've been experimenting with settings in BE to try and improve speed and have made some marginal gains tweaking the block and buffer sizes along with the number of buffers and the high-water mark.

Does anyone have experience with making significant improvements to their tape backup speeds?

4 REPLIES 4

Andr__Schild
Level 3
Partner

Do you have one job which is running sequencially for all sources, or do you have multiple Jobs which run concurrently?

Having them concurrently can improve overall performance, but if you have too much concurrent, then it beginns to drop again

Larry_Fine
Level 6
   VIP   

I would suggest setting the tape block & buffer sizes as large as they will go (512k-1024k, depending upon your environment).  Keep in mind the disaster recovery implications as you need an environment that can read those large blocks sizes.  Big block sizes can make a big difference in speed.  I would keep number of buffers and high water mark at their defaults as any improvment you see will likely be marginal.

Then you need to focus on your source speed and your connection speeds.  One of those is extermely likely to be your bottleneck.  LTO certainly can run at its rated speed, if you have a fast enough source.

We have two servers with multiple jobs on each. Jobs tend to run concurrently but will be from different sources to different tape drives. Some of these jobs are from NAS which are unsupported as there is no agent present so compression can't happen at the NAS end of the stream, only at the tape end.

Our sources have at least dual-teamed NICs which are trunked/aggregated at the switch end and both backup servers have quad-teamed NICs.

I've played around with the block & buffer sizes and have seen some slight gains but then the more testing I do these gains seem to evaporate. Currently we're getting around the 1TB per 24h mark to LTO-7 regardless of the block/buffer sizes.

I'm seeing some strange things on our LTO-6 setup too. Two identical jobs, both from the same storage to the same tape 3.16TB - 4d 5h 31m 43s at 1,827 MB/min and then 1d 18h 38m 39s at 2,080 MB/min