Highlighted

Backup exec job engine failed to start

BackupExecJobEngine service hangs at 'Starting'. Earlier the problem started when the job was stucking at 'Active: Running' completes some 10 GB to the drive and hangs there. Then i restarted the services where this resulted in BackupExecJobEngine service hangs at 'Stopping'. After this only now the service hangs at Starting. Is this related Backup exec or the tape drive(currently using HP Ultrium 1760). Can someone help me to resolve this issue?

Tags (2)
7 Replies
Highlighted

Re: Backup exec job engine failed to start

You can do the following: * Stop the BE services and run the HP LTT tool against the drive to rule out any hardware issues; * Check the Alerts tab to see if there are any issues listed; * Make sure that any AV installed isn't blocking activity during the backup; * Make sure BE is fully patched by running LiveUpdate and installing what's available. Thanks!
Highlighted

Re: Backup exec job engine failed to start

Thanks for the reply. Initially when i had this issue i did the Drive assessment test and it gave me error while soft unload. But after doing a drive power drain  this issue was solved and the test passed successfully. For the update feature pack five is available which i tried but getting error 'LU1812: A program that was part of this update failed when it ran. This update was not applied.'.

Tags (2)
Highlighted

Re: Backup exec job engine failed to start

Hello Jacob,

 

Try starting the BEngine services and post the event viewer logs with module and Event ID.

Re: Backup exec job engine failed to start

One more thing to try, you can run the service in console mode. Your path may be symantec:

C:\program files\veritas\backup exec\bengine.exe -console

This will output data, you might be able to see something going on.

 

Highlighted

Re: Backup exec job engine failed to start

 

This what i am getting running the services

Log Name: Application
Source: Backup Exec
Date: 10/26/2016 10:37:06 AM
Event ID: 33808
Task Category: None
Level: Error
Keywords: Classic
User: N/A
Computer: xxxx
Description:
An error occurred while processing a B2D command.
Changer: CreatePath() CreateDirectory1 failed (\\?). Error=123

For more information, click the following link:
http://entced.symantec.com/entt?product=BE&module=eng-event&error=V-379-33808&build=retail&version=1...
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
<System>
<Provider Name="Backup Exec" />
<EventID Qualifiers="8192">33808</EventID>
<Level>2</Level>
<Task>0</Task>
<Keywords>0x80000000000000</Keywords>
<TimeCreated SystemTime="2016-10-26T06:37:06.000Z" />
<EventRecordID>155038</EventRecordID>
<Channel>Application</Channel>
<Computer>xxxxx</Computer>
<Security />
</System>
<EventData>
<Data>Changer: CreatePath() CreateDirectory1 failed (\\?). Error=123</Data>
<Data>&amp;version=14.2.1180.3142&amp;language=EN&amp;os=Windows_V-6.0.6002_SP-2.0_PL-0x2_SU-0x110_PT-0x3</Data>
</EventData>
</Event>

Log Name: Application
Source: Backup Exec
Date: 10/26/2016 10:37:29 AM
Event ID: 57345
Task Category: (65535)
Level: Information
Keywords: Classic
User: N/A
Computer: xxxxx
Description:
Database Exception Context:m_QueryTimeoutInSeconds=30 sql=SELECT [JobRunFlags],[JobName],[TaskTypeID],[TaskDefinitionID],[BEJobID],[JobID],[CurrentStatus],[SubStatus],[NextDueDate],[ScheduleID],[ScriptID],[Priority],[BackupOptions],[BackupOptions2],[CommonJobFlags],[ShareBackupMethod],[MediaSetID],[TargetID],[SortedJobType],[MachineID],[PolicyID],[PolicyType],[PolicyName],[LinkedJobID],[DjmType],[TargetName],[MediaSetName],[ScriptName],[TaskDefinitionName],[MediaServerName],[LastChangeDate],[CPSStatus],[CPSJobID],[ResourceContainerID],[ResourceContainerIDList],[BackupOptions3],[SetCopyOptions],[HistoryID],[DataRetentionHours],[PreferredSourceID],[StatusDetails],[EndTime],[OverallBackupMethod],[JobKey],[RestoreOptions3] FROM [DBO].[vwJobSetupAndMonitor] a1 WHERE [JobID]=? OR [JobID]=? OR [JobID]=? OR [JobID]=? OR [JobID]=? OR [JobID]=? OR [JobID]=? OR [JobID]=? OR [JobID]=? OR [JobID]=? Error:-536837662: :: -2147217900:Invalid column name 'RestoreOptions3'. :: DB Error Set 0: native=0xcf source=Microsoft OLE DB Provider for SQL Server hr=0x80040e14 Invalid column name 'RestoreOptions3'.

For more information, click the following link:
http://entced.symantec.com/entt?product=BE&module=eng-event&error=V-379-57345&build=retail%2
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
<System>
<Provider Name="Backup Exec" />
<EventID Qualifiers="8192">57345</EventID>
<Level>4</Level>
<Task>65535</Task>
<Keywords>0x80000000000000</Keywords>
<TimeCreated SystemTime="2016-10-26T06:37:29.000Z" />
<EventRecordID>155040</EventRecordID>
<Channel>Application</Channel>
<Computer>xxxx</Computer>
<Security />
</System>
<EventData>
<Data>Database Exception Context:m_QueryTimeoutInSeconds=30 sql=SELECT [JobRunFlags],[JobName],[TaskTypeID],[TaskDefinitionID],[BEJobID],[JobID],[CurrentStatus],[SubStatus],[NextDueDate],[ScheduleID],[ScriptID],[Priority],[BackupOptions],[BackupOptions2],[CommonJobFlags],[ShareBackupMethod],[MediaSetID],[TargetID],[SortedJobType],[MachineID],[PolicyID],[PolicyType],[PolicyName],[LinkedJobID],[DjmType],[TargetName],[MediaSetName],[ScriptName],[TaskDefinitionName],[MediaServerName],[LastChangeDate],[CPSStatus],[CPSJobID],[ResourceContainerID],[ResourceContainerIDList],[BackupOptions3],[SetCopyOptions],[HistoryID],[DataRetentionHours],[PreferredSourceID],[StatusDetails],[EndTime],[OverallBackupMethod],[JobKey],[RestoreOptions3] FROM [DBO].[vwJobSetupAndMonitor] a1 WHERE [JobID]=? OR [JobID]=? OR [JobID]=? OR [JobID]=? OR [JobID]=? OR [JobID]=? OR [JobID]=? OR [JobID]=? OR [JobID]=? OR [JobID]=? Error:-536837662: :: -2147217900:Invalid column name 'RestoreOptions3'. :: DB Error Set 0: native=0xcf source=Microsoft OLE DB Provider for SQL Server hr=0x80040e14 Invalid column name 'RestoreOptions3'.</Data>
</EventData>
</Event>

this is another information 

DataAccessLayer SetException:
Exception: Invalid column name 'RestoreOptions3'.
Sql Command:
CommandType=Text CommandText = SELECT [BEJobID], [Priority], [Enabled], [ResourceContainerID], [ResourceContainerIDList], [BackupGroupID], [SolutionName], [NextRunnableTaskID], [DjmType], [TaskTypeID], [ScriptID], [PolicyType], [BackupOptions3], [SetCopyOptions], [ScriptDescription], [RestoreOptions3] FROM [vwSolutionView] WHERE [BEJobID] = @001
Parameter: @001=9a43df4e-c218-428f-a41a-ef20bd28e297

Tags (2)
Highlighted

Re: Backup exec job engine failed to start

While running the bengine.exe service in console i am getting the below

 

C:\Program Files\Symantec\Backup Exec>bengine.exe -console
[10568] 2016-10-26T10:48:33.824 [server] - Service status: Starting,
error = 0, checkpoint = 3, wait hint = 60000
[10568] 2016-10-26T10:48:33.828 [server] - Starting a new thread to
handle CORBA requests
[10568] 2016-10-26T10:48:33.828 [server] - Starting server in consol
e mode -- use CTRL-C to stop
[10568] 2016-10-26T10:48:33.830 [server] - Service status: Starting,
error = 0, checkpoint = 5, wait hint = 60000
[4788] 2016-10-26T10:48:33.831 [icorba] - CorbaSrv: Server name = RH
SLOGFILE
[10568] 2016-10-26T10:48:33.832 [server] - Service status: Starting,
error = 0, checkpoint = 6, wait hint = 60000
[4788] 2016-10-26T10:48:33.833 [icorba] - CorbaSrv: Corba Server for
BE engine : Initializing...
[4788] 2016-10-26T10:48:33.835 [icorba] - Argc[0] = '-ORBEndpoint'

[10568] 2016-10-26T10:48:33.836 [server] - Service status: Starting,
error = 0, checkpoint = 7, wait hint = 60000
[4788] 2016-10-26T10:48:33.837 [icorba] - Argc[1] = 'iiop://:5633'

[4788] 2016-10-26T10:48:33.839 [icorba] - Argc[2] = ''
[4788] 2016-10-26T10:48:33.839 [icorba] - Argc[3] = ''
[4788] 2016-10-26T10:48:33.840 [icorba] - Argc[4] = ''
[4788] 2016-10-26T10:48:33.843 [icorba] - Argc[5] = ''
[4788] 2016-10-26T10:48:33.844 [icorba] - Argc[6] = ''
[4788] 2016-10-26T10:48:33.845 [icorba] - Argc[7] = ''
[4788] 2016-10-26T10:48:33.845 [icorba] - Argc[8] = ''
[4788] 2016-10-26T10:48:33.846 [icorba] - Argc[9] = '-ORBUseShared
Profile'
[4788] 2016-10-26T10:48:33.847 [icorba] - Argc[10] = '0'
[4788] 2016-10-26T10:48:33.848 [icorba] - Argc[11] = '-ORBSvcConfD
irective'
[4788] 2016-10-26T10:48:33.849 [icorba] - Argc[12] = 'static Serve
r_Strategy_Factory '-ORBMaxRecvGIOPPayloadSize 8192''
[10568] 2016-10-26T10:48:33.854 [server] - Service status: Starting,
error = 0, checkpoint = 8, wait hint = 300000
[10592] 2016-10-26T10:48:33.856 + comclientenv.cpp (104):
[10592] 2016-10-26T10:48:33.856 | ComEnvironmentFactory::Ge
tEnvironment: COM initialized for the first time on this thread.
[10592] 2016-10-26T10:48:33.859 [server] - DeviceManager thread star
ting
[10592] 2016-10-26T10:48:33.873 [server] - DeviceManager thread read
y
[10592] 2016-10-26T10:48:33.875 [server] - DeviceManager: going to s
leep for 900000 msecs
[4788] 2016-10-26T10:48:33.896 [icorba] - Initializing the context l
ist with size = 128
[4788] 2016-10-26T10:48:33.898 [icorba] - CorbaSrv: Running Secure C
ORBA Server at port Successfully to accept client requests
[5764] 2016-10-26T10:48:33.904 + comclientenv.cpp (104):
[5764] 2016-10-26T10:48:33.904 | ComEnvironmentFactory::Get
Environment: COM initialized for the first time on this thread.
[7196] 2016-10-26T10:48:34.085 + comclientenv.cpp (104):
[7196] 2016-10-26T10:48:34.085 | ComEnvironmentFactory::Get
Environment: COM initialized for the first time on this thread.
[10016] 2016-10-26T10:48:34.103 + comclientenv.cpp (104):
[10016] 2016-10-26T10:48:34.103 | ComEnvironmentFactory::Ge
tEnvironment: COM initialized for the first time on this thread.
000000006B87F5A0000000006B8813C0000000006B87F590

Tags (2)
Highlighted

Re: Backup exec job engine failed to start

While doing the update it is stuck at 'Updating the backup exec database. This may take some minutes.' this process continues almost 4 hrs now.

Tags (2)