Highlighted

Deduplication folder creates thousands of scratch media files??


My deduplication storage folder when it was initially created would produce 10 new scratch meda files when it ran out of recycleable media files... (which I'm told by symantec tech support is normal.)

However, last week my Dedup storage folder created thousands of Scratch Media files (7,505 to be precise) - and if I attempt to retire and delete them, they are immediately recreated...

The dedup folder is in testing and currently only 2TB in size, only about 100 media files are in use...


We are not in production with dedup yet and still testing the viability/reliability of this technology - anyone experienced this type of behaviour?



1 Solution

Accepted Solutions
Highlighted
Accepted Solution!

there's a hotfix available for this!

This known issue is described here:
http://seer.entsupport.symantec.com/docs/350091.htm

Hotfix 348518 will (hopefully) solve this issue, along with a huge list of other DeDup-issues (BUT: this hotfix is not yet available via LiveUpdate as of today!):
http://seer.entsupport.symantec.com/docs/348518.htm

The hotfix is already 7 days old (12-May-2010), but Symantec Technical Support didn't provide us with it two days ago, as a technican called us after creating a top priority support case last week.

He let me re-create a new DeDup-Folder after we were already back on Backup-to-Disk Devices to avoid corrupted Backups (we had some severe corruptions, also solved with this new hotfix). Before that, he only looked into LiveUpdate, where this hotfix didn't show up (same status as of today) - but this new hotfix was already available for direct download at this time.

This really is a shame - and Symantec Support is to blame.

Because of this we now have to remove about 6800 DeDup-"scratch media" manually by moving them to the retired media and then select some hundred at a time and delete them manually. Also we had lots of failed backups on multiple media servers because of issues fixed with this new hotfix, but not applying it by Symantec Support.

So a hint for everyone who opens a support case for DeDuplication-troubles:
Iif your Symantec Support Technican seems to be 1st-Level and only suggests (very basic) things you already did (like running LiveUpdate, re-creation of a fresh DeDup-Device, let run a test-backup and test-duplicate (or restore) to and from the new DeDup-Device), and is also not able to answer your concrete questions filed with the new support case: ask for a duty manager to get some useful support.

View solution in original post

12 Replies
Highlighted

this media creation is a

this media creation is a known issue. There is no document for this as if now .
Highlighted
Accepted Solution!

there's a hotfix available for this!

This known issue is described here:
http://seer.entsupport.symantec.com/docs/350091.htm

Hotfix 348518 will (hopefully) solve this issue, along with a huge list of other DeDup-issues (BUT: this hotfix is not yet available via LiveUpdate as of today!):
http://seer.entsupport.symantec.com/docs/348518.htm

The hotfix is already 7 days old (12-May-2010), but Symantec Technical Support didn't provide us with it two days ago, as a technican called us after creating a top priority support case last week.

He let me re-create a new DeDup-Folder after we were already back on Backup-to-Disk Devices to avoid corrupted Backups (we had some severe corruptions, also solved with this new hotfix). Before that, he only looked into LiveUpdate, where this hotfix didn't show up (same status as of today) - but this new hotfix was already available for direct download at this time.

This really is a shame - and Symantec Support is to blame.

Because of this we now have to remove about 6800 DeDup-"scratch media" manually by moving them to the retired media and then select some hundred at a time and delete them manually. Also we had lots of failed backups on multiple media servers because of issues fixed with this new hotfix, but not applying it by Symantec Support.

So a hint for everyone who opens a support case for DeDuplication-troubles:
Iif your Symantec Support Technican seems to be 1st-Level and only suggests (very basic) things you already did (like running LiveUpdate, re-creation of a fresh DeDup-Device, let run a test-backup and test-duplicate (or restore) to and from the new DeDup-Device), and is also not able to answer your concrete questions filed with the new support case: ask for a duty manager to get some useful support.

View solution in original post

I had the same issue, applied


I had the same issue, applied the hotfix and then moved them all to retired media and deleted them.  Once I updated the agents with this additional hotfix things are much improved.  However, it appears the agent has to send the data tot he data dedupe folder cleanly once before it dedupes it which is basically like starting your first full over again.  Is this what you encountered as well?
Highlighted

Don't bother, it's not worth the agro

I have to say Backup Exec 2010 dedupe is UTTER garbage. I have had nothing but problems with it since we got it.

It's slow, it DOESN'T save you storage, once it's in there it's there for good which I found out later. It is totally unreliable. I have raised numerous issues and got through to clueless techs who don't even seem to know what dedupe is let alone know how to fix anything.

Highlighted

new problem with thousands of scratch media


i just want to tell you we're having a new problem the dedup folder creating thousands of scratch media, even after installing hotfix 348518.

we're in contact with symantec support, i'll keep you up to date if there are any news about this.
it's for sure another new problem, not the one fixed in hf348518.
Highlighted

Me too

I also had the hotfix 348518 installed since it was made available and I now have over 6,000 scratch media items.  The trouble with this is not jobs stay queued as they are 'requesting a media mount and the spad process is taking a whole CPU and nothing happens.   The deduplication option is an absolute mess.  SYMANTEC FIX IT FAST OR LOSE CUSTOMERS.
Highlighted

You folks complaining of

You folks complaining of similar issues, need to call into support to open a case.  Without a trend of known issues, there is no way to fix anything. You have to help them, help us.  These forums, are NOT avenues for support diagnoses and creating patches from said diagnoses.

Often enough some issues are already resolved, but so called computer consultants are to blame in not knowing really how things in BE work, other than having used it for a long time....  Thus the reason for STS, which I bet most would fail yet charge $150/hr for consulting work.
Highlighted

teiva-boy, you're right - and wrong.

teiva-boy,
you're right - and wrong.

the reason you're right is, that if no one opens a case symantec is unable to fix these issues.

but

the reason you're wrong is that even with helping symantec support as good as possible they are unable to help us..

we opened a case with massive deduplication issues (problems with corruption, thousands of "unknown" media, complete failure of dedup store resulting in no backups, dedup playing with itself, resulting in "queued" status for all jobs, etc...) several weeks ago.

even with maximum possible escalation and therefor some competent support technican (which helped a lot) dedup still is unusable.

our customer first fell back to backup2disk on one media server and continued to use dedup on a system with less load. after constantly new problems with all jobs "queued" and 36 thousands of "unknown media", etc. and no backups for several days - and no more reply from our support technican, we had to fall back to backup2disk on the second media server too.
before that i gathered every kind of information and log files (also debug logs and logs from active debugger, like the symantec technican did), sent them to symantec support - but the didn't even really read my mails - they asked questions like if i never had sent them any information before, if they asked questions. and i we asked some questions, we got no concrete answer.

our customer is really frustrated with the (paid) dedup option and doesn't want to use it any more, until BE2010R2 or a service pack becomes available.
in his eyes (mine too) dedup is unstable like hell and unusable for productive environments.

the case is still open, with no dedup in use any more.
there are still some questions open and after we provided lots of information/log/debug info we want some answers. also our customer wants some answers.

lets see how long it takes until we get them, if we get them.. ;-)

it seems marketing works really well at symantec, but dedup doesn't.
if it was "for free" with BE2010, it still would be a problem - but since the license for dedup costs money, it should work as designed. i don't like being an unpayed "beta tester"..


so we look forward to BE2010 R2 and a future service pack for BE2010.

until then dedup will not be used any more - backups and the ability to restore data out from these backups are the liveblood for any company.
non-working restores because of non-working backups because of non-working dedup feature is a real risk, not only some technical play-around-game..
Highlighted

Careful on your assumptions

Firstly I have been certified on Backup Exec for years and always kept up to date on all certifications.  I am certified on the current product as well as NetBackup so please don't assume that people like myself have come here for support without having gone down the proper routes.  In fact I was part of the beta program for this product and got to test this product way ahead of its release.

Secondly I have two major deployments of this product with both having the exact same issues.  The deduplication option is simply unreliable.   I have several open cases with Symantec support all related to the deduplication option.  I've actually spent more time liaising with support than I have actually spent implementing this product. 

It is not right that there should be this many issues with this product where many of us, including Symantec support themselves, are scratching around in the dark.  By expressing experiences here on these OPEN forums I share with others the experience that I am having in the hope that I may get some additional info from others to assist myself as well contributing to the general discussion on these problems with BE2010.

So to summarize:  I have several open cases and on that I am not getting the issues resolved as quickly as I would normally expect from Symantec.  By contributing to these forums I hope to get help form others in the same boat and also illustrate to Symantec that there are people out there who are not happy with this product so far.  So please don't assume we haven't followed the proper steps already as it adds little to the contribution on these forums.

Highlighted

Progress???


Has anyone had any further progress on this issue?  We uploaded our logs over a week ago and still have not heard back from anybody.  I just left a message for the engineer assigned to our case asking him to please follow-up.  I just don't think I can stand sitting on hold for another 40+ minutes.
Highlighted

maybe that's some help

http://www.symantec.com/connect/forums/how-get-rid-thousands-ost-media-result-be2010-deduplication-store-problems


Highlighted

minor update


I just try to give the options back. And hey, i got some symantec guys to contact me :-)

Offtopic Fun:   I need to find a good hold music for my extension.

I update if this results in any fixes.