Error: Could not find virtual machine specified by name:AMSBCK002(VCB-HELPER)

Hi,

 

I am current running an eval of v12.5 and having trouble with backing up VMware ( ESX v3.5) images. In a VM (AMSBCK002) I have installed W2003 Server, BE v12.5 and VCB Framework. For evaluation purposes I am doing a backup-2-disk using the VM's D:\Backup2Disk folder, transport mode is HotAdd, use Local Media Server as VCB Proxy and VCB path is D:\Temp, AMSVC01 is the Virtual Center server and AMSEPO002 is the VM that I try to backup.

 

The job runs for 90 sec's and fail with Final error: 0xe000954c - An error occurred while running the VMware 'vcbMounter' command to back up a virtual machine. See the job log for details.
Final error category: Resource Errors. The errors section show:

 

Backup- VMVCB::\\amsvc01.com\VCGuestVm\(DC)Amsterdam(DC)\vm\Production Medium\AMSEPO02 V-79-57344-38220 - Backup of the virtual machine 'AMSEPO02' failed. VMware VCB framework reported the following error
 Error: Could not find virtual machine specified by name:AMSBCK002(VCB-HELPER)

Any suggestions?

Message Edited by Allan Petersen on 11-04-2008 01:19 AM
1 Solution

Accepted Solutions
Highlighted
Accepted Solution!

Re: Error: Could not find virtual machine specified by name:AMSBCK002(VCB-HELPER)

Found the solution in this thread: https://forums.symantec.com/syment/board/message?board.id=be12x_agent_for_vmware&message.id=35

 

Not sure why I missed that when reading the manual

View solution in original post

7 Replies
Highlighted

Re: Error: Could not find virtual machine specified by name:AMSBCK002(VCB-HELPER)

Can u try running the mounter from CMD 

 

 

1. Start | Run | type cmd in the dialog box . 2. Browse through the path where VCB is installed . Note : By default the path for VCB is C:\Program1. Start | Run | type cmd in the dialog box .
2. Browse through the path where VCB is installed .
  Note : By default the path for VCB is C:\Program files\Vmware\Vmware Consolidated Backup
3. Run the VCB mounter command to mount the virtual machine image to staging area
Command:
vcbmounter.exe -h Virtual Center name  -u Domainname\Username -p Password  -a ipaddress of the Virtual machine  -r "c:\temp" -t fullvm  -m nbd files\Vmware\Vmware Consolidated Backup 3. Run the VCB mounter command to mount the virtual machine image to staging area Command: vcbmounter.exe -h Virtual Center name -u Domainname\Username -p Password -a ipaddress of the Virtual machine -r "c:\temp" -t fullvm -m nbd

Highlighted

Re: Error: Could not find virtual machine specified by name:AMSBCK002(VCB-HELPER)

VCB looks to be working 

 

C:\Program Files\VMware\VMware Consolidated Backup Framework>VCBMOUNTER.EXE -h AMSVC01.EUR.LOCAL -u xxx\xxx -p xxx -a ipaddr:10.xx.xx.239 -r "d:\temp" -t fullvm -m nbd

[2008-11-05 11:44:38.814 'App' 3468 info] Current working directory: C:\Program Files\VMware\VMware Consolidated Backup Framework

[2008-11-05 11:44:38.814 'BaseLibs' 3468 info] HOSTINFO: Seeing Intel CPU, numCoresPerCPU 1 numThreadsPerCore 2.

[2008-11-05 11:44:38.814 'BaseLibs' 3468 info] HOSTINFO: numPhysCPUs is 0, bumping to 1.

[2008-11-05 11:44:38.814 'BaseLibs' 3468 info] HOSTINFO: numCores is 0, bumpingto 1.

[2008-11-05 11:44:38.814 'BaseLibs' 3468 info] HOSTINFO: This machine has 1 physical CPUS, 1 total cores, and 1 logical CPUs.[2008-11-05 11:44:39.642 'BaseLibs' 3468 info] Using system libcrypto, version 90709F

[2008-11-05 11:44:41.892 'BaseLibs' 3468 warning] SSLVerifyCertAgainstSystemStore: Subject mismatch: VMware vs AMSVC01.EUR.LOCAL

[2008-11-05 11:44:41.892 'BaseLibs' 3468 warning] SSLVerifyCertAgainstSystemStore: The remote host certificate has these problems:* The host name used for the connection does not match the subject name on the host certificate* A certificate in the host's chain is based on an untrusted root.

[2008-11-05 11:44:41.892 'BaseLibs' 3468 warning] SSLVerifyIsEnabled: failed to read registry value. Assuming verification is disabled. LastError = 0

[2008-11-05 11:44:41.892 'BaseLibs' 3468 warning] SSLVerifyCertAgainstSystemStore: Certificate verification is disabled, so connection will proceed despite the error

Copying "[AMS SAN Storage] AMSBCK001/AMSBCK001.vmx":        0%=====================50%=====================100%        **************************************************

Copying "[AMS SAN Storage] AMSBCK001/AMSBCK001.nvram":        0%=====================50%=====================100%        **************************************************

Copying "[AMS SAN Storage] AMSBCK001//vmware-34.log":        0%=====================50%=====================100%        **************************************************

Copying "[AMS SAN Storage] AMSBCK001//vmware-32.log":        0%=====================50%=====================100%        **************************************************

Copying "[AMS SAN Storage] AMSBCK001//vmware-33.log":        0%=====================50%=====================100%        **************************************************

Copying "[AMS SAN Storage] AMSBCK001//vmware-29.log":        0%=====================50%=====================100%        **************************************************

Copying "[AMS SAN Storage] AMSBCK001//vmware-30.log":        0%=====================50%=====================100%        **************************************************

Copying "[AMS SAN Storage] AMSBCK001//vmware-31.log":        0%=====================50%=====================100%        **************************************************

Copying "[AMS SAN Storage] AMSBCK001//vmware.log":        0%=====================50%=====================100%        **************************************************

Converting "d:\temp\scsi0-0-0-AMSBCK001.vmdk" (compact file):        0%=====================50%=====================100%        **************************************************

C:\Program Files\VMware\VMware Consolidated Backup Framework>

Highlighted

Re: Error: Could not find virtual machine specified by name:AMSBCK002(VCB-HELPER)

Thanks for reply I think we would need to investigate this little more by using SGMON debug utility.

 

I would also request to open a support case for the same .

 

You can always email me at sudhir_amin@symantec.com

 

 

Highlighted

Re: Error: Could not find virtual machine specified by name:AMSBCK002(VCB-HELPER)

Additional information. I ran the VCBMOUNTER with .... -a name:AMSEPO002 which works as well.

 

Thanks

Highlighted

Re: Error: Could not find virtual machine specified by name:AMSBCK002(VCB-HELPER)

Did you added machine name -AMSEPO002  in the host files of the VCB proxy server.

Highlighted

Re: Error: Could not find virtual machine specified by name:AMSBCK002(VCB-HELPER)

I just did, rebooted and failed with same error. Before I changed the host file I checked that I could ping the hostname and the FQDN.

 

While the job is running a subfolder is being created below d:\temp, and several of the the VM's files (LOG, nvram, vmx, unmount.dat) are being copied and vmdkstubs folder created. The subfolder is being deleted once the job fails.

Highlighted
Accepted Solution!

Re: Error: Could not find virtual machine specified by name:AMSBCK002(VCB-HELPER)

Found the solution in this thread: https://forums.symantec.com/syment/board/message?board.id=be12x_agent_for_vmware&message.id=35

 

Not sure why I missed that when reading the manual

View solution in original post