Highlighted

Errors setting up BE2010 with GRT for Exchange 2010

Hi.

I am having some trouble understanding how to set up GRT for Exchange 2010. So far I read and re-read the BE Admin guide and I seem to be stuck at the point of adding the DC or DAG Group server name. To be clear, with only one Exchange 2010 server, are you still able to specify the DAG server group name? It looks like I can but then...

Once I put in the name for exchange 2010 server, let  BE go off and locate it, I then refresh the page and I see an object ESEFS_DAG::\\E2K10. When I try to browse its contents, I get an error of 'An invalid device was specified'.

Not really sure what is happening with that.

Would anyone have had this experience?

Thanks in advance for any and all replies.

James

 

4 Replies

Hello James,

You have mentioned that you have only one Exchange 2010 server which suggest that Exchange is not in DAG configuration.

In the backup selection list you will still be able to see the option to Add DAG group name. But need not worry over here as this option is not valid since Exchange is not in cluster. So do not add any DAG name or Exchange servername in this node.

Make sure you have installed Backup Exec Remote Agent on the Exchange 2010 server. Then in the selection list under Favourites resources you will be able to see the Exchange server listed under Windows server node. Expand the Exchange server and you will be able to see the Microsoft Information Store for Exchange. Select this for the backups and you should be good. GRT option is by default enabled for Exchange backups.

 

Thanks,

-Sush...

Highlighted

Thanks Sush... I have used

Thanks Sush...

I have used the agent and followed along with the Wizard which has a 'guide me' section. Now, we did not use a policy as we only do full backups. Does GRT actually work with full back jobs?  In testing here is what we found:

  • We tried restoring a few emails to a test account and it seemed to work.
  • There was a message from Backup Exec in the test account's Inbox stating that some items ahd been restored - essentially confirm the items were restored and delete the BE message.
  • No actual emails were restored - no errors occurred either.

Here are setting for the Exchange backup:

 

_____________________________________________________________________________________

Backup method: Full - Database & Logs (flush committed logs)
Backup method: Full - Back up messages - Reset archive bit

Continuously back up transaction logs with Backup Exec Continuous Protection Server: No

Use Backup Exec Granular Recovery Technology (GRT) to enable the restore of individual mailboxes, mail messages, and public folders from Information Store backups (Incremental backups supported with policy-based jobs only): Yes
Enable single instance backup for message attachments: No
Perform consistency check before backup when using Microsoft Volume Shadow Copy Service (VSS) snapshot provider: Yes
Continue with backup if consistency check fails: Yes

_____________________________________________________________________________________

Is there anything in that I should closely look into?

Thanks in advance,

James

Highlighted

Hello James,

Yes. GRT works well with Full backup of Exchange. What i could think which is missing from here could be the updates. Make sure that Backup Exec is fully patched with latest Service packs and Hot fixes (You may have to run Live updates number of times till its fully patched). Ones the Media server is updated then push install  the remote agent again to the remote Exchange server and it will update the Remote Agent too.

Now test the backups and restore and see the result.

Also if your backups are on tapes then during the restore it will stage the Information store at the temporary location on the Media server. By default this location is C:\TEMP. You can change the location for staging if there is any issue of less disk space on the C: drive. In the Restore job go to Advanced tab where you will get the option to change the Staging location.

 

Thanks,

-Sush...

Highlighted

Okay I have updated and will

Okay I have updated and will check it again after the backup occurs as scheduled for tonight.

Thanks Sush.

James