Incremental backup of exchange logs windows errors

Well the title says it all;

We are running Full/Incremental backups (BE 2015) on our Exchange 2007 stores. BE reports that full and incremental backups are succesfull however on the Exchange server we are getting Event Error 206 (ESE) :

Log Name:      Application
Source:        ESE
Description:
MSExchangeIS (7244) First Storage Group: Database D:\ExchangeDB\Mailbox Database.edb cannot be incrementally backed-up. You must first perform a full backup before performing an incremental backup.

Which is immediately followed by error 57920 (Backup Exec):

An error occured while preparing Microsoft Exchange Server \\EXCHANGE\First Storage Group to back up database.

Error code 0xC8000230

Error message: The database missed a previous full backup before the incremental backup.

What gives here? BE 2015 shows everything to be in order. I have tried removing the exchange logs, tried deleting and recreating the jobs, run full backups then new incrementals 9 ways to sunday with no change at all.

Any advice would be greatly appreciated!

Andy

9 Replies

If you have circular logging

If you have circular logging enabled then disable it  check out: http://www.symantec.com/docs/HOWTO74428 

are the Microsoft Exchange 2007 Management Tools installed on the Backup Exec media server and updated to the same level as on the Exchange server?

 
for other requirements for Backup Exec 15 and Exchange 2007
see page 26 of the Backup Exec SCL  http://origin-symwisedownload.symantec.com/library/BUSINESS/xCL/TECH227896/be_15_scl.pdf

also, this might be a disk/IO issue. Make sure you have updated the firmware and drivers and applied

 

Circular logging is disabled.

Circular logging is disabled. Firmware and drivers are all updated. We could put them on if need be but I'm not sure I understand why the Exchange management tools need to be on the Backup Exec server? We never had them there before and BE 2012 and 2014 did not have this issue. It is strange; BE2015 reports everything is fine. I can drill down into a granular backup and grab individual emails no problem. But the Windows event viewer shows the errors.

Re: Incremental backup of exchange logs windows errors

For what it is worth, we are also in this same boat.  I opened a ticket with Veritas and will report back any of the issues they find.

In short: backup exec reports no errors, backups appear to restore fine and we can see the granular email-level recovery options.

We have the EMC tools installed on the backup server.

Highlighted

Re: Incremental backup of exchange logs windows errors

thecope,

we have been digging into this with no success; both our public database and our mailbox database show the proper full/incremental backup dates/times in the Exchange command shell. We have tested restoring databases full and granular with no issue. BE 2015 has the most current service pack updates as does Exchange 2007. Please post your findings; I will not open a support ticket just yet.

At least the backups are usable and it appears that this is just an issue with error reporting... Doesn't appear to be affecting anything critical.

Andy

Re: Incremental backup of exchange logs windows errors

Veritas is still working through the ticket process with us, but I suspect they are just going to point the finger at Microsoft even though the "problem" is probably on their end.  They've already had us update to Feature Pack 2, run a full backup without GRT, run another full backup with GRT, and then see if the incremental jobs generate the error.  The error still generates on the exchange event logs and the backups are fine and appear to restore without any problem.  So now that Feature Pack 3 is out, they want us to do the same thing, but the advanced support person seemed to start laying the foundation to blame Microsoft and close the ticket if that doesn't resolve the issue.

We wouldn't have even noticed this situation if we were not auditing the Exchange server's event viewer.  My ultimate guess is that this is probably some obscure false positive error reporting between BUX and Exchange 2007.  I don't know how many people still use Exchange 2007 like us, but we will be upgrading at some point in the future.

We will not be picking this up again until January, so when we learn more I will put another update on here.

Re: Incremental backup of exchange logs windows errors

Is AOFO explicitly enabled for the Exchange backup ?

If yes, disable it, rerun the full followed by the incremental and check. Thanks.

Re: Incremental backup of exchange logs windows errors

thecope,

Exactly.... EXACTLY where we are. Patched, updated... tested... and yes, the event viewer monitoring is what tipped us off as well. I only found it after an HD failure on the server and so scrutinized the logs closer than usual... I've run every trace and test I can think of... 

VJware,

I've tried the whole 'do not use AOFO' test... including making new backups with and with AOFO initially... no difference. Changed times that backups are run, you name it.

ESE is not seeing the BUX full backup date, even though the full backup date is correct when viewed in Exchange management shell. very strange indeed, and most likely something that will get passed over and never really resolved. only time will tell...

Re: Incremental backup of exchange logs windows errors

Veritas support is presently looking at what is generating the errors, however, they appear to have created this support article: https://www.veritas.com/support/en_US/article.000100557

It basically just says to ignore the errors.  If they discover the cause of the error and any other information, I will post it.

Re: Incremental backup of exchange logs windows errors

Feature Pack 5 finally resolved this issue.

Tags (2)