cancel
Showing results for 
Search instead for 
Did you mean: 

Unable to attach to a resource.

Good morning,

I'm having issues with one of our jobs backing up our data, but failing.  The job is backing up the system state and C: drive of our Enterprise Vault server, and the open partitions and indexes of our Enterprise Vault server (through the database server).  The error is:

Unable to attach to .
V-79-57344-33932 - Unable to attach to a resource. Ensure that the selected resource exists and is online, and then try again. If the server or resource no longer exists, remove it from the selections.

Figuring that as this was a job created before my employment, perhaps a resource on one of the two servers no longer existed, and couldn't be deselected via the GUI.  I created a new job, with the same selections, and I verified their existence.  Accounts and permissions are fine.

The error message does't specify what it cannot connect to (other than "."), so I have no idea where to look for the problem.  Any help would be greatly appreciated.

Russell.

13 Replies

split the job (System State

split the job (System State on it's own, c: drive on its own etc) as then you will know which part of the job is failing.

 

if the system state then something (3rd party application) has probably not uninstalled correctly from the server and left some references behind that are causing the issue.

 

Re: Unable to attach to a resource.

Hi Colin,

Thank you for your reply; I've just tried backing up the job's constituents independently, and it appears to be failing when packing up "Open partitions".  There's only one open partition!

Russell.

Try these KBs

Try these KBs -

https://www.veritas.com/support/en_US/article.TECH160370

https://www.veritas.com/support/en_US/article.TECH143959

https://www.veritas.com/support/en_US/article.TECH187959

Re: Unable to attach to a resource.

Good morning, and thank you for the KB references.

I ran through those guides and everything seems to be as it should.

Quite a generic error. Enable

Quite a generic error. Enable debugging as per this KB & then attach the output over here. -- https://www.veritas.com/support/en_US/article.000010778

Re: Unable to attach to a resource.

Quick question,

I get a lot of console output without any jobs running, so if I run the 4-hour job for the open partition - is the resulting mammoth log file likely to be of use?

Does the backup fail post 4

Does the backup fail post 4 hours ? I mean, does it backup from the open partition & then fail towards the end of it ?

Also, no need to check "Device and Media, Catalog" options in the SGmon.

Re: Unable to attach to a resource.

Hi there,

It does indeed; the backup job backs up the whole open partition, but fails at the end of the job.

Re: Unable to attach to a resource.

Would you pls attach the entire job log over here. Thanks.

Apologies for the delay; here

Apologies for the delay; here is the tail of the log:

[1744] 2016-01-29T17:10:42.802                      |    server                 - 7914A283-47B7-496D-8E97-0785AD85050D
[1744] 2016-01-29T17:10:42.802                      |    server ID              - F5E74FEC-83D9-4793-9275-42670A4A08AF
[1744] 2016-01-29T17:10:42.802                      |    res OSID/Ver, tp/subtp - 73,1, 37,40
[1744] 2016-01-29T17:10:42.802                      |    flags, dsss flags      - 0xc, 0x73
[1744] 2016-01-29T17:10:42.802                      |    parent resource ID     - A86E87F3-F63E-4368-BC59-051A550F2BDD
[1744] 2016-01-29T17:10:42.802                      |    update date time       - 29/01/2016 09:18:35
[1744] 2016-01-29T17:10:42.802                      | *****************************************************************
[1744] 2016-01-29T17:10:42.802                      | Record                    - 45
[1744] 2016-01-29T17:10:42.802                      |    resource               - \\CPG-TAPE3
[1744] 2016-01-29T17:10:42.803                      |    resource flags         - 0x0
[1744] 2016-01-29T17:10:42.803                      |    account name/password  - cpg\evaultservice, Password included
[1744] 2016-01-29T17:10:42.803                      |    account ID             - 64C9B416-9182-47D9-B91A-0903E3451874
[1744] 2016-01-29T17:10:42.803                      |    resource ID, resContID - 00000000-0000-0000-0000-000000000000, 7914A283-47B7-496D-8E97-0785AD85050D
[1744] 2016-01-29T17:10:42.803                      |    server                 - 7914A283-47B7-496D-8E97-0785AD85050D
[1744] 2016-01-29T17:10:42.803                      |    server ID              - 00000000-0000-0000-0000-000000000000
[1744] 2016-01-29T17:10:42.803                      |    res OSID/Ver, tp/subtp - 127,0, 2,3
[1744] 2016-01-29T17:10:42.803                      |    flags, dsss flags      - 0x10000001, 0x0
[1744] 2016-01-29T17:10:42.803                      |    parent resource ID     - 00000000-0000-0000-0000-000000000000
[1744] 2016-01-29T17:10:42.803                      |    update date time       -  
[1744] 2016-01-29T17:10:42.803                      | *****************************************************************
[1744] 2016-01-29T17:10:42.803 [server]             - Removing 'Enterprise Vault to tape-Weekly Full' from status update list
[1744] 2016-01-29T17:10:42.803 [server]             + jobstatus.cpp (729):
[1744] 2016-01-29T17:10:42.803 [server]             | Updating status for: 'Enterprise Vault to tape-Weekly Full'; operation status: 0x18; application status: 0x0;
[1744] 2016-01-29T17:10:42.804 [server]             + jobstatus.cpp (739):
[1744] 2016-01-29T17:10:42.804 [server]             | Status for: 'Enterprise Vault to tape-Weekly Full' updated
[1744] 2016-01-29T17:10:42.811 [server]             - BackupJob::MergeBEVSRJobLogsIfNecessary: processing
[1744] 2016-01-29T17:10:42.811 [server]             - BackupJob::MergeBEVSRJobLogsIfNecessary: No VSR log file found, no merging necessary
[1744] 2016-01-29T17:10:42.811 [server]             - BackupJob::MergeBEVSRJobLogsIfNecessary: processing
[1744] 2016-01-29T17:10:42.811 [server]             - BackupJob::MergeBEVSRJobLogsIfNecessary: No VSR log file found, no merging necessary
[1744] 2016-01-29T17:10:42.811 [server]             - EndJob() criticalVolumeError - 0x0
[1744] 2016-01-29T17:10:42.812 [server]             - Ending job 'Enterprise Vault to tape-Weekly Full' with error status (-536836980)
[1744] 2016-01-29T17:10:42.824 [server]             + jobengine.cpp (1024):
[1744] 2016-01-29T17:10:42.824 [server]             | Job thread terminating for job 'Enterprise Vault to tape-Weekly Full'.
[1744] 2016-01-29T17:10:42.824                      + csecuritysslhelper.cpp (281):
[1744] 2016-01-29T17:10:42.824                      | DeInitialize Thread Specific SSL

Do you require the full logs, and if so, which would be the best way to submit?

 

Yours sincerely,

Russell.

Re: Unable to attach to a resource.

You can send them over via a pvt msg. Pls attach the job log along with the corresponding job logs from both BE server and EV server.

Re: Unable to attach to a resource.

Thank you for your reply, I've sent you a PM with the requested logs!

Re: Unable to attach to a resource.

Resurrecting this thread from the longback->

What was the resolution?

 

We are having a not entirely dissimiliar issue, some of the same error codes and not many results from Google.

 

Any help is appreciated.