V-79-57344-38277 - Unable to open a disk of the virtual machine.

I have new WIndows 2016 server with BE 16 and when I try to backup a VMware 5.0 VM, I got the following error.

V-79-57344-38277 - Unable to open a disk of the virtual machine.

VixDiskLib_Open() reported the error: You do not have access rights to this fileVDDK-Warn: SSL: Unknown SSL Error

VDDK-Warn: SSL: connect failed (1)

VDDK-Warn: [NFC ERROR] NfcNewAuthdConnectionEx: Failed to connect to peer. Error:

Wednesday, November 8, 2017 1:16:39 PM - V-79-57344-38277 - Unable to open a disk of the virtual machine.

VixDiskLib_Open() reported the error: You do not have access rights to this fileVDDK-Warn: SSL: Unknown SSL Error

VDDK-Warn: SSL: connect failed (1)

VDDK-Warn: [NFC ERROR] NfcNewAuthdConnectionEx: Failed to connect to peer. Error:

I have an old Windows Server 2008 R2 with BE 2014 and it is backing up the same VM without any problem. This problem is only for the new Windows server 2016 and BE 16 that I just installed.

 

Tags (2)
2 Solutions

Accepted Solutions
Highlighted
Accepted Solution!

Re: V-79-57344-38277 - Unable to open a disk of the virtual machine.

based on the SCL (https://www.veritas.com/content/support/en_US/doc/BE_16_SCL) you need at least vmware 5.5 for use with bexec16

View solution in original post

Highlighted
Accepted Solution!

Re: V-79-57344-38277 - Unable to open a disk of the virtual machine.

Just to clarify Jurgen's answer a little

 

Backup Exec uses VDDK components which we get from VMware. Those components are designed to support specific versions of ESXi and typically as support for the newer versions are added the older versions start to be removed from being supported by a specific VDDK package. You cannot use more than one level of VDDK on a single server and you can get errors similar those mentioned in thread if the VDDK being used does not support the ESXi version. Hence our Software Compatibility Lists are very specific about supported ESXi versions.

Once we have access to a new VDDK from VMware, we may have to change our own program to match new functionality, which will also limit any ability to possibly allow the use of a older VDDK, and we do have to implement newer VDDK to enable support for their current ESXi versions.

Basically any environment that continues to use obsolete software, whether it be the Operating Systems, Applications, Virtual System Hyper-visors, Security Products or Backup products will have to have decisions made about when everything can be updated and those decisions need to include making sure there is an awareness of which software versions might affect interactions with other active software.  In this case ESXi will need updating OR you will need to maintain an older Backup Exec version just to protect the ESXi version you are running. (if you do maintain an older version be aware of the End of Support Dates)

View solution in original post

6 Replies
Highlighted
Accepted Solution!

Re: V-79-57344-38277 - Unable to open a disk of the virtual machine.

based on the SCL (https://www.veritas.com/content/support/en_US/doc/BE_16_SCL) you need at least vmware 5.5 for use with bexec16

View solution in original post

Highlighted
Accepted Solution!

Re: V-79-57344-38277 - Unable to open a disk of the virtual machine.

Just to clarify Jurgen's answer a little

 

Backup Exec uses VDDK components which we get from VMware. Those components are designed to support specific versions of ESXi and typically as support for the newer versions are added the older versions start to be removed from being supported by a specific VDDK package. You cannot use more than one level of VDDK on a single server and you can get errors similar those mentioned in thread if the VDDK being used does not support the ESXi version. Hence our Software Compatibility Lists are very specific about supported ESXi versions.

Once we have access to a new VDDK from VMware, we may have to change our own program to match new functionality, which will also limit any ability to possibly allow the use of a older VDDK, and we do have to implement newer VDDK to enable support for their current ESXi versions.

Basically any environment that continues to use obsolete software, whether it be the Operating Systems, Applications, Virtual System Hyper-visors, Security Products or Backup products will have to have decisions made about when everything can be updated and those decisions need to include making sure there is an awareness of which software versions might affect interactions with other active software.  In this case ESXi will need updating OR you will need to maintain an older Backup Exec version just to protect the ESXi version you are running. (if you do maintain an older version be aware of the End of Support Dates)

View solution in original post

Highlighted

Re: V-79-57344-38277 - Unable to open a disk of the virtual machine.

Thanks so much for the help. I could lose my mind about it and should check the compatibility list. Smiley Happy

Highlighted

Re: V-79-57344-38277 - Unable to open a disk of the virtual machine.

So I did the upgrade of vcenter server from v5.1 to v5.5u3. I am still geting this error. Do I have to upgrade ESXi servers also to v5.5? eventhough I am using vcenter as contact point for the backup?

 

Highlighted

Re: V-79-57344-38277 - Unable to open a disk of the virtual machine.

of course, your esx servers should met the minimum version mentioned in the compatibility lists of veritas

Highlighted

Re: V-79-57344-38277 - Unable to open a disk of the virtual machine.

got it... thanks. after upgrade of ESXi servers the backups resumed normaly.