cancel
Showing results for 
Search instead for 
Did you mean: 

cannot remove robotic library

jon_manager
Level 4

This is BE2012 SP4

I have a single Robotic Library (Sony Lib-81 - on the Symantec HCL). and have been having trouble with it for weeks. As part of thetroubleshooting I'm trying to remove it so I can install again, however whenever I try to delete it I get 'unable to delete tape library' message.

The library is disabled. I have already successfully deleted the Tape Drive.

I right-click the Library and select Delete. After the confirmation message I get this sequence of messages:

'Finding Jobs that target Robotic Library 0001' is shown

shortly followed by 'Deleting Robotic Library 0001'.

Finally I get the 'Unable to delete the tape library' message.

I've gone through all jobs in the system and have removed all those which target the Tape Library (clean tape job, duplicate jobs, inventory jobs, etc).

Seems to me there's corruption in the BE database/system. I've already run a database repair routine.

Anyone help with how to remove the tape library please?

The underlying issue I'm trying to resolve is that I can't use the library because although I can bring it online, whenever I try to do anything with a slot in the library (inventory tape, duplicate job) I get 'Physical Volume Library Robot not found'.

1 ACCEPTED SOLUTION

Accepted Solutions

CraigV
Level 6
Partner    VIP    Accredited

Hi,


there should be a device configuration wizard available. If you run this there will be an option to remove all old hardware. Select this and see if it has removed the library from within BE.

If this doesn't work I'd suggest logging a call with Symantec support to get it removed from the BEDB.

Thanks!

View solution in original post

8 REPLIES 8

CraigV
Level 6
Partner    VIP    Accredited

Hi,


there should be a device configuration wizard available. If you run this there will be an option to remove all old hardware. Select this and see if it has removed the library from within BE.

If this doesn't work I'd suggest logging a call with Symantec support to get it removed from the BEDB.

Thanks!

View solution in original post

jon_manager
Level 4

Craig - do you mean tapeinst.exe ? or something else? Where do I find the device configuration wizard?

NikiSa
Level 4

yes,  tapeinst.exe, it says that i have also installed the newer driver, so i skip the wizard.

and also i update the dell library in the lastest version.

 

 

CraigV
Level 6
Partner    VIP    Accredited

Try this:

http://www.symantec.com/business/support/index?page=content&id=HOWTO73419

...otherwise tapeinst.exe MIGHT work. BE 2010 etc. had the Device Configuration Wizard where you could delete unused tape hardware etc.

Thanks!

jon_manager
Level 4

ok, tried all that - nothing doing. Using the 'Configure Storage' option within BE gives options but none result in being able to delete the tape library. Have run tapeisnt.exe twice, removed drivers, ticked to remove unavailable devices, but that only deletes the Tape Drive, not the library. Shall raise a case with Support.

pkh
Moderator
Moderator
   VIP    Certified

I think you are unable to delete the library because there are some orphaned jobs targeting it.  There are previous discussions involving disk storage which cannot be removed due to some unknown jobs targeting it.  The solution is to open a support case so that the Symantec engineers can edit the device out of the BEDB.

jon_manager
Level 4

raised support case. edited BEDB and tape library is finally gone!

 

Now to reinstall it .....

 

Thanks everyone for responses, especially CraigV

CraigV
Level 6
Partner    VIP    Accredited

Not a problem jon, glad to have helped.

Thanks!