Highlighted

"the query for ResourceContainer failed" BE2012 - Clean Install

Hi All,

 

just want to share the problem i have with BE 2012.

It is a clean fresh installation on clean newly installed Win2008 R2 SP1 (all pre-checks passed fine).

After remote push of 2 agents and creation oddedupe folder, the console reports error in lower left corner of the screen saying : "The query for ResourceContainer failed".
The result is that nothing is visible inside GUI anyomore (groups, agents, jobs...).

Debugging shows : 

MANAGEME: [03.27.12 15:00:28] [0000] ERROR: Reason: DataAccess DataAccessBEServer QueryResourceContainer: caught an exception:Invalid column name 'finaljobstatus'..

MANAGEME: [03.27.12 15:00:28] [0000] ERROR: Stack: at BackupExec.Management.Components.DataAccess.DataAccessBEServer.QueryResourceContainer(ItemCriteria& queryInfo)

 

I have tried reinstall, removal of installation, deletition of profile, registry keys, deletition of all associated folders and tried a clean install, also i have trye dusing another SQL server as opposed to using SQL express,  but always the same error appears (will have to rebuild the server form scratch it seems).

Any ideas? Ayone seen this before?

Thanks.

 

All the best,


Kresimir

1 Solution

Accepted Solutions
Accepted Solution!

Ok.. Solved. The SQL express

Ok.. Solved.

The SQL express database which BE installs (and any other) inherits collation settings from Language for non-Unicode programs setting (http://msdn.microsoft.com/en-us/library/ms143311(v=sql.90).aspx ). Therefore if you have some other regional setting, the SQL express database of BE inherits these setings and the BE 2012 cannot work with "non-standard" collations.

The collation of SQL Express database which i am now using is (English US) so all is OK now.

 

 

Thanks for your replays.

View solution in original post

13 Replies

Is there enough space on the

Is there enough space on the media server ? as well as on the SQl server where you have te database file .

Are all the services running ?

All services are up. No

All services are up. No errors in windows event viewer. More than enough free space. No antivirus either.

...have you tried a manual

...have you tried a manual installation of the RAWS agent?

http://www.symantec.com/business/support/index?page=content&id=TECH30491

Is there a firewall running on the target server? If so, can you disable it, or put in an exclusion for the RAWS agent to communicate to the media server?

Deployment of agent is not a

Deployment of agent is not a problem. It is the GUI on the BE server  which has problems.

Is there any .net related

Is there any .net related error in the event log? What version of .net are you running on the server?

Is the server in question

Is the server in question configured in Languages other than English?

I have the same problems with

I have the same problems with BE 2012 on German Windows with English SQL Express Edition.

Support won´t be able help you, they won´t answer any formal support requests...

I would recommend to swich back to 2010 till the first Service Pack is released...

This is a mess. I just

This is a mess. I just reinstalled the BE on new server with English US regional settings (in initial installation it was Croatian) , but no result.

@JurgenB .Thanks for replay. We have sold the licneces to the customer for 2012 so there is no way that we go with 2010.

The weird thing is that i have done a big implementation of BE 2012 2 weeks ago and all went fine. Maybe because the upgrade was in question not a clean install.  Whatever the case, it is insane that the clean install of the software on clean supported OS does not work out of the box.

I talked to my reseller a few

I talked to my reseller a few days ago and was told that i have a right to downgrade to 2010 R2.

I have 6 calls open now, not a single reply.angry

I just reinstalled Be 2012 in an US Windows 2008 R2 Std SP1 VLK license
running on Hyper-V R3 and it looks fine.

But my migration was although fine for 5-6 days till monday.
I get problems with this "product" since monday.

We had a switch to summer time and i think the product hasn´t be tested at all for summer time swich ...

I will get a new server box now and will rollout Microsoft Data Protection Manager 2012 RC.
This might even a pain in the ass but what else should i do now?

Symantec isn´t answering calls for 24 hour right now! angry
 

 

Did you tried to use a old

Did you tried to use a old database for backup exec with BE 2012 ? As per the error you posted before ":Invalid column name 'finaljobstatus" it seems the jobstatus table  is missing and you would get this sitiuvation when you use a older version of database or if the database is corrupt.

If you have migrated the database did you use Bemig ? 

Also did you tried reload the backup exec database from base ? Note : when you do this you loose all your configuration and jobs .

I dont think the issue is realted to the langauge , if it would be there would be some conversion related error .

you may raise the severity of you support case so that you get a call as soon as possible .

Accepted Solution!

Ok.. Solved. The SQL express

Ok.. Solved.

The SQL express database which BE installs (and any other) inherits collation settings from Language for non-Unicode programs setting (http://msdn.microsoft.com/en-us/library/ms143311(v=sql.90).aspx ). Therefore if you have some other regional setting, the SQL express database of BE inherits these setings and the BE 2012 cannot work with "non-standard" collations.

The collation of SQL Express database which i am now using is (English US) so all is OK now.

 

 

Thanks for your replays.

View solution in original post

Thanks for sharing the

Thanks for sharing the solution. Cheers !!

Re: "the query for ResourceContainer failed" BE2012 - Clean Install


I had simlar error:

"An error with the Backup Exec administration console has occurred. The administration console will close when you click OK. To restart the console, click the Backup Exec icon or click Start > All Programs > Veritas Backup Exec.
The query for ResourceContainer failed.
The query for Last7Days failed"

I ran BEutility.exe (avaliable in your Veritas BackupExec folder)  to check database consitency and then compact database followed by another consistency check. After following above steps, error is gone and BE version 16 is working fine on Windows Std Server 2016. 

Here is the link: https://www.veritas.com/support/en_US/article.100020074.html