Highlighted

the infamous ralus agent with lib load errors on SLES

Hi,

 

I installed ralus agent 20.4 on a fresh SLES 15. Install went trhough without error. 

Ran a test backup and that says success on BE Server. 

Yet When I start ralus agent with 

sudo ./beremote --log-console &

I get 

NDMPDMainThreadFunc spawned: grpid=1, tid=-2123458816
 : FS_InitFileSys
 : libbedsnt5.so could not be loaded: 0x 2 (2)
 : libbedssql2.so could not be loaded: 0x 2 (2)
 libbedsxchg.so could not be loaded: 0x 2 (2)
 : libbedsxese.so could not be loaded: 0x 2 (2)
: libbedsmbox.so could not be loaded: 0x 2 (2)
 : libbedspush.so could not be loaded: 0x 2 (2)
: libbedsmdoc.so could not be loaded: 0x 2 (2)
: libbedssps2.so could not be loaded: 0x 2 (2)
 : libbedssps3.so could not be loaded: 0x 2 (2)
: libbedsupfs.so could not be loaded: 0x 2 (2)
: libbedsshadow.so could not be loaded: 0x 2 (2)
: libbedsoffhost.so could not be loaded: 0x 2 (2)
: loaded libbedsvx.so

Do these have to be loaded for ralus to work properly ?

I searched and found quite a few fellow-ralus-experimenters with the same log entries but I havent found anyone who successfully got rid of them.

then further down:

libbedssmsp.so loaded at index 11
libbedsra.so could not be loaded: 0x       2 (2)
libbedsdb2.so could not be loaded: 0x       2 (2)
libbedsvmesx.so could not be loaded: 0x       2 (2)
Initializing FSs
FS 1 failed to initialize: 0xE000FE46

Do I need the FS 1 initialized for ralus to work properly?

Oh and Veritas engineers, could you consider compiling ralus for more linux distros ?

thanks

chris

Tags (2)
1 Reply

Re: the infamous ralus agent with lib load errors on SLES

@buschi 

I have tried to find OS requirements in the BE docs - 

SCL merely says this as a footnote under list of supported SUSE versions:

7. The Remote Agent for Linux Servers (RALUS) does not support SUSE servers that have been installed using the 'minimal' installation option.

There's nothing whatsoever about Linux in Readme/Release Notes .

In BE 20.4 Admin Guide:

Requirements for the Agent for Linux
The following items are required to install the Agent for Linux (Linux Agent):
■ The Backup Exec server must have TCP/IP installed.
■ The Linux server must have Perl 5.8.8 or later installed.
■ You must have a root logon account on the Linux servers.
■ You must have the Backup Exec installation media.
■ You must enter a license for the Linux Agent on the Backup Exec server.

Not sure if any of the above helps?
Your other option would be to log a Support call...