Highlighted

Snapshots failing since 9/15/18

When I noticed the system had stopped, I updated Cloudpoint. I am using Ubuntu VM on GCE with Docker 18.x and Cloudpoint 2.1.1.7647 as of 9/21. 

All snapshots are on GCP in the same project as the Cloudpoint instance.

Cloudpoint is using the free license and shows 1.19TB of 10TB used.

All the instances are shown after entering the project credentials.

I am using the same credentials from when it worked and now.

I haven't used Linux in a decade and a lot has changed, but I was able to get around a little using what I remember and some help from Google searches but a deep dive into Docker and Cloudpoint logs is pretty tough.

While I am using free at this point, if the product works and continues to work, as we expand our project, the 10TB limit will be reached and at that time we would purchase the license.

I thought about resetting the system and re entering the settings, but didn't find info on how to reset. Don't want to delete the instance and rebuild from scratch if possible and besides, I need a system that does not require that much labor on.

Any help would be appreciated. See the log info below.

Thank you, William

At this time, when I look in the flexsnap-coordinator.log, I see job failed messages like this:

WARNING - license_mark: devices not found while FETB update for asset google-gce-us-central1-b-8596561531196832042

ERROR - run: failed to load flow None (license_mark: invalid scenario for asset google-gce-us-central1-b-8596561531196832042)

Sep 22 08:00:00 afbc558ff357 flexsnap-coordinator[1] Thread-7947 flexsnap.coordinator: ERROR - Group snapshot failed with exception license_mark: invalid scenario for asset google-gce-us-central1-b-8596561531196832042

Traceback (most recent call last):

  File "/opt/VRTScloudpoint/lib/flexsnap/coordinator.py", line 6151, in create_group_snapshot

    task_id = runner.run()

  File "/opt/VRTScloudpoint/lib/flexsnap/workflow.py", line 588, in run

    book=book)

  File "/usr/local/lib/python2.7/dist-packages/taskflow/engines/helpers.py", line 229, in load_from_factory

    flow = factory_fun(*factory_args, **factory_kwargs)

  File "/opt/VRTScloudpoint/lib/flexsnap/coordinator.py", line 6307, in group_snapshot_factory

    save_result=False)

  File "/opt/VRTScloudpoint/lib/flexsnap/coordinator.py", line 6522, in create_asset_snap_flow

    snap_params=tmp_params)

  File "/opt/VRTScloudpoint/lib/flexsnap/coordinator.py", line 2228, in create_snapshot

    self.db.svc.license_mark(self.objid)

  File "/opt/VRTScloudpoint/lib/flexsnap/coordinator.py", line 4168, in license_mark

    "for asset %s" % asset_id)

GenericError: license_mark: invalid scenario for asset google-gce-us-central1-b-8596561531196832042

Sep 22 08:00:00 afbc558ff357 flexsnap-coordinator[1] Thread-7947 flexsnap.connectors.base: ERROR - Request failed unexpectedly

Traceback (most recent call last):

  File "/opt/VRTScloudpoint/lib/flexsnap/connectors/base.py", line 109, in run

    func(self, user_id, **converted_values)

  File "/opt/VRTScloudpoint/bin/flexsnap-coordinator.py", line 694, in handle_group_create_snapshot

    repl_pol_rules)

  File "/opt/VRTScloudpoint/lib/flexsnap/coordinator.py", line 6151, in create_group_snapshot

    task_id = runner.run()

  File "/opt/VRTScloudpoint/lib/flexsnap/workflow.py", line 588, in run

    book=book)

  File "/usr/local/lib/python2.7/dist-packages/taskflow/engines/helpers.py", line 229, in load_from_factory

    flow = factory_fun(*factory_args, **factory_kwargs)

  File "/opt/VRTScloudpoint/lib/flexsnap/coordinator.py", line 6307, in group_snapshot_factory

    save_result=False)

  File "/opt/VRTScloudpoint/lib/flexsnap/coordinator.py", line 6522, in create_asset_snap_flow

    snap_params=tmp_params)

  File "/opt/VRTScloudpoint/lib/flexsnap/coordinator.py", line 2228, in create_snapshot

    self.db.svc.license_mark(self.objid)

  File "/opt/VRTScloudpoint/lib/flexsnap/coordinator.py", line 4168, in license_mark

    "for asset %s" % asset_id)

GenericError: license_mark: invalid scenario for asset google-gce-us-central1-b-8596561531196832042

2 Replies
Highlighted

Re: Snapshots failing since 9/15/18

So, we purchased a license to get access to support since no response from the community. Surprise, once license installed, all issues dissappeared. It appears that with freemium license that it stopped working because we had 11 instances in the project even if we were making backups of only 9 via policies. Currently we are still making snapshots of 9 machines but it is working now.

Highlighted

Re: Snapshots failing since 9/15/18

Hi William,

This is a known issue for a GCP instance with only boot disk attached and this is been fixed in our next release(2.1.2) to be released in november.
but for now we can attach 1 more disk along with the boot disk(while taking instance snapshot with only boot disk attached) so that the check won't fail for GCP Instance Snapshot.