CP server version for 2 differents SFHA version

Hello,

I've got 2 clusters under RHEL6.3 using SFHA 6.0.30

they are connected to a Cordinate Point server 6.0.30

I want to install 2 new clusters under RHEL6.6 using SFHA 6.2.1

My questions :

Can my 4 clusters uses the sames CP server ?

If yes, do I need to upgrade the CP server ? in which version ?

 

thanks

Cedric

1 Solution

Accepted Solutions
Highlighted
Accepted Solution!

Steps are: Upgrade 6.0 CPS

Steps are:

  1. Upgrade 6.0 CPS to 6.1
  2. Upgrade 6.0 VCS application clusters to 6.1
  3. Install 6.2 cluster which supports 6.1 CPS

1 and 2 are due to:

If you want to upgrade application clusters that use CP server based
fencing to 6.1, make sure that you first upgrade VCS or SFHA on the CP server
systems

 

View solution in original post

6 Replies
Highlighted

Yes all 4 clusters can use

Yes all 4 clusters can use the same CP and yes you need to upgrade CP server to 6.1 - see extract from VCS install guides:

See extracts below:

6.0:

CP server requirements
VCS 6.0 clusters (application clusters) support coordination point servers (CP
servers) which are hosted on the following VCS and SFHA versions:

  • CS 6.0, 5.1SP1, or 5.1 single-node cluster
    Single-node VCS clusters with VCS 5.1 SP1 RP1 and later or VCS 6.0 and later that hosts CP server does not require LLT and GAB to be configured.
  • SFHA 6.0, 5.1SP1, or 5.1 cluster

Warning: Before you upgrade 5.1 CP server nodes to use VCS or SFHA 6.0, you
must upgrade all the application clusters that use this CP server to version 6.0.
Application clusters at version 5.1 cannot communicate with CP server that runs
VCS or SFHA 5.1 SP1 or later.

 

6.1:

CP server requirements
VCS 6.1 clusters (application clusters) support coordination point servers (CP
servers) which are hosted on the following VCS and SFHA versions:

  • VCS 6.1 single-node cluster
    Single-node VCS clusters that hosts CP server requires you to configure LL and GAB.
  • SFHA 6.1 cluster

Warning: If you want to upgrade application clusters that use CP server based
fencing to 6.1, make sure that you first upgrade VCS or SFHA on the CP server
systems. Then, upgrade all application clusters to version 6.1. However, note that
the CP server upgraded to 6.1 can support application clusters on 6.1 (HTTPS-based
communication) and application clusters prior to 6.1 (IPM-based communication).
When you configure the CP server, the installer asks the VIPs for HTTPS-based
communication (if the clients are on release version 6.1) or VIPs for IPM-based
communication (if the clients are on a release version prior to 6.1).

 

6.2

CP server requirements
VCS 6.2 clusters (application clusters) support coordination point servers (CP
servers) that are hosted on the following VCS and SFHA versions:

  • VCS 6.1 or later single-node cluster
  • SFHA 6.1 or later cluster

Upgrade considerations for CP servers

  • Upgrade VCS or SFHA on CP servers to version 6.2 if the current release version is prior to version 6.1.
  • You do not need to upgrade CP servers to version 6.2 if the release version is 6.1.

 

So in summary the above means:
 

6.0 – Application cluster can be higher – i.e – VCS 6.0 can communicate with CPS 5.1 (but NOT vice versa so CPS 6.0 can NOT communicate with VCS 5.1

6.1 – CPS can be higher i.e – CPS 6.1 can communicate with VCS 6.0 (NOT vice versa)

6.2 – CPS can be higher i.e – CPS 6.2 can communicate with VCS 6.1

 

So you need to upgrade CP server to 6.1 first which will be supported by your 6.0 cluster and you need to use IPM-based communication

Then you can install 6.2 cluster and this support 6.1 CPS  

Mike

Highlighted

thanks for this answer, I'll

thanks for this answer, I'll upgrade my CP server next week.

have a good day.

 

Cedric.

Highlighted

hello,  you said : Warning:

hello, 

you said :

Warning: If you want to upgrade application clusters that use CP server based
fencing to 6.1, make sure that you first upgrade VCS or SFHA on the CP server
systems. Then, upgrade all application clusters to version 6.1

And in vcs_install_61_lin.pdf 

Upgrading VCS using the script-based installer

9 If you want to upgrade CP server systems that use VCS or SFHA to VCS 6.1, make sure that you first upgrade all application clusters to version VCS 6.1. Then, upgrade VCS or SFHA on the CP server systems

 

I'm a bit lost (again !! )

cp server first or application cluster first ??? 

thanks to help me to find my way ...

Highlighted
Accepted Solution!

Steps are: Upgrade 6.0 CPS

Steps are:

  1. Upgrade 6.0 CPS to 6.1
  2. Upgrade 6.0 VCS application clusters to 6.1
  3. Install 6.2 cluster which supports 6.1 CPS

1 and 2 are due to:

If you want to upgrade application clusters that use CP server based
fencing to 6.1, make sure that you first upgrade VCS or SFHA on the CP server
systems

 

View solution in original post

Highlighted

Thanks. I've upgrade CPS to

Thanks.

I've upgrade CPS to 6.1

We did not plan to upgrade application cluster to 6.1 (we do not have licences for 6.1, and did not plan down time for applications servers on 6.0).

Can we stay with :

3 applications clusters on 6.0

CP servers on 6.1

2 applications clusters on 6.2  ?

 

Highlighted

I guess this should be ok as

I guess this should be ok as in the extract from the 6.0 manual in my first comment it says:

Then, upgrade all application clusters to version 6.1. However, note that
the CP server upgraded to 6.1 can support application clusters on 6.1 (HTTPS-based
communication) and application clusters prior to 6.1 (IPM-based communication).

 

As above, you will need to use IPM-based communication for CP communication.

Mike