cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted

SF in installed. Now VCS is not able to install

Environment

OS = rhel 5.6

SFHA = 6.1

Query

SF is installed and volumes are created, mounted (mentioned in the below detail). Now I need to install VCS as well. When I am going to install VCS. It giving me the below error.

Symantec Product                     Version Installed on COMUTER1    Licensed
================================================================================
Veritas File System                                 6.1.1.100          yes
Symantec Dynamic Multi-Pathing                      6.1.1.000          yes
Veritas Volume Manager                              6.1.1.000          yes
Symantec Cluster Server                             none               no
Symantec ApplicationHA                              none               no
Symantec Storage Foundation                         6.1.1.000          yes
Symantec Storage Foundation and High Availability   none               no
Symantec Storage Foundation Cluster File System HA  none               no
Symantec Storage Foundation for Oracle RAC          none               no

Task Menu:

    P) Perform a Pre-Installation Check     I) Install a Product
    C) Configure an Installed Product       G) Upgrade a Product
    O) Perform a Post-Installation Check    U) Uninstall a Product
    L) License a Product                    S) Start a Product
    D) View Product Descriptions            X) Stop a Product
    R) View Product Requirements            ?) Help

Enter a Task: [P,I,C,G,O,U,L,S,D,X,R,?]

 

ERROR

     1)  Symantec Dynamic Multi-Pathing (DMP)
     2)  Symantec Cluster Server (VCS)
     3)  Symantec Storage Foundation (SF)
     4)  Symantec Storage Foundation and High Availability (SFHA)
     5)  Symantec Storage Foundation Cluster File System HA (SFCFSHA)
     6)  Symantec Storage Foundation for Oracle RAC (SF Oracle RAC)
     7)  Symantec ApplicationHA (ApplicationHA)
     b)  Back to previous menu

Select a product to install: [1-7,b,q] 2

Logs are being written to /var/tmp/installer-201601271523BCo while installer is in progress

    Verifying systems: 100%                                                                                                                    

    Estimated time remaining: (mm:ss) 0:00                                                                                              8 of 8

    Checking system communication ....................................................................................................... Done
    Checking release compatibility ...................................................................................................... Done
    Checking installed product .......................................................................................................... Done
    Checking prerequisite patches and rpms .............................................................................................. Done
    Checking platform version ........................................................................................................... Done
    Checking file system free space ..................................................................................................... Done
    Checking product licensing .......................................................................................................... Done
    Performing product prechecks ........................................................................................................ Done

System verification checks completed

The following errors were discovered on the systems:

CPI ERROR V-9-30-1307 A more recent version of SF, 6.1.1.000, is already installed on COMPUTER1

installer log files and summary file are saved at:

    /opt/VRTS/install/logs/installer-201601271523BCo

Would you like to view the summary file? [y,n,q] (n)

 

 

 

 

 

1 Solution

Accepted Solutions
Highlighted
Accepted Solution!

First insure the rpms in the

First insure the rpms in the "rpms" directory in the installation media contains the same version for exisiting VRTS rpms you have installed (rpm -aq | grep VRTS).  If they are the same versions, then cd into "cluster_server" directory in installation media and run installvcs with -minpkgs, -recpkgs or -allpkgs depending on your requirements.

Compare this list of rpms with those installed  (rpm -aq  | grep VRTS) and install the difference.

Example:

[root@r55v61b cluster_server]# ./installvcs -minpkgs
VCS: PKGS: VRTSperl VRTSvlic VRTSllt VRTSgab VRTSvxfen VRTSamf VRTSvcs VRTSvcsag VRTSsfmh VRTSvcswiz VRTSsfcpi61 
 

Here where SF is already installed, this means:

VRTSperl, VRTSvlic, VRTSsfmh, VRTSsfcpi61 i

s already installed so then run use "rpm -i" to install:

VRTSllt VRTSgab VRTSvxfen VRTSamf VRTSvcs VRTSvcsag VRTSvcswiz

You can then run "installvcs -configure" if you want to configure cluster

Mike

View solution in original post

3 Replies
Highlighted

Re: SF in installed. Now VCS is not able to install

Hi, Seems it's a CPI issue.

 

As a workaround, suggest you 

try:  

  1. uninstall Sf,  install SFHA directly.

  2.On the installation media,  cd down to the cluster_server directory and run the ./installvcs script to see if it gives you the same error?

The incident concludes "or else customer will have to go with manual installation..."

Highlighted

Re: SF in installed. Now VCS is not able to install

Or

 

run /installvcs and not the full installer.

Highlighted
Accepted Solution!

First insure the rpms in the

First insure the rpms in the "rpms" directory in the installation media contains the same version for exisiting VRTS rpms you have installed (rpm -aq | grep VRTS).  If they are the same versions, then cd into "cluster_server" directory in installation media and run installvcs with -minpkgs, -recpkgs or -allpkgs depending on your requirements.

Compare this list of rpms with those installed  (rpm -aq  | grep VRTS) and install the difference.

Example:

[root@r55v61b cluster_server]# ./installvcs -minpkgs
VCS: PKGS: VRTSperl VRTSvlic VRTSllt VRTSgab VRTSvxfen VRTSamf VRTSvcs VRTSvcsag VRTSsfmh VRTSvcswiz VRTSsfcpi61 
 

Here where SF is already installed, this means:

VRTSperl, VRTSvlic, VRTSsfmh, VRTSsfcpi61 i

s already installed so then run use "rpm -i" to install:

VRTSllt VRTSgab VRTSvxfen VRTSamf VRTSvcs VRTSvcsag VRTSvcswiz

You can then run "installvcs -configure" if you want to configure cluster

Mike

View solution in original post