cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted

Unable to bring the Service Group online.

Hi All,

I tried to bring a SG online in a node but it's not comming online. Let me explaing the issue.

 

We did reboot of a node aixprd001 and we found that /etc/filesystem is corrupted so the SG bosinit_SG is in partial state since lot of cluster FS in not mounted.

Then we corrected the entry and done the manual mout of all the FS but the SG still show the status partial so we did the bellow command.

hagrp -clear bosinit_SG -all

Once done the SG is in online state.

 

For safer side we tried to offline the SG and brought it up online again but the SG failed to come online, Bellow is the only error we able find the engine_A.log file.

 

2014/12/17 06:49:04 VCS NOTICE V-16-1-10166 Initiating manual online of group bosinit_SG on system aixprd001
2014/12/17 06:49:04 VCS NOTICE V-16-1-10233 Clearing Restart attribute for group bosinit_SG on all nodes

 

Please help me by providing suggestion, I will provide the output of logs if needed.

 

Thanks,

Rufus


 

1 Solution

Accepted Solutions
Highlighted
Accepted Solution!

Hello, there should be more

Hello,

there should be more in engine_A.log, please attach log for this event ..

Also, is there a preonline trigger for this group ? If yes, check the trigger as well.

 

G

View solution in original post

4 Replies
Highlighted
Accepted Solution!

Hello, there should be more

Hello,

there should be more in engine_A.log, please attach log for this event ..

Also, is there a preonline trigger for this group ? If yes, check the trigger as well.

 

G

View solution in original post

Highlighted

Hi Gaurav, engine_A.log is

Hi Gaurav,

 

engine_A.log is not having any more information, even hastatus -sum command is not showing that any resourse is trying to come online, It's just showing that SG is offline in all nodes, I will paste the output of hastatus -sum command soon.

I will check and let you know soon.

 

Thanks,

Rufus

 

Highlighted

Hi, Rufus  Please help get

Hi, Rufus

 Please help get following output on both vcs nodes:

 

    1. hastatus -sum

    2.df -k

    3. cat /var/VRTSvcs/log/engine_A.log

   4. cat  /etc/VRTSvcs/conf/config/main.cf

   5. ps -ef|grep -i had

   6. errpt -a

   7.vxprint -ht

  Seems vcs work abnormal.

 

 Regards

 

 

Highlighted

Thanks for your replay

Thanks for your replay Starflyfly,

 

Actually I found the solution yesterday,

 

In our environment there is a pre-online script will be running which will adjust the system memory and process to the desired value which is required the SG to be online in the node,

In this case the HMC is rebooted and the ssh key which use to connect to the HMC as password less authentication is failed since the key is changed,

Hence there is not log in the engine_A.log because all log is capture in the file which is mentioned in the pre online script.

Now we corrected the ssh key entry in the server and everything looks good. Thanks for all your support Smiley Happy

Learning new things everyday Smiley Happy

Thanks to all.

 

Regards,

Rufus.