cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted

Unable to install cpi-Patch-6.1.0.600 cpi-Patch-6.1.1.500

ENVIRONMENT
 
OS = Redhat 5.9 (64bit)
SFHA = 6.1
Total cluster nodes = 2
 
QUERY
 
There are following 7 patches for SFHA 6.1
 
vm-rhel5_x86_64-Patch-6.1.1.400
cpi-Patch-6.1.0.600
cpi-Patch-6.1.1.500
gab-rhel5_x86_64-Patch-6.1.0.100
fs-rhel5_x86_64-6.1.1.100
fsadv-rhel5_x86_64-6.1.1.100
sfha-rhel5_x86_64-6.1.1
 
I am able to install 4 patches. However I am unable to install following 3 patches from the above 7
 
cpi-Patch-6.1.0.600
cpi-Patch-6.1.1.500
gab-rhel5_x86_64-Patch-6.1.0.100
 
DETAILS / ERROR WHILE INSTALLING PATCHES
 
# ls -l
total 28
drwxr-xr-x 3 root root 4096 May  1 13:52 cpi-Patch-6.1.0.600
drwxr-xr-x 3 root root 4096 May  1 14:21 cpi-Patch-6.1.1.500
drwxr-xr-x 4 root root 4096 May  1 14:16 fsadv-rhel5_x86_64-6.1.1.100-rpms
drwxr-xr-x 4 root root 4096 May  1 14:12 fs-rhel5_x86_64-6.1.1.100-rpms
drwxr-xr-x 4 root root 4096 May  1 14:10 gab-rhel5_x86_64-Patch-6.1.0.100
drwxr-xr-x 3 root root 4096 May  1 13:22 sfha-rhel5_x86_64-6.1.1
drwxr-xr-x 4 root root 4096 May  1 13:58 vm-rhel5_x86_64-Patch-6.1.1.400
# cd cpi-Patch-6.1.0.600/
ls -l
total 44
-rw-r--r-- 1 root root 26585 Apr 28 12:40 cpi-Patch-6.1.0.600.tar.gz
-rw-r--r-- 1 root root   200 Apr 28 12:40 New Text Document.txt
drwxrwxr-x 2 root root  4096 May  1 13:53 patches
-rw-r--r-- 1 root root  7568 Mar  7 09:05 README
# cd patches/
# ls -l
total 132
-rwxr-xr-x 1 root root 128850 Mar  5 07:55 CPI_6.1.0_P6.pl
-rw-r--r-- 1 root root      0 May  1 14:31 glibc-2.12-1.80.el6.i686,?
-rw-r--r-- 1 root root      0 May  1 14:31 glibc-2.12-1.80.el6.x86_64,?
-rw-r--r-- 1 root root      0 May  1 14:31 {hfvers}=6.1.1.100
-rw-r--r-- 1 root root      0 May  1 14:31 {oslibs}{RHEL6.3}={?
# ./CPI_6.1.0_P6.pl
./CPI_6.1.0_P6.pl: line 1: package: command not found
: command not foundline 1:
: command not foundline 2:
./CPI_6.1.0_P6.pl: line 3: sub: command not found
./CPI_6.1.0_P6.pl: line 4: my: command not found
: command not foundline 4:
./CPI_6.1.0_P6.pl: line 5: -: command not found
: command not foundline 5:
./CPI_6.1.0_P6.pl: line 6: -: command not found
./CPI_6.1.0_P6.pl: line 7: libc.so.6: command not found
./CPI_6.1.0_P6.pl: line 8: libc.so.6()(64bit): command not found
./CPI_6.1.0_P6.pl: line 9: libc.so.6(GLIBC_2.0): command not found
./CPI_6.1.0_P6.pl: line 10: libc.so.6(GLIBC_2.1): command not found
./CPI_6.1.0_P6.pl: line 11: libc.so.6(GLIBC_2.1.3): command not found
./CPI_6.1.0_P6.pl: line 12: libc.so.6(GLIBC_2.2.5)(64bit): command not found
./CPI_6.1.0_P6.pl: line 13: libc.so.6(GLIBC_2.3): command not found
./CPI_6.1.0_P6.pl: line 14: libc.so.6(GLIBC_2.7): command not found
./CPI_6.1.0_P6.pl: line 15: libnsl.so.1: command not found
./CPI_6.1.0_P6.pl: line 16: rtld(GNU_HASH): command not found
./CPI_6.1.0_P6.pl: line 17: syntax error near unexpected token `}'
'/CPI_6.1.0_P6.pl: line 17: `    };
 
 
 
 
 
 
1 Reply
Highlighted

PROBLEM IS RESOLVED -   

PROBLEM IS RESOLVED

-    cpi-Patch-6.1.0.600 has a product Id 3542842 which is covered in cpi-Patch-6.1.1.500  (SUMMARY OF INCIDENTS FIXED BY THE PATCH SECTION> 3542842 )

-    gab-rhel5_x86_64-Patch-6.1.0.100  patch is not required on the installed version of SFHA as per the below error

Logs are being written to /var/tmp/installVRTSgab610HF100-201605021311VkU while installVRTSgab610HF100 is in progress

    Verifying systems: 37%                                                    ______________________________________________________________________________________

    Estimated time remaining: (mm:ss) 0:25                                                                                                                    3 of 8

    Checking system communication ............................................................................................................................. Done
    Checking release compatibility ............................................................................................................................ Done
    Checking installed product ................................................................................................................................ Done

System verification checks completed

The following errors were discovered on the systems:

CPI ERROR V-9-0-0 SFHA 6.1.0 does not appear to be installed on Server01

CPI ERROR V-9-0-0 SFHA 6.1.0 does not appear to be installed on Server02

 

Now we only need to install cpi-Patch-6.1.1.500. As per the documentation, the command to install  cpi-Patch-6.1.1.500 patch is ./installmr -require /tmp/CPI_6.1.1_P5.pl. and installmr path will be drived from unziping of sfha-rhel5_x86_64-6.1.1