resource

hi,

i have 2 node in vcs.

if i start the had in node test9 and i issue haclus -display i can see that the cluster is running then hares -state will show all resources offline.is this because the other node test5 in still down in vcs so the resources are not probed on all nodes?

why the haclus -state show cluster running if there only on a node i started hastart the other node is in unknown?

why hasys -state show node unknown on node where vcs is not started?

test9->hastart

test9->hasys -state
#System Attribute Value
test5 SysState UNKNOWN
test9 SysState RUNNING

haclus -state
#Cluster Attribute Value
clust ClusState RUNNING

 

4 Replies

Re: resource

Hi.

A cluster is "RUNNING" if at least one node in the cluster has all VCS releated modules loaded and processes started.

I like to use:

# hastatus -sum

to see the state of nodes, service groups, and resources.

In general, "ha" commands  execute against/run on all nodes that are configured in the cluster.  If communications are lost, or processes are not started, then you see the status of "UNKNOWN".

 

Once you run "hastart -local" on node test5, assuming it can communicate over LLT and GAB, then its status will change.

 

Hope that helps.

Cheers

My customers spend the weekends at home with family, not in the datacenter.

Re: resource

if i start the had in node test9 and i issue haclus -display i can see that the cluster is running then hares -state will show all resources offline.is this because the other node test5 in still down in vcs so the resources are not probed on all nodes?

Re: resource

Please see my auswers/comments in line starting with "<<<" below

>if i start the had in node test9 and i issue haclus -display i can see that the cluster is running then hares -state will show all resources offline.is this because the other node test5 in still down in vcs so the resources are not probed on all nodes?

<<< if one of the nodes is not in running state, the service group on the node will be marked as "auto-disable" so all the resoruces in a disabled service group will not be brought up online during cluster or node start up. There are two things you can do in order to bring up the resources.

 

1. start up had of all the nodes 

or

2. turn the service group autodisable flag off by running the command

hagrp -autoenable group -sys system

once the service group auto-disable flag is turned off, you can online the service group by running

hagrp -online

or

hares -online res_name -sys node_name

 

to find out if a service grouop has auto-disabled flag tuned on, run

hastatus -sum

 

Highlighted

Re: resource

Agree with previous comments, just by haclus -display you won't know the full picture.

The service group you are talking about, what is the characteristics for that ? is it a parallel SG or no, which node is primary to bring that SG ? Also read the autodisable statement in previous comment ..