cancel
Showing results for 
Search instead for 
Did you mean: 

DLO 7.5 fresh install, but does not create DLO instance

Hello..

 

We have installed DLO 7.5 on an old test server which is running BE 2012...

 

DLO setup was successfull, was unable to launch the administration console..Also noticed that DLO setup did not create a SQL 2008 instance..

I do not see a DLO database on the backup exec instance..

 

i've created a instance and attached the database from the data folder, but recive the below error:

"symantec DLO administration service on the local computer started and then stoped, some service stopped automatically if they are not ins use by another service or program.."

 

Event viewer:

Error 2/9/2014 3:34:41 PM DLOAdminSvcu 50040 None

 
Log Name:      Application
Source:        DLOAdminSvcu
Date:          2/9/2014 3:34:41 PM
Event ID:      50040
Task Category: None
Level:         Error
Keywords:      Classic
User:          N/A
Computer:      2012CASO
Description:
The description for Event ID 50040 from source DLOAdminSvcu cannot be found. Either the component that raises this event is not installed on your local computer or the installation is corrupted. You can install or repair the component on the local computer.
 
If the event originated on another computer, the display information had to be saved with the event.
 
The following information was included with the event: 
 
275
shadow\Server\consolesvc\consolesvc.cpp
ADODBError-_com_error: foundationerror=cc000064, comerr=80004005, nativeerror=17, conn=Provider=SQLOLEDB;Data Source=2012CASO\DLO;Initial Catalog=master;Integrated Security=SSPI;Connect Timeout=120, query=, msg=Unspecified error, src=Microsoft OLE DB Provider for SQL Server, desc=[DBNETLIB][ConnectionOpen (Connect()).]SQL Server does not exist or access denied.
 
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
  <System>
    <Provider Name="DLOAdminSvcu" />
    <EventID Qualifiers="49152">50040</EventID>
    <Level>2</Level>
    <Task>0</Task>
    <Keywords>0x80000000000000</Keywords>
    <TimeCreated SystemTime="2014-02-09T10:04:41.000Z" />
    <EventRecordID>2854</EventRecordID>
    <Channel>Application</Channel>
    <Computer>2012CASO.nik.com</Computer>
    <Security />
  </System>
  <EventData>
    <Data>275</Data>
    <Data>shadow\Server\consolesvc\consolesvc.cpp</Data>
    <Data>ADODBError-_com_error: foundationerror=cc000064, comerr=80004005, nativeerror=17, conn=Provider=SQLOLEDB;Data Source=2012CASO\DLO;Initial Catalog=master;Integrated Security=SSPI;Connect Timeout=120, query=, msg=Unspecified error, src=Microsoft OLE DB Provider for SQL Server, desc=[DBNETLIB][ConnectionOpen (Connect()).]SQL Server does not exist or access denied.</Data>
  </EventData>
</Event>

Help?

3 Replies

Hi, Please raise a formal

Hi,

Please raise a formal support case by attaching all logs form the server machine where it failed to create the SQL instance.

As of now just update the following registry entries and a file with proper SQL server details:

HKEY_LOCAL_MACHINE\SOFTWARE\Symantec\Symantec DLO\AdminService\DBInstance
HKEY_LOCAL_MACHINE\SOFTWARE\Symantec\Symantec DLO\AdminService\DBServer
HKEY_LOCAL_MACHINE\SOFTWARE\Symantec\Symantec DLO\DB\DBServer
HKEY_LOCAL_MACHINE\SOFTWARE\Symantec\Symantec DLO\DB\DBInstance
HKEY_LOCAL_MACHINE\SOFTWARE\Symantec\Symantec DLO\DB\DedupeDBInstance.

Note: Before modifying any registries take a backup of registry entries by exporting them.

Modify the setup.ini file present in the install path of server(<Install Path of Server>\DLOAgent) with proper SQL server details as shown in the attached image(Setup.png).

Note: Before modifying take a backup of the setup.ini file.

Modify the context.xml file present in the install path of server (<Install Path of Server>\Dedupe\Tomcat\webapps\DedupeServer\META-INF) with proper SQL server details(Where Dedupe database is connected) as shown in attaced image(Config.png).

Note:  Before modifying take a backup of the context.xml file.

After modifying above entries restart the DLO services and launch the console.

Thanks,
Santosh.

Similar probem here .....with

Similar probem here .....with a longer and more complicated history:

We have changed name and domain of the server running BE2012 and DLO 7.5. I have managed to repair BE2012, but did not manage to repair DLO 7.5. So, we decided to uninstall DLO, and install it from scratch.

After DLO removal BE2012 stopped working, and the nightmare begins. we were not able to repair it or unistall it. To keep the long story short - we ended up manualy cleaning the registry to get to the point where we were able to install BE2012 from scratch.

Having BE2012 back in business, we decided that it is high time to install DLO 7.5 too. The installation was "successful", but the SQL instance was in fact not created, and we have exactly the same problems as nik263.

I have checked all files specified by Santosh and everything seems to be OK, but services still won't start and we don't see the DLO database instance running in Services.

Santosh, your text is mainly focused to check if registry entries address the right DB instance. Our problem is that this instance is not started. There seems to be some problem with OLEDB provider.

BR,

Ivo

Dear all, After reading a

Dear all,

After reading a number of mediocre "solutions" like TECH205308 in which we are to fix the instance of SQL which is not there to begin with, we finally found a solution in following:

http://social.msdn.microsoft.com/Forums/sqlserver/en-US/89eb8038-68a6-4201-a784-aa0063f4d8c0/msigetp...

I have uninstalled the failed "successfull" installation of DLO, modified the registry as described in link, rebooted, and managed to install DLO.

BR,

Ivo