cancel
Showing results for 
Search instead for 
Did you mean: 

DLO DEDUPE problem with configuration

GROSA
Level 3

Hello

I installed DLO 7.5 and I cant configure Dedupe server. When I enter port numbers (i'm using wizard) and click next, the DLO Console hangs out.

DLO should use my MS SQL Express R2 database. For test I installed DLO with its MS SQL Express and with this configuration i can configure dedupe. But with my database i cant.

Ports 8080 and 8443 are opened. I'm using WIndows Server 2008 R2.

Any idea how to force DLO to work with my database server?

 

Best Regards

Grzegorz

1 ACCEPTED SOLUTION

Accepted Solutions

VJware
Level 6
Employee Accredited Certified

Are Named Pipes and TCP/IP enabled for SQL remote connections ?
 

View solution in original post

10 REPLIES 10

VJware
Level 6
Employee Accredited Certified

Did you choose the option of existing SQL instance when you configured SDLO for the first time ?

If not, you will have to attach the DLO and DeDupe DBs to your existing instance and also modify certain registry keys/files to update the instance name.

And under what user account are you logged in to the DLO server ? Is this the same account which was used to install DLO and is this the same account used for the SQL / DLO services ?


 

GROSA
Level 3

Yes, I chose the option of existing SQL instance. Does DeDupe need second SQL instance?

I installed DLO as local admin. For other things I use my domain account with admin rights (to run console, SQL/DLO services are using my account).

Now I noticed that i cant stop tomcat service using Services Console. I have to kill the process.

VJware
Level 6
Employee Accredited Certified

No, DeDupe does not require any other instance.

Is the Mindtree Storesmart DeDupe server service running ?

Do ensure the SQL instance, DeDupe and DLO Admin services are running under the same account. Run the following SQL queries via cmd as well so that your domain account has appropriate privileges ~

sqlcmd.exe -E -l 60 -S SERVERNAME\INSTANECENAME -d DedupeDB -Q "EXEC
sp_addsrvrolemember 'DOMAINNAME\USERNAME', 'sysadmin'"

sqlcmd.exe -E -S.\INSTANECENAME -d DedupeDB -Q "insert into
user_info values (5,'DOMAINNAME\USERNAME',NULL,1)"

Lastly, do ensure remote connections are enabled to your SQL instance as well.

GROSA
Level 3

SQL instance, DeDupe and DLO Admin services use the same admin rights.

I have run scripts and still is the same problem.

I found one difference between security configuration DLO database and DedupeDB. Could this be a source of my problems ( I attached print screen from MS SQL Management Studio)?
I tried add entry for domain account for dlo but it didnt help,

VJware
Level 6
Employee Accredited Certified

The second sql query which I mentioned earlier was to add your domain account to the DeDupe DB. Manually, adding the user and providing it appropriate user mapping roles/membership would also help.

Are there any errors/warnings in the event viewer ?

Would recommend to enable debugging as well so that we can try to find out why there is an issue during the DeDupe configuration.

GROSA
Level 3

In event viewer is error:

The description for Event ID 0 from source DLO Admin Console cannot be found. Either the component that raises this event is not installed on your local computer or the installation is corrupted. You can install or repair the component on the local computer.

If the event originated on another computer, the display information had to be saved with the event.

The following information was included with the event:

06/10/2014, 15:31:25:916, 3716, 3720, [Error],"WebServerRequest::RunWebRequest: curl error code = 28; curl error message = Operation timed out after 300688 milliseconds with 0 out of 0 bytes received; Retrying to connect..."

and

06/10/2014, 15:41:27:214, 3716, 3720, [Error],"CRESTHashStoreProxy::HandleCommonServerError/(ERRORLOGGER): Error Code = 23022; Error Message = Could not connect to server host.

WebService API = closeSession; No. of hash = 0; "

and

06/10/2014, 15:41:27:214, 3716, 3720, [Error],"WebServerRequest::RunWebRequest: curl error code = 3; curl error message = <url> malformed"

 

After 10 min of waiting i received error from DLO Console:

The server Host or port details you have entered is invalid or there is no dedupe server running at the specified location

Ports are listening and firewall is turned off

 

 

How can I turn on debugging ?

VJware
Level 6
Employee Accredited Certified

Edit server.xml file located at \Program Files\Symantec\Symantec DLO\Dedupe Server\Tomcat\conf\

Confirm the HTTP & HTTPS port numbers mentioned in this file.

Check the DeDupeserver.log found at :\Program Files\Symantec\Symantec DLO\DedupeServer\Tomcat\logs

Lastly, try this KB as well - http://www.symantec.com/business/support/index?page=content&id=TECH210450

 

GROSA
Level 3

Lines from server.xml:

<Connector acceptorThreadCount="2" connectionTimeout="20000" executor="tomcatThreadPool" port="8080" protocol="org.apache.coyote.http11.Http11NioProtocol" redirectPort="8443" server=" "/>
 

 <Connector SSLEnabled="true" SSLProtocol="TLS" acceptorThreadCount="2" ciphers="TLS_RSA_WITH_AES_128_CBC_SHA,TLS_DHE_RSA_WITH_AES_128_CBC_SHA,TLS_DHE_DSS_WITH_AES_128_CBC_SHA,SSL_RSA_WITH_3DES_EDE_CBC_SHA,SSL_DHE_RSA_WITH_3DES_EDE_CBC_SHA,SSL_DHE_DSS_WITH_3DES_EDE_CBC_SHA" clientAuth="false" executor="tomcatThreadPool" keystoreFile="dedupeserver.jks" keystorePass="dedupeserver" port="8443" protocol="org.apache.coyote.http11.Http11NioProtocol" scheme="https" secure="true" server=" "/>
 

Log from DeDupeserver.log

[11/06/2014], [10:33:57:548], [ERROR], [Thread-4], [localhost], DBConnection::getConnection: org.apache.tomcat.dbcp.dbcp.SQLNestedException: Cannot create PoolableConnectionFactory (The server SDLO is not configured to listen with TCP/IP.)
[11/06/2014], [10:33:57:548], [ERROR], [Thread-4], [localhost], DBConnectionDAO::run: (20002) Could not get database connection. Cannot create PoolableConnectionFactory (The server SDLO is not configured to listen with TCP/IP.)
[11/06/2014], [10:33:57:548], [DEDUPE_TRACE], [Thread-4], [localhost], DBConnectionDAO::run: Connection to the Database failed. Server will retry after 180000 milliseconds.

 

I attached list of opened ports. I can telent to them.

VJware
Level 6
Employee Accredited Certified

Are Named Pipes and TCP/IP enabled for SQL remote connections ?
 

View solution in original post

GROSA
Level 3

TCP/IP was disabled.

I enabled Named Pipes but i didn't noticed that TCP/IP is disabled.

Thank you for help