cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted

Discovery accelerator cannot create Report

Hi,

when i am creating a case report i got the below error, i am using the same ev user for DA server and Client:

System.Web.Services.Protocols.SoapException: An error has occurred during report processing. ---> Microsoft.ReportingServices.ReportProcessing.ProcessingAbortedException: An error has occurred during report processing. ---> Microsoft.ReportingServices.ReportProcessing.ReportProcessingException: Cannot impersonate user for data source 'CustomerDatabase'. ---> Microsoft.ReportingServices.Diagnostics.Utilities.LogonFailedException: Log on failed. Ensure the user name and password are correct. ---> System.ComponentModel.Win32Exception: The user name or password is incorrect
   at Microsoft.ReportingServices.Library.ReportingService2005Impl.CreateItemHistorySnapshot(String Report, Guid batchId, String& HistoryID, Warning[]& Warnings)
   at Microsoft.ReportingServices.WebServer.ReportingService2005.CreateReportHistorySnapshot(String Report, String& HistoryID, Warning[]& Warnings)

 

1 Solution

Accepted Solutions
Highlighted
Accepted Solution!

looks like an issue with the

looks like an issue with the account you use for sql reporting in DA. might be easiest to redeploy the reports or you can start digging around with the accounts, permissions, and databases in sql/srs 

View solution in original post

5 Replies
Highlighted
Accepted Solution!

looks like an issue with the

looks like an issue with the account you use for sql reporting in DA. might be easiest to redeploy the reports or you can start digging around with the accounts, permissions, and databases in sql/srs 

View solution in original post

Highlighted

i recreated the reports but i

i recreated the reports but i got the below 

System.Web.Services.Protocols.SoapException: The current action cannot be completed. The user data source credentials do not meet the requirements to run this report or shared dataset. Either the user data source credentials are not stored in the report server database, or the user data source is configured not to require credentials but the unattended execution account is not specified. ---> Microsoft.ReportingServices.Diagnostics.Utilities.InvalidDataSourceCredentialSettingException: The current action cannot be completed. The user data source credentials do not meet the requirements to run this report or shared dataset. Either the user data source credentials are not stored in the report server database, or the user data source is configured not to require credentials but the unattended execution account is not specified.    at Microsoft.ReportingServices.Library.ReportingService2005Impl.CreateItemHistorySnapshot(String Report, Guid batchId, String& HistoryID, Warning[]& Warnings)    at Microsoft.ReportingServices.WebServer.ReportingService2005.CreateReportHistorySnapshot(String Report, String& HistoryID, Warning[]& Warnings)

Highlighted

You probably didn't configure

You probably didn't configure the dataset's execution account.

Configure the Unattended Execution Account

Check this thread: Error scheduling report

Highlighted

the issue was the reports was

 

the issue was the reports was not uploaded succsessfully, after i upload the reports it wroked fine

Highlighted

ok great so redeploying the

ok great so redeploying the reports was the solution afterall. thanks for the update.